The Linux Kernel Mailing List
 help / color / mirror / Atom feed
 messages from 2007-07-11 23:33:06 to 2007-07-12 05:48:19 UTC [more...]

[PATCH 0/2][RFC] Scheduler preemption hooks, #2
 2007-07-12  5:48 UTC  (8+ messages)
` [PATCH 1/2] SCHED: Generic hooks for trapping task preemption
` [PATCH 2/2] KVM: Use the scheduler preemption hooks to make kvm preemptible
  ` [kvm-devel] "

[PATCH, RESEND] Teach do_mpage_readpage() about unwritten buffers
 2007-07-12  5:39 UTC 

[GIT PULL] KVM Updates for 2.6.23-rc1
 2007-07-12  5:35 UTC  (3+ messages)

[2.6 patch] the scheduled ACPI_PROCFS removal
 2007-07-12  5:32 UTC  (5+ messages)

-mm merge plans for 2.6.23
 2007-07-12  5:39 UTC  (47+ messages)
` containers (was Re: -mm merge plans for 2.6.23)
` lguest, Re: -mm merge plans for 2.6.23
` x86 status was "
` generic clockevents/ (hr)time(r) patches "
      ` [stable] "
` fault vs invalidate race (Re: -mm merge plans for 2.6.23)
  ` block_page_mkwrite? (Re: fault vs invalidate race (Re: -mm merge plans for 2.6.23))

New LSM security operation
 2007-07-12  5:21 UTC 

Forward port of latest RT patch (2.6.21.5-rt20) to 2.6.22 available
 2007-07-12  5:14 UTC  (3+ messages)

[PATCH][RFC] 4K stacks default, not a debug thing any more...?
 2007-07-12  4:59 UTC  (6+ messages)

[EXT4 set 4][PATCH 1/5] i_version:64 bit inode version
 2007-07-12  4:56 UTC  (9+ messages)

[PATCH 7/7] Use --build-id ld option
 2007-07-12  4:48 UTC  (2+ messages)

[PATCH 2 of 2] Make XFS use block_page_mkwrite
 2007-07-12  4:47 UTC 

[PATCH 1 of 2] block_page_mkwrite V2
 2007-07-12  4:45 UTC 

[PATCH, RESEND] Export radix_tree_preload()
 2007-07-12  4:27 UTC 

New LSM security operation
 2007-07-12  3:38 UTC 

sata_sil, writing bug with multiple cards?
 2007-07-12  3:21 UTC  (6+ messages)

[GIT] SELinux changes for 2.6.23 (updated)
 2007-07-12  3:20 UTC 

SATA exceptions
 2007-07-12  3:13 UTC  (4+ messages)

Hibernation Redesign (was: malicious filesystems (was Re: [linux-pm] Re: [PATCH] Remove process freezer from suspend to RAM)
 2007-07-12  3:11 UTC  (7+ messages)
` Hibernation Redesign

[Pcihpd-discuss] [PATCH 26/34] PCI: add pci_try_set_mwi
 2007-07-12  3:12 UTC  (4+ messages)

2.6.22-rc6-mm1 -- BUG - EIP: [<c01a77a1>] sysfs_addrm_finish+0x1c2/0x226 SS:ESP 0068:c5ff9db8
 2007-07-12  3:04 UTC  (11+ messages)

[GIT PATCH] sysfs and driver core patches for 2.6.22
 2007-07-12  3:00 UTC  (68+ messages)
` [PATCH 01/61] Rules on how to use sysfs in userspace programs
  ` [PATCH 02/61] debugfs: add rename for debugfs files
    ` [PATCH 03/61] DMI-based module autoloading
      ` [PATCH 04/61] Driver core: add missing kset uevent
        ` [PATCH 05/61] sysdev: use mutex instead of semaphore
          ` [PATCH 06/61] Power Management: use mutexes instead of semaphores
            ` [PATCH 07/61] PM: Remove pm_parent from struct dev_pm_info
              ` [PATCH 08/61] PM: Remove saved_state "
                ` [PATCH 09/61] PM: Simplify suspend_device
                  ` [PATCH 10/61] Driver core: include linux/mutex.h from attribute_container.c
                    ` [PATCH 11/61] driver core: properly get driver in device_release_driver
                      ` [PATCH 12/61] driver core: fix kernel doc of device_release_driver
                        ` [PATCH 13/61] Driver core: fix devres_release_all() return value
                          ` [PATCH 14/61] PM: Remove prev_state from struct dev_pm_info
                            ` [PATCH 15/61] PM: Remove power_state.event checks from suspend core code
                              ` [PATCH 16/61] PM: Do not check parent state in suspend and resume "
                                ` [PATCH 17/61] PM: do not use saved_state from struct dev_pm_info on ARM
                                  ` [PATCH 18/61] Driver core: coding style cleanup
                                    ` [PATCH 19/61] idr: fix obscure bug in allocation path
                                      ` [PATCH 20/61] idr: separate out idr_mark_full()
                                        ` [PATCH 21/61] ida: implement idr based id allocator
                                          ` [PATCH 22/61] sysfs: move release_sysfs_dirent() to dir.c
                                            ` [PATCH 23/61] sysfs: allocate inode number using ida
                                              ` [PATCH 24/61] sysfs: make sysfs_put() ignore NULL sd
                                                ` [PATCH 25/61] sysfs: fix error handling in binattr write()
                                                  ` [PATCH 26/61] sysfs: flatten cleanup paths in sysfs_add_link() and create_dir()
                                                    ` [PATCH 27/61] sysfs: flatten and fix sysfs_rename_dir() error handling
                                                      ` [PATCH 28/61] sysfs: consolidate sysfs_dirent creation functions
                                                        ` [PATCH 29/61] sysfs: add sysfs_dirent->s_parent
                                                          ` [PATCH 30/61] sysfs: add sysfs_dirent->s_name
                                                            ` [PATCH 31/61] sysfs: make sysfs_dirent->s_element a union
                                                              ` [PATCH 32/61] sysfs: implement kobj_sysfs_assoc_lock
                                                                ` [PATCH 33/61] sysfs: reimplement symlink using sysfs_dirent tree
                                                                  ` [PATCH 34/61] sysfs: implement bin_buffer
                                                                    ` [PATCH 35/61] sysfs: implement sysfs_dirent active reference and immediate disconnect
                                                                      ` [PATCH 36/61] sysfs: kill attribute file orphaning
                                                                        ` [PATCH 37/61] sysfs: separate out sysfs_attach_dentry()
                                                                          ` [PATCH 38/61] sysfs: reimplement sysfs_drop_dentry()
                                                                            ` [PATCH 39/61] sysfs: kill unnecessary attribute->owner
                                                                              ` [PATCH 40/61] driver-core: make devt_attr and uevent_attr static
                                                                                ` [PATCH 41/61] sysfs: make sysfs_alloc_ino() static
                                                                                  ` [PATCH 42/61] sysfs: fix parent refcounting during rename and move
                                                                                    ` [PATCH 43/61] sysfs: reorganize sysfs_new_indoe() and sysfs_create()
                                                                                      ` [PATCH 44/61] sysfs: use iget_locked() instead of new_inode()
                                                                                        ` [PATCH 45/61] sysfs: fix root sysfs_dirent -> root dentry association
                                                                                          ` [PATCH 46/61] sysfs: move s_active functions to fs/sysfs/dir.c
                                                                                            ` [PATCH 47/61] sysfs: slim down sysfs_dirent->s_active
                                                                                              ` [PATCH 48/61] sysfs: use singly-linked list for sysfs_dirent tree
                                                                                                ` [PATCH 49/61] sysfs: Fix oops in sysfs_drop_dentry on x86_64
                                                                                                  ` [PATCH 50/61] sysfs: make sysfs_drop_dentry() access inodes using ilookup()
                                                                                                    ` [PATCH 51/61] sysfs: rename sysfs_dirent->s_type to s_flags and make room for flags
                                                                                                      ` [PATCH 52/61] sysfs: implement SYSFS_FLAG_REMOVED flag
                                                                                                        ` [PATCH 53/61] sysfs: implement sysfs_find_dirent() and sysfs_get_dirent()
                                                                                                          ` [PATCH 54/61] sysfs: make kobj point to sysfs_dirent instead of dentry
                                                                                                            ` [PATCH 55/61] sysfs: consolidate sysfs spinlocks
                                                                                                              ` [PATCH 56/61] sysfs: use sysfs_mutex to protect the sysfs_dirent tree
                                                                                                                ` [PATCH 57/61] sysfs: restructure add/remove paths and fix inode update
                                                                                                                  ` [PATCH 58/61] sysfs: move sysfs_drop_dentry() to dir.c and make it static
                                                                                                                    ` [PATCH 59/61] sysfs: implement sysfs_get_dentry()
                                                                                                                      ` [PATCH 60/61] sysfs: make directory dentries and inodes reclaimable
                                                                                                                        ` [PATCH 61/61] sysfs: add parameter "struct bin_attribute *" in .read/.write methods for sysfs binary attributes

[PATCH 1/5] try parent numa_node at first before using default
 2007-07-12  3:01 UTC  (6+ messages)

[PATCH 6/7] Add /sys/kernel/notes
 2007-07-12  2:41 UTC  (6+ messages)

[PATCH resend] rewrite AF_UNIX garbage collector, fixes race
 2007-07-12  2:29 UTC  (2+ messages)

[PATCH][BUG] Incorrect SCSI transfer length computation from odd sized scsi_execute_async() transfers
 2007-07-12  2:25 UTC  (3+ messages)

!! CORRECTION !! Re: Forward port of latest RT patch (2.6.21.5-rt20) to 2.6.22 available
 2007-07-12  2:25 UTC 

[PATCH] Use BIOS Keyboard variable to set Numlock
 2007-07-12  2:10 UTC  (4+ messages)

[PATCH 0/11] SELinux patches for 2.6.23
 2007-07-12  2:04 UTC  (3+ messages)
` [PATCH 05/11] security: revalidate rw permissions for sys_splice and sys_vmsplice

[PATCH] mkmakefile: include ARCH on O= builds
 2007-07-12  2:00 UTC  (3+ messages)

[GIT PATCH] PCI patches for 2.6.22
 2007-07-12  1:53 UTC  (5+ messages)
          ` [PATCH 05/34] PCI: Use a weak symbol for the empty version of pcibios_add_platform_entries()

2.6.22 booting hangs after "INIT: version 2.86 booting"
 2007-07-12  1:31 UTC  (2+ messages)

[PATCH] rocket: Fix mutex locking compile warning
 2007-07-12  1:27 UTC  (2+ messages)

[PATCH 1/1] x86-64: introduce struct pci_sysdata to facilitate sharing of ->sysdata
 2007-07-12  1:17 UTC  (2+ messages)

Liunx power consumption on laptops -- Enormous progress in the last few months
 2007-07-12  1:15 UTC  (3+ messages)
` PCI devices power management, w/o sysfs? [Was: Re: Liunx power consumption on laptops ...]

[2.6.23 PATCH 16/18] dm mpath: rdac
 2007-07-12  1:11 UTC  (3+ messages)
  ` [dm-devel] "

[RFC 1/7] cpuset write dirty map
 2007-07-12  1:07 UTC  (9+ messages)

[PATCH] Immunize rcu_dereference() against crazy compiler writers
 2007-07-12  1:03 UTC  (2+ messages)
` [PATCH] Remove workaround for unimmunized rcu_dereference from mce_log()

[PATCH] Remove CHILD_MAX
 2007-07-12  1:01 UTC 

[PATCH] Remove OPEN_MAX
 2007-07-12  0:59 UTC 

[PATCH] avoid OPEN_MAX in SCM_MAX_FD
 2007-07-12  0:58 UTC 

acpi regression on some laptops
 2007-07-12  0:58 UTC  (6+ messages)

Linux drm "war on typedefs"
 2007-07-12  0:41 UTC 

[2.6.23 PATCH 14/18] dm: netlink add to core
 2007-07-12  0:40 UTC  (3+ messages)

[patch 09/10] Remove the SLOB allocator for 2.6.23
 2007-07-12  0:33 UTC  (14+ messages)

[PATCH -rt WIP] NMI-safe lightweight parallel-update -rt RCU
 2007-07-12  0:30 UTC  (3+ messages)

[EXT4 set 9][PATCH 5/5]Extent micro cleanups
 2007-07-11 21:29 UTC  (3+ messages)

[PATCH 0/2] Kexec jump: The first step to kexec base hibernation
 2007-07-12  0:22 UTC  (2+ messages)

[PATCH 0/16] Pid namespaces
 2007-07-12  0:21 UTC  (3+ messages)
` [PATCH 10/16] Changes in copy_process() to work with pid namespaces

[PATCH 00/23] Mount writer count API (read-only bind mounts prep)
 2007-07-12  0:17 UTC  (24+ messages)
` [PATCH 01/23] rearrange may_open() to be r/o friendly
` [PATCH 02/23] create cleanup helper svc_msnfs()
` [PATCH 03/23] filesystem helpers for custom 'struct file's
` [PATCH 04/23] r/o bind mounts: stub functions
` [PATCH 05/23] elevate write count open()'d files
` [PATCH 06/23] r/o bind mounts: elevate write count for some ioctls
` [PATCH 07/23] elevate writer count for chown and friends
` [PATCH 08/23] make access() use mnt check
` [PATCH 09/23] elevate mnt writers for callers of vfs_mkdir()
` [PATCH 10/23] elevate write count during entire ncp_ioctl()
` [PATCH 11/23] elevate write count for link and symlink calls
` [PATCH 12/23] elevate mount count for extended attributes
` [PATCH 13/23] elevate write count for file_update_time()
` [PATCH 14/23] mount_is_safe(): add comment
` [PATCH 15/23] unix_find_other() elevate write count for touch_atime()
` [PATCH 16/23] elevate write count over calls to vfs_rename()
` [PATCH 17/23] nfs: check mnt instead of superblock directly
` [PATCH 18/23] elevate writer count for do_sys_truncate()
` [PATCH 19/23] elevate write count for do_utimes()
` [PATCH 20/23] elevate write count for do_sys_utime() and touch_atime()
` [PATCH 21/23] sys_mknodat(): elevate write count for vfs_mknod/create()
` [PATCH 22/23] elevate mnt writers for vfs_unlink() callers
` [PATCH 23/23] do_rmdir(): elevate write count

RFC: CONFIG_PAGE_SHIFT (aka software PAGE_SIZE)
 2007-07-12  0:12 UTC  (4+ messages)

Linux 2.6.22 released
 2007-07-11 23:56 UTC  (11+ messages)

[PATCH] Pass -g to assembler under CONFIG_DEBUG_INFO
 2007-07-11 23:53 UTC  (5+ messages)

[2.6.23 PATCH 13/18] dm: netlink
 2007-07-11 23:37 UTC  (3+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox