The Linux Kernel Mailing List
 help / color / mirror / Atom feed
 messages from 2025-02-07 23:08:13 to 2025-02-08 04:32:49 UTC [more...]

[PATCH v8 2/2] rust: add dma coherent allocator abstraction
 2025-02-08  4:32 UTC  (12+ messages)
        ` On community influencing (was Re: [PATCH v8 2/2] rust: add dma coherent allocator abstraction.)

[syzbot] [f2fs?] kernel BUG in folio_end_read
 2025-02-08  4:27 UTC 

[PATCH 0/2] Add MediaTek DRAMC driver support
 2025-02-08  4:24 UTC  (9+ messages)
` [PATCH 1/2] memory/mediatek: Add an interface to get current DDR data rate
` [PATCH 2/2] dt-bindings: memory-controllers: Add mediatek common-dramc dt-bindings

[GIT PULL] smb3 client fixes
 2025-02-08  4:24 UTC  (2+ messages)

[PATCH v3] docs/arch: remove deprecated function name
 2025-02-08  4:19 UTC  (2+ messages)

[PATCH] platform/x86: thinkpad_acpi: Fix registration of tpacpi platform driver
 2025-02-08  9:14 UTC 

[PATCH net-next v5 0/3] netdev-genl: Add an xsk attribute to queues
 2025-02-08  4:12 UTC  (4+ messages)
` [PATCH net-next v5 1/3] netlink: Add nla_put_empty_nest helper
` [PATCH net-next v5 2/3] netdev-genl: Add an XSK attribute to queues
` [PATCH net-next v5 3/3] selftests: drv-net: Test queue xsk attribute

[PATCH v7 0/7] drm/msm: make use of the HDMI connector infrastructure
 2025-02-08  4:14 UTC  (15+ messages)
` [PATCH v7 1/7] drm/msm/hdmi: switch to atomic bridge callbacks
` [PATCH v7 2/7] drm/msm/hdmi: program HDMI timings during atomic_pre_enable
` [PATCH v7 3/7] drm/msm/hdmi: make use of the drm_connector_hdmi framework
` [PATCH v7 4/7] drm/msm/hdmi: get rid of hdmi_mode
` [PATCH v7 5/7] drm/msm/hdmi: update HDMI_GEN_PKT_CTRL_GENERIC0_UPDATE definition
` [PATCH v7 6/7] drm/msm/hdmi: also send the SPD and HDMI Vendor Specific InfoFrames
` [PATCH v7 7/7] drm/msm/hdmi: use DRM HDMI Audio framework

[PATCH net-next v4 2/3] netdev-genl: Add an XSK attribute to queues
 2025-02-08  4:02 UTC  (2+ messages)

[PATCH net-next] documentation: networking: Add NAPI config
 2025-02-08  3:58 UTC  (2+ messages)

[PATCH v3] crypto: x86/aes-ctr - rewrite AESNI+AVX optimized CTR and add VAES support
 2025-02-08  3:52 UTC 

[PATCH] phy: freescale: fsl-samsung-hdmi: Use helper function devm_clk_get_enabled()
 2025-02-08  3:44 UTC 

[PATCH v3] scsi: Bypass certain SCSI commands on disks with "use_192_bytes_for_3f" attribute
 2025-02-08  3:40 UTC 

[PATCH 6.13 000/619] 6.13.2-rc2 review
 2025-02-08  3:40 UTC  (4+ messages)

[RFC PATCH 0/2] livepatch: Add support for hybrid mode
 2025-02-08  3:38 UTC  (24+ messages)
` [RFC PATCH 2/2] livepatch: Implement livepatch "

[RFC PATCH bpf-next 0/8] bpf, sched_ext: Make kfunc filters support struct_ops context to reduce runtime overhead
 2025-02-08  3:37 UTC  (3+ messages)
` [RFC PATCH bpf-next 6/8] sched_ext: Add filter for scx_kfunc_ids_unlocked

[PATCH net-next v7 0/7] Enable SGMII and 2500BASEX interface mode switching for Intel platforms
 2025-02-08  3:33 UTC  (6+ messages)
` [PATCH net-next v7 2/7] net: pcs: xpcs: re-initiate clause 37 Auto-negotiation

[PATCH v2] usb: dwc3: gadget: Prevent irq storm when TH re-executes
 2025-02-08  3:31 UTC 

[PATCH 0/2] sched_ext: Add a core event and update scx schedulers
 2025-02-08  3:17 UTC  (5+ messages)

[RFC PATCH v2 0/8] fallocate: introduce FALLOC_FL_WRITE_ZEROES flag
 2025-02-08  3:12 UTC  (4+ messages)
` [RFC PATCH v2 4/8] dm: add BLK_FEAT_WRITE_ZEROES_UNMAP support

[PATCH 0/2] crypto: x86 - AES-CTR and AES-XCTR rewrite
 2025-02-08  3:12 UTC  (3+ messages)
` [PATCH 2/2] crypto: x86/aes-ctr - remove non-AVX implementation of AES-CTR

[PATCH bpf-next v2 00/26] Resilient Queued Spin Lock
 2025-02-08  3:06 UTC  (12+ messages)
` [PATCH bpf-next v2 11/26] rqspinlock: Add deadlock detection and recovery
` [PATCH bpf-next v2 17/26] rqspinlock: Hardcode cond_acquire loops to asm-generic implementation
` [PATCH bpf-next v2 19/26] bpf: Convert hashtab.c to rqspinlock
` [PATCH bpf-next v2 23/26] bpf: Handle allocation failure in acquire_lock_state

[PATCH] vgaarbiter: documentation grammar correction
 2025-02-08  3:06 UTC 

[PATCH 0/4] Small changes related to prefetch and spurious faults
 2025-02-08  3:01 UTC  (10+ messages)
` [PATCH 2/4] KVM: x86/tdp_mmu: Merge the prefetch into the is_access_allowed() check
` [PATCH 3/4] KVM: x86/mmu: Make sure pfn is not changed for spurious fault
` [PATCH 4/4] KVM: x86/mmu: Free obsolete roots when pre-faulting SPTEs

[PATCH v10 0/8] rust: Add IO polling
 2025-02-08  3:01 UTC  (6+ messages)
` [PATCH v10 1/8] sched/core: Add __might_sleep_precision()
` [PATCH v10 7/8] rust: Add read_poll_timeout functions

[PATCH v2 0/2] Fix dwc_pcie pmu driver issues
 2025-02-08  2:59 UTC  (7+ messages)
` [PATCH v2 1/2] perf/dwc_pcie: fix the incorrect reference count
    ` [External] "
` [PATCH v2 2/2] perf/dwc_pcie: fix duplicate pci_dev devices
    ` [External] "

[RFC 0/2] refcount: attempt to avoid imbalance warnings
 2025-02-08  2:52 UTC  (3+ messages)

[PATCH] mm: use READ/WRITE_ONCE() for vma->vm_flags on migrate, mprotect
 2025-02-08  2:50 UTC  (2+ messages)

[PATCH 1/2] md/raid5: skip stripes with bad reads during reshape to avoid stall
 2025-02-08  2:49 UTC  (3+ messages)
` [PATCH v2 1/2] md/raid5: freeze reshape when encountering a bad read

[PATCH v2 0/6] A few more CRC32 library cleanups
 2025-02-08  2:49 UTC  (7+ messages)
` [PATCH v2 1/6] mips/crc32: remove unused enums
` [PATCH v2 2/6] lib/crc32: use void pointer for data
` [PATCH v2 3/6] lib/crc32: don't bother with pure and const function attributes
` [PATCH v2 4/6] lib/crc32: standardize on crc32c() name for Castagnoli CRC32
` [PATCH v2 5/6] lib/crc32: rename __crc32c_le_combine() to crc32c_combine()
` [PATCH v2 6/6] lib/crc32: remove "_le" from crc32c base and arch functions

[PATCH v2] vdpa/mlx5: Fix mlx5_vdpa_get_config() endianness on big-endian machines
 2025-02-08  2:45 UTC  (3+ messages)

[PATCH 6.12 000/583] 6.12.13-rc2 review
 2025-02-08  2:43 UTC  (3+ messages)

[RFC PATCH 3/3] drm/virtio: implement blob userptr resource object
 2025-02-08  2:43 UTC  (12+ messages)

[RFC] bpf: Rethinking BPF safety, BPF open-coded iterators, and possible improvements (runtime protection)
 2025-02-08  2:40 UTC  (4+ messages)

[PATCH bpf-next] selftests/bpf: Remove with_addr.sh and with_tunnels.sh
 2025-02-08  2:40 UTC  (2+ messages)

[PATCH v3] f2fs: quota: fix to avoid warning in dquot_writeback_dquots()
 2025-02-08  2:33 UTC 

[PATCH] PM / devfreq: Fix a typo in trans_stat
 2025-02-08  2:13 UTC 

[PATCH v2 1/3] powerpc/time: Export boot_tb and log initial timebase at boot
 2025-02-08  2:29 UTC  (3+ messages)

[PATCH v2 00/12] YAML conversion of several Freescale/PowerPC DT bindings
 2025-02-08  2:20 UTC  (12+ messages)
` [PATCH v2 02/12] dt-bindings: ata: Convert fsl,pq-sata to YAML
` [PATCH v2 06/12] dt-bindings: pci: Convert fsl,mpc83xx-pcie "
` [PATCH v2 09/12] dt-bindings: memory-controllers: Convert fsl,elbc "
` [PATCH v2 11/12] dt-bindings: nand: Add fsl,elbc-fcm-nand

[PATCH bpf-next v2 0/9] Introduce load-acquire and store-release BPF instructions
 2025-02-08  2:20 UTC  (5+ messages)
` [PATCH bpf-next v2 8/9] selftests/bpf: Add selftests for load-acquire and store-release instructions

objtool failure caused some kernel functionality not working
 2025-02-08  2:16 UTC  (4+ messages)

[PATCH net-next 00/13] Introduce an ethernet port representation
 2025-02-08  2:14 UTC  (2+ messages)

[PATCH 6.6 000/389] 6.6.76-rc2 review
 2025-02-08  2:13 UTC  (3+ messages)
` [PATCH 6.6] "

[PATCH v2 bpf 0/2] bpf: skip non exist keys in
 2025-02-08  2:13 UTC  (6+ messages)
` [PATCH v2 bpf 1/2] bpf: skip non exist keys in generic_map_lookup_batch
` [PATCH v2 bpf 2/2] selftests: bpf: test batch lookup on array of maps with holes

[PATCH] objtool: Hide unnecessary compiler error message
 2025-02-08  2:12 UTC  (2+ messages)

[PATCH v18 0/3] ACPI: APEI: handle synchronous errors in task work
 2025-02-08  2:05 UTC  (3+ messages)

[PATCH v3 0/2] clk: rockchip: Fixed some incorrect commits
 2025-02-08  1:57 UTC  (3+ messages)
` [PATCH v3 1/2] ARM: dts: rockchip: assigned-clock-parents to SCLK_HDMI_PHY for DCLK_VOP
` [PATCH v3 2/2] arm64: dts: rockchip: Increase VOP clk rate on RK3328

[RFC PATCH v2 0/4] PMU partitioning driver support
 2025-02-08  2:01 UTC  (5+ messages)
` [RFC PATCH v2 1/4] perf: arm_pmuv3: Generalize counter bitmasks
` [RFC PATCH v2 2/4] perf: arm_pmuv3: Introduce module param to partition the PMU
` [RFC PATCH v2 3/4] perf: arm_pmuv3: Keep out of guest counter partition
` [RFC PATCH v2 4/4] KVM: arm64: Make guests see only counters they can access

[PATCH 0/2] arm64: dts: qcom: sm8750: Introduce BWMONs
 2025-02-08  1:48 UTC  (4+ messages)
` [PATCH 2/2] arm64: dts: qcom: sm8750: Add BWMONs

[PATCH v2 00/35] drm/bridge: Various quality of life improvements
 2025-02-08  1:44 UTC  (7+ messages)
` [PATCH v2 13/35] drm/bridge: Change parameter name of drm_atomic_bridge_chain_post_disable()
` [PATCH v2 18/35] drm/bridge: Change parameter name of drm_atomic_bridge_chain_pre_enable()
` [PATCH v2 35/35] drm/bridge: ti-sn65dsi86: Use bridge_state crtc pointer

[PATCH 0/5] Add UFS support for SM8750
 2025-02-08  1:43 UTC  (3+ messages)
` [PATCH 4/5] arm64: dts: qcom: sm8750: Add UFS nodes for SM8750 SoC

[PATCH v4 00/14] kexec: introduce Kexec HandOver (KHO)
 2025-02-08  1:38 UTC  (4+ messages)

[PATCH 00/19 v7?] RFC: Allow concurrent and async changes in a directory
 2025-02-08  1:38 UTC  (6+ messages)
` [PATCH 11/19] VFS: Add ability to exclusively lock a dentry and use for create/remove operations
` [PATCH 13/19] VFS: lock dentry for ->revalidate to avoid races with rename etc

[PATCH v2 0/2] Refine kmalloc caches randomization in kvmalloc
 2025-02-08  1:47 UTC  (3+ messages)
` [PATCH v2 1/2] slab: Adjust placement of __kvmalloc_node_noprof
` [PATCH v2 2/2] slab: Achieve better kmalloc caches randomization in kvmalloc

[PATCH v2] f2fs: quota: fix to avoid warning in dquot_writeback_dquots()
 2025-02-08  1:37 UTC  (3+ messages)

[PATCH] selftests: i915: Use struct_size() helper in kmalloc()
 2025-02-08  1:35 UTC 

[PATCH] LoongArch: Remove the deprecated notifier hook mechanism
 2025-02-08  1:33 UTC 

[PATCH] ACPI: thermal: Fix incorrect comment about trip points
 2025-02-08  1:33 UTC 

[PATCH 0/9] riscv: Unaligned access speed probing fixes and skipping
 2025-02-08  1:22 UTC  (3+ messages)
` [PATCH 7/9] riscv: Prepare for unaligned access type table lookups

[PATCH v7 00/24] Intel vendor events and TMA 5.02 metrics
 2025-02-08  1:19 UTC  (5+ messages)
` [PATCH v7 03/24] perf vendor events: Add Arrowlake events/metrics

[PATCH -next v5 00/22] arm64: entry: Convert to generic entry
 2025-02-08  1:15 UTC  (2+ messages)

[PATCH 1/2] libbpf: BPF program load type enum
 2025-02-08  1:13 UTC  (6+ messages)
` [PATCH 2/2] libbpf: BPF programs dynamic loading and attaching
    `  "
        `  "

[PATCH 00/12] Tiny cleanup and improvements about SWAP code
 2025-02-08  1:08 UTC  (3+ messages)

[PATCH V2 2/2] sched: Reduce the default slice to avoid tasks getting an extra tick
 2025-02-08  1:04 UTC  (2+ messages)

[PATCH 0/4] ASoC: tas2764: Random patches from the Asahi Linux tree
 2025-02-08  1:03 UTC  (5+ messages)
` [PATCH 1/4] ASoC: tas2764: Power up/down amp on mute ops
` [PATCH 2/4] ASoC: tas2764: Wait for ramp-down after shutdown
` [PATCH 3/4] ASoC: tas2764: Mark SW_RESET as volatile
` [PATCH 4/4] ASoC: tas2764: Add reg defaults for TAS2764_INT_CLK_CFG

[PATCH] ASoC: ops: Enforce platform maximum on initial value
 2025-02-08  0:57 UTC 

[PATCH] ASoC: tas2770: Fix volume scale
 2025-02-08  0:54 UTC 

[PATCH bpf-next v2 18/26] rqspinlock: Add entry to Makefile, MAINTAINERS
 2025-02-08  0:43 UTC  (2+ messages)

[PATCH v4 0/2] rust: lockdep: Fix soundness issue affecting LockClassKeys
 2025-02-08  0:39 UTC  (3+ messages)
` [PATCH v4 1/2] rust: lockdep: Remove support for dynamically allocated LockClassKeys
` [PATCH v4 2/2] rust: lockdep: Use Pin for all LockClassKey usages

[PATCH] crypto: ccp - Add support for PCI device 0x1134
 2025-02-08  0:36 UTC  (2+ messages)

[PATCH net-next v3 0/2] Use PHYlib for reset randomization and adjustable polling
 2025-02-08  0:34 UTC  (5+ messages)
` [PATCH net-next v3 1/2] net: phy: Add support for driver-specific next update time
` [PATCH net-next v3 2/2] net: phy: dp83tg720: Add randomized polling intervals for unstable link detection

[PATCH v6 00/17] Enable CXL PCIe port protocol error handling and logging
 2025-02-08  0:29 UTC  (18+ messages)
` [PATCH v6 01/17] PCI/AER: Introduce 'struct cxl_err_handlers' and add to 'struct pci_driver'
` [PATCH v6 02/17] PCI/AER: Rename AER driver's interfaces to also indicate CXL PCIe Port support
` [PATCH v6 03/17] CXL/PCI: Introduce PCIe helper functions pcie_is_cxl() and pcie_is_cxl_port()
` [PATCH v6 04/17] PCI/AER: Modify AER driver logging to report CXL or PCIe bus error type
` [PATCH v6 05/17] PCI/AER: Add CXL PCIe Port correctable error support in AER service driver
` [PATCH v6 06/17] PCI/AER: Add CXL PCIe Port uncorrectable error recovery "
` [PATCH v6 07/17] cxl/pci: Map CXL PCIe Root Port and Downstream Switch Port RAS registers
` [PATCH v6 08/17] cxl/pci: Map CXL PCIe Upstream "
` [PATCH v6 09/17] cxl/pci: Update RAS handler interfaces to also support CXL PCIe Ports
` [PATCH v6 10/17] cxl/pci: Add log message for unmapped registers in existing RAS handlers
` [PATCH v6 11/17] cxl/pci: Change find_cxl_port() to non-static
` [PATCH v6 12/17] cxl/pci: Add error handler for CXL PCIe Port RAS errors
` [PATCH v6 13/17] cxl/pci: Add trace logging "
` [PATCH v6 14/17] cxl/pci: Update CXL Port RAS logging to also display PCIe SBDF
` [PATCH v6 15/17] cxl/pci: Add support to assign and clear pci_driver::cxl_err_handlers
` [PATCH v6 16/17] PCI/AER: Enable internal errors for CXL Upstream and Downstream Switch Ports
` [PATCH v6 17/17] cxl/pci: Handle CXL Endpoint and RCH protocol errors separately from PCIe errors

[PATCH v4 02/14] Add TSEM specific documentation
 2025-02-08  0:29 UTC  (6+ messages)
` [PATCH v4 2/14] "

[PATCH v3 0/2] netconsole: allow selection of egress interface via MAC address
 2025-02-08  0:28 UTC  (3+ messages)
` [PATCH v3 2/2] "

[PATCH RFC net-next] net: Add dev_getbyhwaddr_rtnl() helper
 2025-02-08  0:27 UTC  (2+ messages)

[PATCH RFC net-next v3 0/2] Add SGMII port support to KSZ9477 switch
 2025-02-08  0:24 UTC  (3+ messages)
` [PATCH RFC net-next v3 1/2] net: pcs: xpcs: Activate DW_XPCS_SGMII_MODE_MAC_MANUAL for KSZ9477
` [PATCH RFC net-next v3 2/2] net: dsa: microchip: Add SGMII port support to KSZ9477 switch

[REGRESSION][BISECTED] Crash with Bad page state for FUSE/Flatpak related applications since v6.13
 2025-02-08  0:22 UTC  (13+ messages)

[PATCH v2 00/18] cxl: Address translation support, part 1: Cleanups and refactoring
 2025-02-07 23:57 UTC  (9+ messages)
` [PATCH v2 01/18] cxl: Remove else after return
` [PATCH v2 02/18] cxl/pci: Moving code in cxl_hdm_decode_init()
` [PATCH v2 05/18] cxl: Introduce parent_port_of() helper
` [PATCH v2 16/18] cxl/region: Show message on broken target list

[PATCH v3 0/2] seccomp: pass uretprobe system call through seccomp
 2025-02-08  0:03 UTC  (3+ messages)

[PATCH v9 00/26] riscv control-flow integrity for usermode
 2025-02-07 23:52 UTC  (8+ messages)
` [PATCH v9 01/26] mm: helper `is_shadow_stack_vma` to check shadow stack vma
` [PATCH v9 03/26] riscv: zicfiss / zicfilp enumeration

[PATCH RFC 00/33] Compile-time thread-safety checking
 2025-02-07 23:50 UTC  (6+ messages)
` [PATCH RFC 03/33] locking: Introduce <linux/thread_safety.h>

[PATCH 0/2] Add option for generating BTF types of global variables
 2025-02-07 23:50 UTC  (3+ messages)
` [PATCH 2/2] btf: Add the option to include global variable types

[PATCH bpf-next v2 0/3] bpf: Some fixes for nullness elision
 2025-02-07 23:50 UTC  (2+ messages)

[PATCH v3] rust/kernel: Add faux device bindings
 2025-02-07 23:49 UTC 

[PATCH v6 0/7] drm/msm: make use of the HDMI connector infrastructure
 2025-02-07 23:43 UTC  (8+ messages)
` [PATCH v6 3/7] drm/msm/hdmi: make use of the drm_connector_hdmi framework

[RFT][PATCH v1] cpuidle: teo: Avoid selecting deepest idle state over-eagerly
 2025-02-07 23:40 UTC  (2+ messages)

[PATCH] blackhole_dev: convert self-test to KUnit
 2025-02-07 23:38 UTC 

[PATCH v2 0/7] Add io_dir to avoid memory overhead from opendir
 2025-02-07 23:24 UTC  (8+ messages)
` [PATCH v2 1/7] tools lib api: Add io_dir an allocation free readdir alternative
` [PATCH v2 2/7] perf maps: Switch modules tree walk to io_dir__readdir
` [PATCH v2 3/7] perf pmu: Switch "
` [PATCH v2 4/7] perf header: Switch mem topology "
` [PATCH v2 5/7] perf events: Remove scandir in thread synthesis
` [PATCH v2 6/7] perf parse-events: Switch tracepoints to io_dir__readdir
` [PATCH v2 7/7] perf hwmon_pmu: Switch event discovery "

[PATCH bpf-next v2 02/26] locking: Move common qspinlock helpers to a private header
 2025-02-07 23:21 UTC  (2+ messages)

[PATCH net-next v6 0/5] net: stmmac: Add PCI driver support for BCM8958x
 2025-02-07 23:18 UTC  (4+ messages)

[PATCH v3 0/2] rust: lockdep: Fix soundness issue affecting LockClassKeys
 2025-02-07 23:11 UTC  (9+ messages)
` [PATCH v3 1/2] rust: lockdep: Remove support for dynamically allocated LockClassKeys
` [PATCH v3 2/2] rust: lockdep: Use Pin for all LockClassKey usages

[RFC PATCH v3 00/13] Clavis LSM
 2025-02-07 23:09 UTC  (4+ messages)
` [RFC PATCH v3 07/13] keys: Add ability to track intended usage of the public key


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox