The Linux Kernel Mailing List
 help / color / mirror / Atom feed
 messages from 2025-05-14 18:15:16 to 2025-05-14 20:21:03 UTC [more...]

(no subject)
 2025-05-14 20:21 UTC 

[PATCH] tracing: Replace deprecated strncpy() with strscpy() for string keys in hist triggers
 2025-05-14 20:19 UTC 

[PATCH 00/28] mm, swap: introduce swap table
 2025-05-14 20:17 UTC  (29+ messages)
` [PATCH 01/28] mm, swap: don't scan every fragment cluster
` [PATCH 02/28] mm, swap: consolidate the helper for mincore
` [PATCH 03/28] mm/shmem, swap: remove SWAP_MAP_SHMEM
` [PATCH 04/28] mm, swap: split readahead update out of swap cache lookup
` [PATCH 05/28] mm, swap: sanitize swap cache lookup convention
` [PATCH 06/28] mm, swap: rearrange swap cluster definition and helpers
` [PATCH 07/28] mm, swap: tidy up swap device and cluster info helpers
` [PATCH 08/28] mm, swap: use swap table for the swap cache and switch API
` [PATCH 09/28] mm/swap: rename __read_swap_cache_async to __swapin_cache_alloc
` [PATCH 10/28] mm, swap: add a swap helper for bypassing only read ahead
` [PATCH 11/28] mm, swap: clean up and consolidate helper for mTHP swapin check
` [PATCH 12/28] mm, swap: never bypass the swap cache for SWP_SYNCHRONOUS_IO
` [PATCH 13/28] mm/shmem, swap: avoid redundant Xarray lookup during swapin
` [PATCH 14/28] mm/shmem: never bypass the swap cache for SWP_SYNCHRONOUS_IO
` [PATCH 15/28] mm, swap: split locked entry freeing into a standalone helper
` [PATCH 16/28] mm, swap: use swap cache as the swap in synchronize layer
` [PATCH 17/28] mm, swap: sanitize swap entry management workflow
` [PATCH 18/28] mm, swap: rename and introduce folio_free_swap_cache
` [PATCH 19/28] mm, swap: clean up and improve swap entries batch freeing
` [PATCH 20/28] mm, swap: check swap table directly for checking cache
` [PATCH 21/28] mm, swap: add folio to swap cache directly on allocation
` [PATCH 22/28] mm, swap: drop the SWAP_HAS_CACHE flag
` [PATCH 23/28] mm, swap: remove no longer needed _swap_info_get
` [PATCH 24/28] mm, swap: implement helpers for reserving data in swap table
` [PATCH 25/28] mm/workingset: leave highest 8 bits empty for anon shadow
` [PATCH 26/28] mm, swap: minor clean up for swapon
` [PATCH 27/28] mm, swap: use swap table to track swap count
` [PATCH 28/28] mm, swap: implement dynamic allocation of swap table

[PATCH v11 00/30] x86/resctrl: Move the resctrl filesystem code to /fs/resctrl
 2025-05-14 20:19 UTC  (13+ messages)
` [PATCH v11 01/30] cpumask: relax cpumask_any_but()
` [PATCH v11 02/30] find: add find_first_andnot_bit()
` [PATCH v11 03/30] cpumask: add cpumask_{first,next}_andnot() API
` [PATCH v11 04/30] x86/resctrl: Optimize cpumask_any_housekeeping()
` [PATCH v11 25/30] x86,fs/resctrl: Move the resctrl filesystem code to live in /fs/resctrl

[RFC PATCH v2 0/8] staging: apfs: init APFS filesystem support
 2025-05-14 20:19 UTC  (5+ messages)
` Subject: "

[PATCH 5/8] pinctrl: meson: support amlogic S6/S7/S7D SoC
 2025-05-14 20:18 UTC  (2+ messages)

[PATCH 0/2] genirq: Retain disable-depth across irq_{shutdown,startup}()
 2025-05-14 20:16 UTC  (4+ messages)
` [PATCH 2/2] genirq: Retain disable depth across irq shutdown/startup

[PATCH] mm: madvise: make MADV_NOHUGEPAGE a no-op if !THP
 2025-05-14 20:15 UTC  (2+ messages)

[PATCH v16 00/10] perf record --off-cpu: Dump off-cpu samples directly
 2025-05-14 20:15 UTC  (5+ messages)

[PATCH RESEND] arm64: dts: qcom: x1e001de-devkit: Enable support for both Type-A USB ports
 2025-05-14 20:14 UTC 

[PATCH v2 0/2] genirq: Retain depth for managed IRQs across CPU hotplug
 2025-05-14 20:13 UTC  (3+ messages)
` [PATCH v2 1/2] "
` [PATCH v2 2/2] genirq: Add kunit tests for depth counts

[PATCH v2 0/2] Add a Rust GPUVM abstraction
 2025-05-14 20:11 UTC  (6+ messages)
` [PATCH v2 2/2] rust: drm: Add "

[PATCH v3 0/4] Describe the cameras in the PinePhone Pro dts
 2025-05-14 20:12 UTC  (5+ messages)
` [PATCH v3 1/4] dt-bindings: media: ov8858: inherit video-interface-devices properties
` [PATCH v3 2/4] dt-bindings: media: imx258: "

[PATCH] perf trace: Show zero value in STRARRAY
 2025-05-14 20:09 UTC  (2+ messages)

[RFT PATCH v2 00/15] Add a single source of truth for UBWC configuration data
 2025-05-14 20:09 UTC  (30+ messages)
` [PATCH RFT v2 01/15] soc: qcom: Add UBWC config provider
` [PATCH RFT v2 02/15] drm/msm: Offset MDSS HBB value by 13
` [PATCH RFT v2 03/15] drm/msm: Use the central UBWC config database
` [PATCH RFT v2 05/15] drm/msm/a6xx: Resolve the meaning of AMSBC
` [PATCH RFT v2 06/15] drm/msm/a6xx: Simplify uavflagprd_inv detection
` [PATCH RFT v2 07/15] drm/msm/a6xx: Resolve the meaning of UBWC_MODE
` [PATCH RFT v2 08/15] drm/msm/a6xx: Replace '2' with BIT(1) in level2_swizzling_dis calc
` [PATCH RFT v2 09/15] drm/msm/a6xx: Resolve the meaning of rgb565_predicator
` [PATCH RFT v2 10/15] drm/msm/a6xx: Simplify min_acc_len calculation
` [PATCH RFT v2 11/15] drm/msm/adreno: Switch to the common UBWC config struct
` [PATCH RFT v2 13/15] soc: qcom: ubwc: Fix SM6125's ubwc_swizzle value
` [PATCH RFT v2 14/15] soc: qcom: ubwc: Add #defines for UBWC swizzle bits
` [PATCH RFC RFT v2 15/15] drm/msm/a6xx: Warn if the highest_bank_bit value is overwritten

[PATCH] perf trace: Support --summary-mode=cgroup
 2025-05-14 20:07 UTC  (2+ messages)

[PATCH 6.6 000/113] 6.6.91-rc2 review
 2025-05-14 20:05 UTC  (4+ messages)

[PATCH v3 0/2] rust: add support for request_irq
 2025-05-14 20:06 UTC  (5+ messages)
` [PATCH v3 1/2] rust: irq: add support for request_irq()
` [PATCH v3 2/2] rust: platform: add irq accessors

[RFC PATCH 00/12] Private MMIO support for private assigned dev
 2025-05-14 20:05 UTC  (12+ messages)

[PATCH net-next] net/mlx5e: Reuse per-RQ XDP buffer to avoid stack zeroing overhead
 2025-05-14 20:03 UTC 

[PATCH v3 01/14] selinux: avoid nontransitive comparison
 2025-05-14 20:02 UTC  (18+ messages)
` [PATCH v3 07/14] selinux: check type attr map overflows
` [PATCH v3 08/14] selinux: reorder policydb_index()
` [PATCH v3 09/14] selinux: beef up isvalid checks
` [PATCH v3 10/14] selinux: validate symbols
` [PATCH v3 11/14] selinux: more strict bounds check
` [PATCH v3 12/14] selinux: check for simple types
` [PATCH v3 13/14] selinux: restrict policy strings
` [PATCH v3 14/14] selinux: harden MLS context string generation against overflows

[PATCH RESEND v4 0/3] Add Luckfox Omni3576 Carrier Board support for RK3576
 2025-05-14 20:01 UTC  (3+ messages)
` [PATCH RESEND v4 2/3] dt-bindings: arm: rockchip: Add Luckfox Omni3576 and Core3576 bindings

[PATCH v10 0/9] Add STM32MP25 PCIe drivers
 2025-05-14 19:59 UTC  (3+ messages)
` [PATCH v10 3/9] dt-bindings: PCI: Add STM32MP25 PCIe Endpoint bindings

[PATCH v1 0/2] mm/memory_hotplug: introduce and use PG_offline_skippable
 2025-05-14 19:57 UTC  (6+ messages)
` [PATCH v1 1/2] mm/memory_hotplug: PG_offline_skippable for offlining memory blocks with PageOffline pages
` [PATCH v1 2/2] mm/memory_hotplug: remove -EBUSY handling from scan_movable_pages()

[PATCH RFC] leds: leds-lp50xx: Handle reg to get correct multi_index
 2025-05-14 19:55 UTC  (4+ messages)

[RELEASE] LTTng-modules 2.14.0-rc2 (Linux kernel tracer)
 2025-05-14 19:53 UTC 

[PATCH] tools/powercap: Implement powercap_set_enabled()
 2025-05-14 19:53 UTC  (4+ messages)

[PATCH v3] PCI: Prevent power state transition of erroneous device
 2025-05-14 19:53 UTC  (3+ messages)

[syzbot] [net?] possible deadlock in ptp_clock_unregister
 2025-05-14 19:51 UTC 

[syzbot] [net?] possible deadlock in team_del_slave (3)
 2025-05-14 19:51 UTC 

[PATCH] thermal/drivers/mediatek/lvts_thermal: Remove redundant code in lvts_ctrl_configure
 2025-05-14 19:49 UTC  (4+ messages)

[syzbot] [xfs?] general protection fault in do_move_mount (3)
 2025-05-14 19:49 UTC  (6+ messages)

[PATCH v2 0/2] vt: bracketed paste and cursor position
 2025-05-14 19:42 UTC  (3+ messages)
` [PATCH v2 1/2] vt: bracketed paste support
` [PATCH v2 2/2] vt: add VT_GETCONSIZECSRPOS to retrieve console size and cursor position

[PATCH 0/5] Rust beta (1.87) and nightly (1.88) lint cleanups
 2025-05-14 19:46 UTC  (9+ messages)
` [PATCH 1/5] objtool/rust: add one more `noreturn` Rust function for Rust 1.87.0

[PATCH 1/2] dt-bindings: arm: fsl: Add EDM-G-IMX8M-PLUS SOM and WB-EDM-G carrier board
 2025-05-14 19:45 UTC  (2+ messages)

[PATCH net] amd-xgbe: read link status twice to avoid inconsistencies
 2025-05-14 19:41 UTC 

[PATCH v2 0/5] Add support for Battery Status & Battery Caps AMS in TCPM
 2025-05-14 19:42 UTC  (3+ messages)
` [PATCH v2 1/5] dt-bindings: connector: extend ports property to model power connections

[PATCH 1/1] PCI/bwctrl: Remove also pcie_bwctrl_lbms_rwsem
 2025-05-14 19:42 UTC  (3+ messages)

[RELEASE] LTTng-UST 2.14.0-rc2 (Linux user-space tracer)
 2025-05-14 19:41 UTC 

[PATCH net-next,v3] net: mana: Add handler for hardware servicing events
 2025-05-14 19:36 UTC  (2+ messages)

[PATCH v2 0/3] Improvements to S5 power consumption
 2025-05-14 19:34 UTC  (4+ messages)
` [PATCH v2 1/3] PM: Use hibernate flows for system power off
` [PATCH v2 2/3] PCI: Put PCIe ports with downstream devices into D3 at hibernate
` [PATCH v2 3/3] drm/amd: Avoid evicting resources at S5

[RELEASE] Userspace RCU 0.15.3
 2025-05-14 19:30 UTC 

[PATCH] x86/cpu/intel: replace deprecated strcpy with strscpy
 2025-05-14 19:16 UTC  (4+ messages)

The future of kernel-patches-daemon - folding under LF?
 2025-05-14 19:22 UTC  (3+ messages)

[PATCH 0/3] KVM: arm64: Allow vGICv4 configuration per VM
 2025-05-14 19:21 UTC  (4+ messages)
` [PATCH 1/3] kvm: arm64: Add support for KVM_DEV_ARM_VGIC_CONFIG_GICV4 attr
` [PATCH 2/3] docs: kvm: devices/arm-vgic-v3: Document "
` [PATCH 3/3] KVM: selftests: Extend vgic_init to test GICv4 config attr

[PATCH v4 00/23] iommufd: Add vIOMMU infrastructure (Part-4 HW QUEUE)
 2025-05-14 19:21 UTC  (6+ messages)
` [PATCH v4 06/23] iommufd/driver: Add iommufd_struct_destroy to revert iommufd_viommu_alloc
` [PATCH v4 09/23] iommufd: Abstract iopt_pin_pages and iopt_unpin_pages helpers

[PATCH v2 0/7] pinctrl: armada-37xx: a couple of small fixes
 2025-05-14 19:18 UTC  (8+ messages)
` [PATCH v2 1/7] pinctrl: armada-37xx: use correct OUTPUT_VAL register for GPIOs > 31
` [PATCH v2 2/7] pinctrl: armada-37xx: set GPIO output value before setting direction
` [PATCH v2 3/7] pinctrl: armada-37xx: propagate error from armada_37xx_gpio_direction_output()
` [PATCH v2 4/7] pinctrl: armada-37xx: propagate error from armada_37xx_gpio_get()
` [PATCH v2 5/7] pinctrl: armada-37xx: propagate error from armada_37xx_pmx_gpio_set_direction()
` [PATCH v2 6/7] pinctrl: armada-37xx: propagate error from armada_37xx_gpio_get_direction()
` [PATCH v2 7/7] pinctrl: armada-37xx: propagate error from armada_37xx_pmx_set_by_name()

[PATCH v2] params: Add support for static keys
 2025-05-14 19:17 UTC  (9+ messages)

[PATCH v2] fs: minix: Fix handling of corrupted directories
 2025-05-14 19:13 UTC  (3+ messages)

[PATCH v4 00/18] clk: qcom: Add support to attach multiple power domains in cc probe
 2025-05-14 19:09 UTC  (19+ messages)
` [PATCH v4 01/18] dt-bindings: clock: qcom,sm8450-videocc: Add MXC power domain
` [PATCH v4 02/18] dt-bindings: clock: qcom: Update sc8280xp camcc bindings
` [PATCH v4 03/18] dt-bindings: clock: qcom: sm8450-camcc: Allow to specify two power domains
` [PATCH v4 04/18] clk: qcom: clk-alpha-pll: Add support for common PLL configuration function
` [PATCH v4 05/18] clk: qcom: common: Handle runtime power management in qcom_cc_really_probe
` [PATCH v4 06/18] clk: qcom: common: Add support to configure clk regs "
` [PATCH v4 07/18] clk: qcom: videocc-sm8450: Move PLL & clk configuration to really probe
` [PATCH v4 08/18] clk: qcom: videocc-sm8550: "
` [PATCH v4 09/18] clk: qcom: camcc-sm8450: "
` [PATCH v4 10/18] clk: qcom: camcc-sm8550: "
` [PATCH v4 11/18] clk: qcom: camcc-sm8650: "
` [PATCH v4 12/18] clk: qcom: camcc-x1e80100: "
` [PATCH v4 13/18] arm64: dts: qcom: sm8450: Additionally manage MXC power domain in videocc
` [PATCH v4 14/18] arm64: dts: qcom: sm8550: "
` [PATCH v4 15/18] arm64: dts: qcom: sm8650: "
` [PATCH v4 16/18] arm64: dts: qcom: sm8450: Additionally manage MXC power domain in camcc
` [PATCH v4 17/18] arm64: dts: qcom: sm8550: "
` [PATCH v4 18/18] arm64: dts: qcom: sm8650: "

[PATCH] fs: allow clone_private_mount() for a path on real rootfs
 2025-05-14 19:02 UTC  (4+ messages)

[PATCH V4 1/2] dt-bindings: spi: tegra: Document IOMMU property for Tegra234 QSPI
 2025-05-14 19:01 UTC  (5+ messages)
` [PATCH V4 2/2] spi: tegra210-quad: Add support for internal DMA

[PATCH v2] dt-bindings: spi: nvidia,tegra210-quad: Add IOMMU property for Tegra234
 2025-05-14 19:01 UTC  (2+ messages)

lockup and kernel panic in linux-next-202505{09,12} when compiled with clang
 2025-05-14 18:56 UTC  (7+ messages)

[PATCH 1/9] CodingStyle: make Documentation/CodingStyle into symlink
 2025-05-14 18:55 UTC  (6+ messages)

[PATCH] arm64: dts: qcom: x1e80100-romulus: Enable DP over Type-C
 2025-05-14 18:53 UTC  (2+ messages)

[PATCH] ASoC: q6apm-lpass-dais: Print APM port id in decimal on enable error
 2025-05-14 18:53 UTC  (2+ messages)

[RFT PATCH v3 00/21] x86: strict separation of startup code
 2025-05-14 18:53 UTC  (4+ messages)

[PATCH] rbd: replace strcpy() with strscpy()
 2025-05-14 18:52 UTC  (2+ messages)

[PATCH v4 0/2] kvm: sev: Add SNP guest request throttling
 2025-05-14 18:50 UTC  (6+ messages)
` [PATCH v4 1/2] kvm: sev: Add SEV-SNP "
` [PATCH v4 2/2] kvm: sev: If ccp is busy, report busy to guest
` [PATCH v4 2/2] The ccp driver can be overloaded even with guest request rate limits. The return value of -EBUSY means that there is no firmware error to report back to user space, so the guest VM would see this as exitinfo2 = 0. The false success can trick the guest to update its message sequence number when it shouldn't have

[PATCH] net: phy: mxl-8611: add support for MaxLinear MxL86110/MxL86111 PHY
 2025-05-14 18:49 UTC  (3+ messages)
` [PATCH v2] "

[PATCH v3 0/4] Introducing Hornet LSM
 2025-05-14 18:48 UTC  (12+ messages)

[PATCH v5] mmc: sdhci_am654: Add SDHCI_QUIRK2_SUPPRESS_V1P8_ENA quirk to am62 compatible
 2025-05-14 18:44 UTC  (3+ messages)

[PATCH v2 0/7] memcg: make memcg stats irq safe
 2025-05-14 18:41 UTC  (8+ messages)
` [PATCH v2 1/7] memcg: memcg_rstat_updated re-entrant safe against irqs
` [PATCH v2 2/7] memcg: move preempt disable to callers of memcg_rstat_updated
` [PATCH v2 3/7] memcg: make mod_memcg_state re-entrant safe against irqs
` [PATCH v2 4/7] memcg: make count_memcg_events "
` [PATCH v2 5/7] memcg: make __mod_memcg_lruvec_state "
` [PATCH v2 6/7] memcg: no stock lock for cpu hot-unplug
` [PATCH v2 7/7] memcg: objcg stock trylock without irq disabling

[PATCH] perf trace: Split BPF skel code to util/trace_augment.c
 2025-05-14 18:36 UTC  (2+ messages)

[PATCH 0/2] UFFDIO_API.2const: Two man page updates
 2025-05-14 18:35 UTC  (9+ messages)
` [PATCH 1/2] UFFDIO_API.2const: Update userfaultfd handshake and feature probe
` [PATCH 2/2] UFFDIO_API.2const: Add an entry for UFFDIO_MOVE

[PATCH 6.1 00/96] 6.1.139-rc2 review
 2025-05-14 18:30 UTC  (2+ messages)

[PATCH v4 00/24] Tracefs support for pKVM
 2025-05-14 18:28 UTC  (4+ messages)

[GIT PULL] tracing: Fixes for v6.15
 2025-05-14 18:28 UTC  (2+ messages)

[linux-next:master] [rcutorture] c27d0d38f2: WARNING:at_kernel/rcu/rcutorture.c:#rcutorture_one_extend_check[rcutorture]
 2025-05-14 18:26 UTC  (2+ messages)

[PATCH v3 0/9] module: Introduce hash-based integrity checking
 2025-05-14 18:25 UTC  (5+ messages)
` [PATCH v3 2/9] ima: efi: Drop unnecessary check for CONFIG_MODULE_SIG/CONFIG_KEXEC_SIG

[PATCH v4 00/10] phy: qcom: Introduce USB support for SM8750
 2025-05-14 18:24 UTC  (6+ messages)
` [PATCH v4 06/10] phy: qcom: Add M31 based eUSB2 PHY driver

[PATCH 5.10] bpf: Avoid overflows involving hash elem_size
 2025-05-14 18:07 UTC 

[PATCH v5 0/7] fs: introduce file_getattr and file_setattr syscalls
 2025-05-14 18:21 UTC  (5+ messages)
` [PATCH v5 2/7] lsm: introduce new hooks for setting/getting inode fsxattr

[PATCH] mm: Rename page->index to page->__folio_index
 2025-05-14 18:15 UTC 


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox