The Linux Kernel Mailing List
 help / color / mirror / Atom feed
 messages from 2025-08-01 02:43:10 to 2025-08-01 07:58:13 UTC [more...]

[PATCH 0/5] rv: LTL per-cpu monitor type and real-time scheduling monitor
 2025-08-01  7:58 UTC  (14+ messages)
` [PATCH 2/5] rv/ltl: Support per-cpu monitors
` [PATCH 4/5] sched: Add rt task enqueue/dequeue trace points
` [PATCH 5/5] rv: Add rts monitor

[PATCH] checkpatch: validate commit tag ordering
 2025-08-01  7:55 UTC  (5+ messages)

[syzbot] [dri?] upstream test error: WARNING in __ww_mutex_wound
 2025-08-01  7:54 UTC 

[REGRESSION] next/master: suspect endianness issue in common PCI capability search macro
 2025-08-01  7:52 UTC  (3+ messages)
` [PATCH] PCI: Fix endianness issues in pci_bus_read_config()

[GIT PULL] MIPS changes for v6.17
 2025-08-01  7:40 UTC  (3+ messages)

[PATCH] drm/nouveau: Remove surplus struct member
 2025-08-01  7:45 UTC 

[PATCH v2 0/2] lib/sbitmap: convert shallow_depth from one word to the whole sbitmap
 2025-08-01  7:44 UTC  (10+ messages)
` [PATCH v2 1/2] "

(no subject)
 2025-08-01  7:41 UTC  (7+ messages)
` [PATCH 1/3] dt-bindings: mediatek : add binding for pwrap,spmi
` [PATCH 2/3] soc:mediatek mt8189: Porting driver for spmi/pwrap
` [PATCH 3/3] regulator: Modify mt6315 regulator mode mask

[PATCH v2 00/13] Add DisplayPort support for QCS615 platform
 2025-08-01  7:38 UTC  (12+ messages)
` [PATCH v2 02/13] dt-bindings: phy: Add binding for QCS615 standalone QMP DP PHY

[PATCH 00/33] tty: summer cleanup
 2025-08-01  7:38 UTC  (7+ messages)
` [PATCH 07/33] tty: vt: use _IO() to define ioctl numbers

[PATCH] fs: correctly check for errors from replace_fd() in receive_fd_replace()
 2025-08-01  7:38 UTC 

[PATCH v2] sched/deadline: Remove fair-servers from real-time task's bandwidth accounting
 2025-08-01  7:37 UTC  (2+ messages)

[PATCH v2 00/20] Add support for the NXP automotive S32G PIT
 2025-08-01  7:36 UTC  (13+ messages)
` [PATCH v2 07/20] clocksource/drivers/vf-pit: Allocate the struct timer at init time
` [PATCH v2 10/20] clocksource/drivers/vf-pit: Encapsulate the macros
` [PATCH v2 11/20] clocksource/drivers/vf-pit: Encapsulate the PTLCVAL macro
` [PATCH v2 17/20] clocksource/drivers/vf-pit: Unify the function name for irq ack
` [PATCH v2 18/20] clocksource/drivers/vf-pit: Rename the VF PIT to NXP PIT
` [PATCH v2 20/20] clocksource/drivers/nxp-pit: Add NXP Automotive s32g2 / s32g3 support

[PATCH] block/partitions/ldm: Use bool as the function return type
 2025-08-01  7:33 UTC 

[PATCH net-next] net: ip: lookup the best matched listen socket
 2025-08-01  7:33 UTC  (3+ messages)

[PATCH V1] ufs: core: Fix interrupt handling for MCQ Mode in ufshcd_intr
 2025-08-01  7:31 UTC  (2+ messages)

[PATCH v5 00/11] md/llbitmap: md/md-llbitmap: introduce a new lockless bitmap
 2025-08-01  7:03 UTC  (12+ messages)
` [PATCH v5 01/11] md: add a new parameter 'offset' to md_super_write()
` [PATCH v5 02/11] md: factor out a helper raid_is_456()
` [PATCH v5 03/11] md/md-bitmap: support discard for bitmap ops
` [PATCH v5 04/11] md: add a new mddev field 'bitmap_id'
` [PATCH v5 05/11] md/md-bitmap: add a new sysfs api bitmap_type
` [PATCH v5 06/11] md/md-bitmap: delay registration of bitmap_ops until creating bitmap
` [PATCH v5 07/11] md/md-bitmap: add a new method skip_sync_blocks() in bitmap_operations
` [PATCH v5 08/11] md/md-bitmap: add a new method blocks_synced() "
` [PATCH v5 09/11] md: add a new recovery_flag MD_RECOVERY_LAZY_RECOVER
` [PATCH v5 10/11] md/md-bitmap: make method bitmap_ops->daemon_work optional
` [PATCH v5 11/11] md/md-llbitmap: introduce new lockless bitmap

[PATCH] arm64: dts: renesas: rzg2lc-smarc: Fix typo for deleting node
 2025-08-01  7:30 UTC  (2+ messages)

[PATCH v3 0/7] Add support for Clock controllers for Glymur
 2025-08-01  7:28 UTC  (13+ messages)
` [PATCH v3 2/7] dt-bindings: clock: qcom: Document the Glymur TCSR Clock Controller
` [PATCH v3 3/7] clk: qcom: Add TCSR clock driver for Glymur
` [PATCH v3 7/7] clk: qcom: gcc: Add support for Global Clock Controller

[PATCH 0/3] opp: Add bw_factor support to adjust bandwidth dynamically
 2025-08-01  7:28 UTC  (3+ messages)

[PATCH v2 0/9] Add thermal sensor driver support for Mediatek MT8196
 2025-08-01  7:28 UTC  (15+ messages)
` [PATCH v2 2/9] thermal/drivers/mediatek/lvts: Make number of calibration offsets configurable
` [PATCH v2 3/9] thermal/drivers/mediatek/lvts: Guard against zero temp_factor in lvts_raw_to_temp
` [PATCH v2 4/9] thermal: mediatek: lvts: Add platform ops to support alternative conversion logic
` [PATCH v2 5/9] thermal/drivers/mediatek/lvts: Add lvts_temp_to_raw variant
` [PATCH v2 6/9] thermal/drivers/mediatek/lvts: Add support for ATP mode
` [PATCH v2 7/9] thermal/drivers/mediatek/lvts: Support MSR offset for 16-bit calibration data
` [PATCH v2 8/9] thermal/drivers/mediatek/lvts_thermal: Add MT8196 support

[PATCH v19 0/6] Introduction of a remoteproc tee to load signed firmware
 2025-08-01  7:23 UTC  (4+ messages)
` [PATCH v19 2/6] remoteproc: Add TEE support

[PATCH v2 1/1] userfaultfd: fix a crash when UFFDIO_MOVE handles a THP hole
 2025-08-01  7:21 UTC  (2+ messages)

[PATCH 0/8] staging: rtl8723bs: get rid of os_dep/mlme_linux.c
 2025-08-01  7:19 UTC  (4+ messages)
` [PATCH 3/8] staging: rtl8723bs: move rtw_init_mlme_timer to core/rtw_mlme.c

[PATCH] Revert "gpio: pxa: Make irq_chip immutable"
 2025-08-01  7:18 UTC 

linux-next: manual merge of the rust-timekeeping tree with the drm-nova tree
 2025-08-01  7:18 UTC  (2+ messages)

[PATCH] selftests/mm: pass filename as input param to VM_PFNMAP tests
 2025-08-01  7:14 UTC  (2+ messages)

[syzbot] [dri?] WARNING in __ww_mutex_wound
 2025-08-01  7:09 UTC  (4+ messages)
` [RFC][PATCH] locking: Fix __clear_task_blocked_on() warning from __ww_mutex_wound() path

[v2 00/11] THP support for zone device page migration
 2025-08-01  7:04 UTC  (23+ messages)
` [v2 02/11] mm/thp: zone_device awareness in THP handling code

[PATCH v2] dt-bindings: riscv: Add SiFive vendor extensions description
 2025-08-01  7:01 UTC 

[PATCH] perf tools c2c: Add annotation support to perf c2c report
 2025-08-01  7:51 UTC 

[PATCH] mm:slub:avoid wake up kswapd in set_track_prepare
 2025-08-01  6:51 UTC 

[PATCH v3 05/13] generic/1226: Add atomic write test using fio crc check verifier
 2025-08-01  6:41 UTC  (11+ messages)

[PATCH -next] thermal/drivers/mediatek/lvts_thermal: remove unneeded semicolon
 2025-08-01  6:35 UTC 

[PATCH v2 0/3] pinctrl: tegra: Add Tegra186 pinmux driver
 2025-08-01  6:33 UTC  (10+ messages)
` [PATCH v2 2/3] "

[PATCH] backlight: pwm_bl: apply the initial backlight state with sane defaults
 2025-08-01  6:32 UTC  (2+ messages)

linux-next: build warning after merge of the drm-misc tree
 2025-08-01  6:28 UTC  (3+ messages)
  `  "

Question on the scheduling of timer interrupt and FIO interrupt
 2025-08-01  6:26 UTC 

[PATCH 00/12] docs: kdoc: thrash up dump_struct()
 2025-08-01  6:23 UTC  (27+ messages)
` [PATCH 01/12] docs: kdoc: consolidate the stripping of private struct/union members
` [PATCH 02/12] docs: kdoc: Move a regex line in dump_struct()
` [PATCH 03/12] docs: kdoc: backslashectomy in kdoc_parser
` [PATCH 04/12] docs: kdoc: move the prefix transforms out of dump_struct()
` [PATCH 05/12] docs: kdoc: split top-level prototype parsing "
` [PATCH 06/12] docs: kdoc: split struct-member rewriting "
` [PATCH 07/12] docs: kdoc: rework the rewrite_struct_members() main loop
` [PATCH 08/12] docs: kdoc: remove an extraneous strip() call
` [PATCH 09/12] docs: kdoc: Some rewrite_struct_members() commenting
` [PATCH 10/12] docs: kdoc: further rewrite_struct_members() cleanup
` [PATCH 11/12] docs: kdoc: extract output formatting from dump_struct()
` [PATCH 12/12] docs: kdoc: a few final dump_struct() touches

[PATCH 1/4] ASoC: SOF: amd: Add sof audio support for acp7.2 platform
 2025-08-01  6:21 UTC  (4+ messages)
` [PATCH 2/4] ASoC: amd: ps: Add SoundWire pci and dma driver "
` [PATCH 3/4] ASoC: amd: acp: Add SoundWire legacy machine "
` [PATCH 4/4] ASoC: amd: acp: Add SoundWire SOF "

[PATCH] bcache: enhancing the security of dirty data writeback
 2025-08-01  6:10 UTC  (7+ messages)

[PATCH v4] mm: slub: avoid deref of invalid free pointer in object_err()
 2025-08-01  6:10 UTC 

[RFC PATCH 0/6] virtio: Add support for Virtio message transport
 2025-08-01  6:02 UTC  (6+ messages)
` [RFC PATCH 2/6] of: reserved-memory: Add of_reserved_mem_lookup_by_name

[PATCH v7 0/3] PCI: tegra: Allow building as a module
 2025-08-01  6:00 UTC  (3+ messages)

[PATCH v3] platform/x86: Add WMI driver for Redmibook keyboard
 2025-08-01  6:00 UTC  (2+ messages)

[PATCH] tools/testing/vma: Fix function parameter declarations for GCC 8.3 compatibility
 2025-08-01  5:57 UTC  (7+ messages)

[PATCH v4 0/4] Enable cpufreq for IPQ5424
 2025-08-01  5:58 UTC  (4+ messages)
` [PATCH v4 1/4] dt-bindings: clock: ipq5424-apss-clk: Add ipq5424 apss clock controller

Aquantia PHY in OCSGMII mode?
 2025-08-01  5:53 UTC  (8+ messages)

linux-next: Tree for Aug 1
 2025-08-01  5:48 UTC 

[PATCH v2 00/13] Add MediaTek ISP7.x camera system support
 2025-08-01  5:45 UTC  (3+ messages)
` [PATCH v2 10/13] media: platform: mediatek: add isp_7x video ops

[PATCH v3 0/2] PCI/ERR: s390/pci: Use pci_uevent_ers() in PCI recovery
 2025-08-01  5:44 UTC  (7+ messages)
` [PATCH v3 1/2] PCI/AER: Fix missing uevent on recovery when a reset is requested

[PATCH] media: rzg2l-cru: Drop function pointer to configure CSI
 2025-08-01  5:34 UTC 

[PATCH] LoongArch: KVM: Access mailbox directly in mail_send()
 2025-08-01  5:32 UTC  (4+ messages)

[GIT PULL] HID for 6.17 merge window
 2025-08-01  4:54 UTC  (2+ messages)

[GIT PULL] power-supply changes for 6.17
 2025-08-01  4:53 UTC  (2+ messages)

[GIT PULL] smb3 client fixes
 2025-08-01  4:52 UTC  (2+ messages)

[git pull] drm fixes for 6.17-rc1
 2025-08-01  4:51 UTC  (2+ messages)

linux-next: build warnings after merge of the drm-msm tree
 2025-08-01  4:46 UTC  (3+ messages)

linux-next: build warning after merge of the amdgpu tree
 2025-08-01  4:45 UTC  (2+ messages)

[PATCH v1 0/3] spidev: introduce trivial abb sensor device
 2025-08-01  4:45 UTC  (7+ messages)
` (subset) "

[PATCH v2 6/9] thermal/drivers/mediatek/lvts: Add support for ATP mode
 2025-08-01  4:44 UTC  (3+ messages)

[PATCHv9 00/16] x86: Enable Linear Address Space Separation support
 2025-08-01  4:43 UTC  (6+ messages)
` [PATCHv9 04/16] x86/cpu: Defer CR pinning setup until core initcall

[PATCH v2 2/2] cpufreq: CPPC: Dont read counters for idle CPUs
 2025-08-01  4:43 UTC  (11+ messages)

linux-next: build warnings after merge of the net-next tree
 2025-08-01  4:42 UTC  (2+ messages)

linux-next: build warning after merge of the vfs-brauner tree
 2025-08-01  4:38 UTC  (2+ messages)

[PATCH v11 00/24] zswap compression batching with optimized iaa_crypto driver
 2025-08-01  4:36 UTC  (25+ messages)
` [PATCH v11 01/24] crypto: iaa - Reorganize the iaa_crypto driver code
` [PATCH v11 02/24] crypto: iaa - New architecture for IAA device WQ comp/decomp usage & core mapping
` [PATCH v11 03/24] crypto: iaa - Simplify, consistency of function parameters, minor stats bug fix
` [PATCH v11 04/24] crypto: iaa - Descriptor allocation timeouts with mitigations
` [PATCH v11 05/24] crypto: iaa - iaa_wq uses percpu_refs for get/put reference counting
` [PATCH v11 06/24] crypto: iaa - Simplify the code flow in iaa_compress() and iaa_decompress()
` [PATCH v11 07/24] crypto: iaa - Refactor hardware descriptor setup into separate procedures
` [PATCH v11 08/24] crypto: iaa - Simplified, efficient job submissions for non-irq mode
` [PATCH v11 09/24] crypto: iaa - Deprecate exporting add/remove IAA compression modes
` [PATCH v11 10/24] crypto: iaa - Rearchitect the iaa_crypto driver to be usable by zswap and zram
` [PATCH v11 11/24] crypto: iaa - Enablers for submitting descriptors then polling for completion
` [PATCH v11 12/24] crypto: acomp - Add "void *kernel_data" in "struct acomp_req" for kernel users
` [PATCH v11 13/24] crypto: iaa - IAA Batching for parallel compressions/decompressions
` [PATCH v11 14/24] crypto: iaa - Enable async mode and make it the default
` [PATCH v11 15/24] crypto: iaa - Disable iaa_verify_compress by default
` [PATCH v11 16/24] crypto: iaa - Submit the two largest source buffers first in decompress batching
` [PATCH v11 17/24] crypto: iaa - Add deflate-iaa-dynamic compression mode
` [PATCH v11 18/24] crypto: acomp - Add crypto_acomp_batch_size() to get an algorithm's batch-size
` [PATCH v11 19/24] crypto: iaa - IAA acomp_algs register the get_batch_size() interface
` [PATCH v11 20/24] mm: zswap: Per-CPU acomp_ctx resources exist from pool creation to deletion
` [PATCH v11 21/24] mm: zswap: Consistently use IS_ERR_OR_NULL() to check acomp_ctx resources
` [PATCH v11 22/24] mm: zswap: Allocate pool batching resources if the compressor supports batching
` [PATCH v11 23/24] mm: zswap: zswap_store() will process a large folio in batches
` [PATCH v11 24/24] mm: zswap: Batched zswap_compress() with compress batching of large folios

[PATCH v2 0/3] pmdomain: core: Introduce device_set/get_out_band_wakeup
 2025-08-01  4:34 UTC  (4+ messages)
` [PATCH v2 1/3] pmdomain: core: Introduce device_set/get_out_band_wakeup()
` [PATCH v2 2/3] usb: chipidea: ci_hdrc_imx: Set out of band wakeup for i.MX95
` [PATCH v2 3/3] usb: dwc3: imx8mp: "

linux-next: build warnings after merge of the drm-misc tree
 2025-08-01  4:34 UTC  (2+ messages)

[RFC v2 0/4] add static huge zero folio support
 2025-08-01  4:30 UTC  (7+ messages)
` [RFC v2 1/4] mm: rename huge_zero_page_shrinker to huge_zero_folio_shrinker
` [RFC v2 2/4] mm: add static huge zero folio
` [RFC v2 3/4] mm: add largest_zero_folio() routine

[syzbot] [ntfs3?] KASAN: stack-out-of-bounds Read in unwind_next_frame (4)
 2025-08-01  4:30 UTC 

[PATCH v2 0/9] Add watchdog driver support for RZ/T2H and RZ/N2H SoCs
 2025-08-01  4:17 UTC  (17+ messages)
` [PATCH v2 2/9] watchdog: rzv2h_wdt: Obtain clock-divider ranges from OF match data
` [PATCH v2 3/9] watchdog: rzv2h_wdt: Obtain CKS divider via OF data
` [PATCH v2 4/9] watchdog: rzv2h_wdt: Make "oscclk" an optional clock
` [PATCH v2 5/9] watchdog: rzv2h_wdt: Add support for configurable count clock source
` [PATCH v2 6/9] watchdog: rzv2h_wdt: Make reset controller optional
` [PATCH v2 7/9] watchdog: rzv2h: Set min_timeout based on max_hw_heartbeat_ms
` [PATCH v2 8/9] watchdog: rzv2h: Add support for RZ/T2H
` [PATCH v2 9/9] watchdog: rzv2h_wdt: Improve error strings and add newlines

[syzbot] [gfs2?] KASAN: null-ptr-deref Write in gfs2_trans_add_revoke
 2025-08-01  4:12 UTC  (3+ messages)
` Forwarded: "
` [PATCH] gfs2: Correct use of trans

[syzbot] [gfs2?] KASAN: null-ptr-deref Write in gfs2_trans_add_revoke
 2025-08-01  4:11 UTC 

[PATCH v4 00/10] Coverage deduplication for KCOV
 2025-08-01  4:10 UTC  (3+ messages)
` [PATCH v4 09/10] kcov: selftests: add kcov_test

[PATCH] powerpc/64: Drop unnecessary 'rc' variable
 2025-08-01  3:59 UTC 

[PATCH RESEND v3 0/2] clk: spacemit: fix sspax_clk
 2025-08-01  3:25 UTC  (3+ messages)
` [PATCH RESEND v3 2/2] "

[PATCH v15 0/4] Support system sleep with offloaded usb transfers
 2025-08-01  3:39 UTC  (5+ messages)
` [PATCH v15 1/4] usb: xhci-plat: separate dev_pm_ops for each pm_event
` [PATCH v15 2/4] usb: offload: add apis for offload usage tracking
` [PATCH v15 3/4] xhci: sideband: add api to trace sideband usage
` [PATCH v15 4/4] usb: host: enable USB offload during system sleep

[PATCH v2 1/3] spi: atmel: simplify MR register update in cs_activate()
 2025-08-01  3:36 UTC  (4+ messages)
` [PATCH v2 2/3] spi: dt-bindings: atmel,at91rm9200-spi: Add support for optional 'spi_gclk' clock

[PATCH] net/mac80211: replace scnprintf() with sysfs_emit() for sysfs output
 2025-08-01  3:32 UTC  (2+ messages)

[PATCH v3] f2fs: add error checking in do_write_page()
 2025-08-01  3:30 UTC  (2+ messages)

linux-next: manual merge of the modules tree with the kbuild tree
 2025-08-01  3:29 UTC 

[PATCH] selftests: bpf: Add missing symbol declarations to common header
 2025-08-01  3:08 UTC  (2+ messages)

[PATCH 0/2] tpm: HMAC fix and cleanup
 2025-08-01  3:02 UTC  (4+ messages)
` [PATCH 1/2] tpm: Compare HMAC values in constant time

[PATCH RESEND] x86/kexec: Carry forward the boot DTB on kexec
 2025-08-01  3:02 UTC  (2+ messages)

[PATCH rc] iommu/arm-smmu-v3: Fix smmu_domain->nr_ats_masters decrement
 2025-08-01  3:01 UTC 

[PATCH v5 0/5] Display enablement changes for Qualcomm QCS8300 platform
 2025-08-01  2:50 UTC  (7+ messages)
` [PATCH v5 2/5] dt-bindings: display/msm: dp-controller: document QCS8300 compatible
` [PATCH v5 5/5] soc: qcom: ubwc: Add QCS8300 UBWC cfg

[PATCH RESEND] riscv: mmap(): use unsigned offset type in riscv_sys_mmap
 2025-08-01  2:49 UTC 

[PATCH 0/3] Improvements to ww_mutex test driver
 2025-08-01  2:46 UTC  (2+ messages)

[PATCH] clocksource: Use correct limit for wd-cs-wd read back delay in printing
 2025-08-01  2:42 UTC  (3+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox