The Linux Kernel Mailing List
 help / color / mirror / Atom feed
 messages from 2025-12-16 03:54:48 to 2025-12-16 06:56:45 UTC [more...]

[PATCH v3 00/11] drm/msm: Add support for Kaanapali
 2025-12-16  6:56 UTC  (7+ messages)
` [PATCH v3 05/11] drm/msm/mdss: "
` [PATCH v3 10/11] drm/msm/dpu: Refactor SSPP to compatible DPU 13.0.0

[PATCH v8 00/12] barrier: Add smp_cond_load_{relaxed,acquire}_timeout()
 2025-12-16  6:55 UTC  (4+ messages)
` [PATCH v8 12/12] cpuidle/poll_state: Wait for need-resched via tif_need_resched_relaxed_wait()

[PATCH v4] ocfs2: Add validate function for slot map blocks
 2025-12-16  6:55 UTC  (3+ messages)

[PATCH 00/26] Introduce meminspect
 2025-12-16  6:54 UTC  (5+ messages)

[PATCH] arm64: dts: toshiba: tmpv7708: Align node names with DT bindings
 2025-12-16  6:54 UTC  (2+ messages)

[PATCH] ARM: dts: samsung: Drop s3c6400.dtsi
 2025-12-16  6:53 UTC  (2+ messages)

[PATCH] perf bench: Add -t/--threads option to perf bench mem mmap
 2025-12-16  6:53 UTC  (4+ messages)

[PATCH v10 0/8] mm: folio_zero_user: clear contiguous pages
 2025-12-16  6:49 UTC  (6+ messages)
` [PATCH v10 7/8] mm, folio_zero_user: support clearing page ranges

[PATCH v1 0/5] hwmon: Add support for Altera SoCFPGA hardware monitoring
 2025-12-16  6:49 UTC  (6+ messages)
` [PATCH v1 1/5] dt-bindings: hwmon: add altr,socfpga-hwmon.yaml binding
` [PATCH v1 2/5] dt-bindings: firmware: svc: add hwmon property
` [PATCH v1 3/5] hwmon: (altr-hwmon): Add initial support for SoCFPGA
` [PATCH v1 4/5] arm64: dts: socfpga: stratix10: Add hwmon node
` [PATCH v1 5/5] arm64: dts: socfpga: agilex: "

[PATCH] KEYS: trusted: Use get_random-fallback for TPM
 2025-12-16  6:48 UTC  (5+ messages)

[PATCH v3 0/7] rust: build_assert: document and fix use with function arguments
 2025-12-16  6:48 UTC  (6+ messages)
` [PATCH v3 3/7] rust: cpufreq: always inline functions using build_assert with arguments

[PATCH 0/2] ASoC: codecs: ES8326 : Add Kcontrol
 2025-12-16  6:47 UTC  (3+ messages)
` [PATCH 1/2] ASoC: codecs: ES8326: Add a kcontrol for PGAGAIN
` [PATCH 2/2] ASoC: codecs: ES8326: Add kcontrol for DRE

[PATCH] Remove duplicate header file references
 2025-12-16  6:45 UTC  (2+ messages)
` [PATCH v2] kho: "

[PATCH RFC] alloc_tag: add option to pick the first codetag along callchain
 2025-12-16  6:43 UTC 

[PATCH v2] scsi: 3w-sas: validate request_id reported by controller
 2025-12-16  6:43 UTC  (3+ messages)

[PATCH] drm/radeon: Convert logging in radeon_display.c to drm_* helpers
 2025-12-16  6:42 UTC 

[PATCH v2 0/8] Generic IRQ entry/exit support for powerpc
 2025-12-16  6:41 UTC  (3+ messages)
` [PATCH v2 8/8] powerpc: Enable Generic Entry/Exit for syscalls

[PATCH v6] dma-buf: add some tracepoints to debug
 2025-12-16  6:39 UTC 

[PATCH v5 0/4] Align atomic storage
 2025-12-16  6:31 UTC  (5+ messages)
` [PATCH v5 1/4] bpf: Explicitly align bpf_res_spin_lock
` [PATCH v5 2/4] atomic: Specify alignment for atomic_t and atomic64_t
` [PATCH v5 4/4] atomic: Add option for weaker alignment check
` [PATCH v5 3/4] atomic: Add alignment check to instrumented atomic operations

[PATCH v2] platform/x86/intel/vsec: correct kernel-doc comments
 2025-12-16  6:38 UTC 

[PATCH] mm/shmem: add mTHP swpout fallback statistics in shmem_writeout()
 2025-12-16  6:34 UTC  (2+ messages)

[PATCH 0/3] gpio: pca953x: Add support for TCAL6408 TCAL6416
 2025-12-16  6:33 UTC  (3+ messages)
` [PATCH 3/3] dt-bindings: gpio: gpio-pca95xx: Add tcal6408 and tcal6416

[PATCH 0/4] Improve khugepaged scan logic
 2025-12-16  6:32 UTC  (8+ messages)
` [PATCH 2/4] mm: khugepaged: remove mm when all memory has been collapsed

[PATCH v2 7/8] powerpc: Enable IRQ generic entry/exit path
 2025-12-16  6:29 UTC  (2+ messages)

arch/arm64/kvm/arm.c:64:1: sparse: sparse: symbol '__pcpu_scope_kvm_arm_hyp_stack_base' was not declared. Should it be static?
 2025-12-16  6:29 UTC 

[PATCH 1/2] dt-bindings: power: fsl,imx-gpc: Document address-cells
 2025-12-16  6:28 UTC  (2+ messages)

kernel-doc comment with anonymous macro?
 2025-12-16  6:28 UTC  (2+ messages)

[PATCH 0/3] Implementation of Ascon-Hash256
 2025-12-16  6:27 UTC  (3+ messages)

[PATCH 0/8] Add support for AAEON SRG-IMX8PL MCU
 2025-12-16  6:25 UTC  (3+ messages)
` [PATCH 1/8] dt-bindings: vendor-prefixes: Add AAEON vendor prefix

[PATCH v5 0/6] io_uring: avoid uring_lock for IORING_SETUP_SINGLE_ISSUER
 2025-12-16  6:24 UTC  (5+ messages)
` [PATCH v5 6/6] "
` [syzbot ci] "

[PATCH v7 0/5] Add CCI and imx577 sensor support for monaco evk
 2025-12-16  6:22 UTC  (6+ messages)
` [PATCH v7 1/5] dt-bindings: i2c: qcom-cci: Document qcs8300 compatible
` [PATCH v7 2/5] arm64: dts: qcom: monaco: Add CCI definitions
` [PATCH v7 3/5] arm64: dts: qcom: monaco: Add camera MCLK pinctrl
` [PATCH v7 4/5] arm64: dts: qcom: monaco-evk: Add camera AVDD regulators
` [PATCH v7 5/5] arm64: dts: qcom: monaco-evk-camera: Add DT overlay

[PATCH v6 0/2] sched: update the rq->avg_idle when a task is moved to an idle CPU
 2025-12-16  6:22 UTC  (4+ messages)
` [PATCH v6 2/2] "

[PATCH] zram: drop pp_in_progress
 2025-12-16  6:22 UTC 

[PATCH] dt-bindings: kbuild: Support single binding targets
 2025-12-16  6:22 UTC  (2+ messages)

[PATCH v2 0/3] support batch checking of references and unmapping for large folios
 2025-12-16  6:22 UTC  (6+ messages)
` [PATCH v2 3/3] mm: rmap: support batched unmapping for file "

[PATCH 1/2] tools/build: Add a feature test for libopenssl
 2025-12-16  6:19 UTC  (7+ messages)

[PATCH] selftests/mm: Fix thread state check in uffd-unit-tests
 2025-12-16  6:15 UTC  (2+ messages)

[PATCH v3 0/4] gpu: nova-core: fixups for GSP message queue and bindings
 2025-12-16  6:14 UTC  (3+ messages)
` [PATCH v3 2/4] gpu: nova-core: gsp: fix length of received messages

[PATCH 0/4] Input: small nitpick fixes
 2025-12-16  6:13 UTC  (9+ messages)
` [PATCH 1/4] Input: stmfts - correct wording for the warning message
` [PATCH 2/4] Input: stmfts - Make comments correct
` [PATCH 3/4] Input: stmfts - use sysfs_emit() instead of sprintf()
` [PATCH 4/4] Input: stmfts - use client to make future code cleaner

[PATCH] fs/ext4: Remove unnecessary zero-initialization via memset
 2025-12-16  6:12 UTC  (2+ messages)

[PATCH v2 00/23] Cache aware scheduling
 2025-12-16  6:12 UTC  (8+ messages)
` [PATCH v2 01/23] sched/cache: Introduce infrastructure for cache-aware load balancing
` [PATCH v2 04/23] sched/cache: Make LLC id continuous

[PATCH 0/7] gpu: nova-core: run unload sequence upon unbinding
 2025-12-16  6:12 UTC  (9+ messages)
` [PATCH 1/7] rust: pci: pass driver data by value to `unbind`
` [PATCH 2/7] rust: add warn_on_err macro
` [PATCH 3/7] gpu: nova-core: use "
` [PATCH RFC 4/7] rust: pin-init: allow `dead_code` on projection structure
` [PATCH 5/7] gpu: nova-nova: use pin-init projections
` [PATCH 6/7] gpu: nova-core: send UNLOADING_GUEST_DRIVER GSP command GSP upon unloading
` [PATCH 7/7] gpu: nova-core: run Booter Unloader and FWSEC-SB upon unbinding

[PATCH v3] mhi: host: Add standard elf image download functionality
 2025-12-16  6:11 UTC  (5+ messages)

[RFC PATCH 0/3] ad9832: driver cleanup
 2025-12-16  6:08 UTC  (3+ messages)
` [RFC PATCH 3/3] dt-bindings: iio: add analog devices ad9832/ad9835

[PATCH next 2/2] mm/huge_memory: Add sysfs knob for executable THP COW
 2025-12-16  6:07 UTC  (2+ messages)

[PATCH v4] clocksource: timer-sp804: Fix read_current_timer() issue when clock source is not registered
 2025-12-16  6:05 UTC  (4+ messages)

[PATCH v2 0/3] riscv: dts: starfive: Append starfive,jh7110 compatible to VisionFive 2 Lite
 2025-12-16  6:05 UTC  (3+ messages)
` [PATCH v2 1/3] dt-bindings: riscv: starfive: Append JH-7110 SoC compatible to VisionFive 2 Lite board

[PATCH v2] ALSA: usb-mixer: us16x08: validate meter packet indices
 2025-12-16  6:01 UTC 

[PATCH v2 0/2] Add FRDM i.MX 91 Development board support
 2025-12-16  6:02 UTC  (3+ messages)
` [PATCH v2 1/2] dt-bindings: arm: imx Add FRDM-IMX91 board

6.19 tmpfs __d_lookup() lockup
 2025-12-16  6:02 UTC  (10+ messages)
              ` shmem_rename() bugs (was Re: 6.19 tmpfs __d_lookup() lockup)
                ` [git pull] shmem rename fixes

[PATCH v2] scsi: megaraid_mbox: validate numstatus and completed[] from firmware
 2025-12-16  6:01 UTC 

[PATCH v2] scsi: mptbase: bounds-check req_idx in reply paths
 2025-12-16  6:01 UTC 

[PATCH] hfsplus: fix missing hfs_bnode_get() in hfs_bnode_create()
 2025-12-16  6:01 UTC  (3+ messages)

[PATCH v2 00/20] Clean and update tilcdc driver to support DRM_BRIDGE_ATTACH_NO_CONNECTOR
 2025-12-16  6:02 UTC  (5+ messages)
` [PATCH v2 01/20] dt-bindings: display: tilcdc: Convert to DT schema
` [PATCH v2 02/20] dt-bindings: display: tilcdc: Mark panel binding as deprecated

[PATCH] dt-bindings: PCI: socionext,uniphier-pcie: Fix interrupt controller node name
 2025-12-16  5:59 UTC  (4+ messages)

[PATCH] perf build: Support passing extra Clang options via EXTRA_BPF_FLAGS
 2025-12-16  5:58 UTC  (10+ messages)

[PATCH RFC 0/3] remoteproc/qcom,q6v5: introduce IPQ9574
 2025-12-16  5:53 UTC  (3+ messages)
` [PATCH RFC 1/3] dt-bindings: remoteproc: qcom,ipq8074-wcss-pil: convert to DT schema

[PATCH v4 0/5] Add PCIe support for Kaanapali
 2025-12-16  5:48 UTC  (4+ messages)
` [PATCH v4 5/5] phy: qcom: qmp-pcie: add QMP PCIe PHY tables "

[PATCH v1 5/5] drm/panthor: Use GROUP_GET_STATE to provide group and queue errors
 2025-12-16  5:45 UTC  (2+ messages)

[PATCH v3 0/2] iommu: Avoid setting C-bit for MMIO addresses
 2025-12-16  5:40 UTC  (6+ messages)
` [PATCH v3 2/2] vfio/type1: Set IOMMU_MMIO in dma->prot for MMIO-backed addresses

[PATCH v2 0/4] PCI: tegra: A couple of cleanups
 2025-12-16  5:38 UTC  (3+ messages)
` [PATCH v2 1/4] dt-bindings: PCI: Convert nvidia,tegra-pcie to DT schema

[PATCH] dt-bindings: power: supply: Add Silergy SY6974B charger
 2025-12-16  5:33 UTC  (2+ messages)

[PATCH v8 00/13] cxl: ACPI PRM Address Translation Support and AMD Zen5 enablement
 2025-12-16  5:26 UTC  (5+ messages)
` [PATCH v8 12/13] cxl: Check if ULLONG_MAX was returned from translation functions
` [PATCH v8 13/13] cxl: Disable HPA/SPA translation handlers for Normalized addressing

[PATCH v3 0/3] firmware_loader: make RUST_FW_LOADER_ABSTRACTIONS select FW_LOADER
 2025-12-16  5:24 UTC  (4+ messages)
` [PATCH v3 2/3] gpu: nova-core: select RUST_FW_LOADER_ABSTRACTIONS

[RFC PATCH v3 00/59] struct filename work
 2025-12-16  5:23 UTC  (54+ messages)
` [RFC PATCH v3 01/59] do_faccessat(): import pathname only once
` [RFC PATCH v3 02/59] do_fchmodat(): "
` [RFC PATCH v3 03/59] do_fchownat(): "
` [RFC PATCH v3 10/59] get rid of audit_reusename()
` [RFC PATCH v3 11/59] ntfs: ->d_compare() must not block
` [RFC PATCH v3 12/59] getname_flags() massage, part 1
` [RFC PATCH v3 13/59] getname_flags() massage, part 2
` [RFC PATCH v3 14/59] struct filename: use names_cachep only for getname() and friends
` [RFC PATCH v3 15/59] struct filename: saner handling of long names
` [RFC PATCH v3 16/59] fs: hide names_cache behind runtime const machinery
` [RFC PATCH v3 17/59] allow incomplete imports of filenames
` [RFC PATCH v3 18/59] struct filename ->refcnt doesn't need to be atomic
` [RFC PATCH v3 19/59] allow to use CLASS() for struct filename *
` [RFC PATCH v3 20/59] file_getattr(): filename_lookup() accepts ERR_PTR() as filename
` [RFC PATCH v3 21/59] file_setattr(): "
` [RFC PATCH v3 22/59] move_mount(): "
` [RFC PATCH v3 23/59] ksmbd_vfs_path_lookup(): vfs_path_parent_lookup() accepts ERR_PTR() as name
` [RFC PATCH v3 24/59] ksmbd_vfs_rename(): "
` [RFC PATCH v3 25/59] do_filp_open(): DTRT when getting ERR_PTR() as pathname
` [RFC PATCH v3 26/59] rename do_filp_open() to do_file_open()
` [RFC PATCH v3 27/59] do_sys_openat2(): get rid of useless check, switch to CLASS(filename)
` [RFC PATCH v3 28/59] simplify the callers of file_open_name()
` [RFC PATCH v3 29/59] simplify the callers of do_open_execat()
` [RFC PATCH v3 30/59] simplify the callers of alloc_bprm()
` [RFC PATCH v3 31/59] switch {alloc,free}_bprm() to CLASS()
` [RFC PATCH v3 32/59] file_[gs]etattr(2): switch to CLASS(filename_maybe_null)
` [RFC PATCH v3 33/59] mount_setattr(2): don't mess with LOOKUP_EMPTY
` [RFC PATCH v3 34/59] do_open_execat(): don't care about LOOKUP_EMPTY
` [RFC PATCH v3 35/59] vfs_open_tree(): use CLASS(filename_uflags)
` [RFC PATCH v3 36/59] name_to_handle_at(): "
` [RFC PATCH v3 37/59] fspick(2): use CLASS(filename_flags)
` [RFC PATCH v3 38/59] do_fchownat(): unspaghettify a bit
` [RFC PATCH v3 39/59] chdir(2): "
` [RFC PATCH v3 40/59] do_utimes_path(): switch to CLASS(filename_uflags)
` [RFC PATCH v3 41/59] do_sys_truncate(): switch to CLASS(filename)
` [RFC PATCH v3 42/59] do_readlinkat(): switch to CLASS(filename_flags)
` [RFC PATCH v3 43/59] do_f{chmod,chown,access}at(): use CLASS(filename_uflags)
` [RFC PATCH v3 44/59] io_openat2(): use CLASS(filename_complete_delayed)
` [RFC PATCH v3 45/59] io_statx(): "
` [RFC PATCH v3 46/59] do_{renameat2,linkat,symlinkat}(): use CLASS(filename_consume)
` [RFC PATCH v3 47/59] do_{mknodat,mkdirat,unlinkat,rmdir}(): "
` [RFC PATCH v3 48/59] namei.c: convert getname_kernel() callers to CLASS(filename_kernel)
` [RFC PATCH v3 49/59] namei.c: switch user pathname imports to CLASS(filename{,_flags})
` [RFC PATCH v3 50/59] filename_...xattr(): don't consume filename reference
` [RFC PATCH v3 51/59] move_mount(2): switch to CLASS(filename_maybe_null)
` [RFC PATCH v3 53/59] quotactl_block(): switch to CLASS(filename)
` [RFC PATCH v3 54/59] statx: switch to CLASS(filename_maybe_null)
` [RFC PATCH v3 56/59] mqueue: switch to CLASS(filename)
` [RFC PATCH v3 57/59] ksmbd: use CLASS(filename_kernel)
` [RFC PATCH v3 58/59] alpha: switch osf_mount() to strndup_user()
` [RFC PATCH v3 59/59] sysfs(2): fs_index() argument is _not_ a pathname

[PATCH 2/3] i2c: k1: add reset support
 2025-12-16  5:21 UTC  (3+ messages)

[PATCH net v2] team: fix qom_list corruption by using list_del_init_rcu()
 2025-12-16  5:20 UTC  (2+ messages)

linux-next: trees being removed
 2025-12-16  5:19 UTC  (3+ messages)

[PATCH v6 00/14] Nesting support for lazy MMU mode
 2025-12-16  5:14 UTC  (3+ messages)
` [PATCH v6 03/14] powerpc/mm: implement arch_flush_lazy_mmu_mode()

[PATCH v2] block: add allocation size check in blkdev_pr_read_keys()
 2025-12-16  5:11 UTC 

[GIT PULL[ ksmbd server fixes
 2025-12-16  5:06 UTC 

[syzbot] [mm?] WARNING in blkdev_common_ioctl
 2025-12-16  5:04 UTC 

[PATCH next 1/2] mm/huge_memory: Implementation of THP COW for executable file mmap
 2025-12-16  5:03 UTC  (3+ messages)

[PATCH 1/1] firmware: stratix10-svc: stop kernel thread once service is completed
 2025-12-16  5:01 UTC  (3+ messages)

[syzbot] [net?] [nfc?] WARNING in nfc_dev_down
 2025-12-16  4:58 UTC  (2+ messages)

[PATCHSET v6 0/6] perf tools: Add deferred callchain support
 2025-12-16  4:48 UTC  (4+ messages)
` [PATCH v6 4/6] perf script: Display PERF_RECORD_CALLCHAIN_DEFERRED

[PATCH v2 2/2] platform/x86: thinkpad_acpi: Add sysfs to display details of damaged device
 2025-12-16  4:42 UTC  (2+ messages)

[Patch v5 00/19] Support SIMD/eGPRs/SSP registers sampling for perf
 2025-12-16  4:42 UTC  (2+ messages)

[PATCH v2 0/3] thermal: spacemit: Add support for SpacemiT K1 SoC thermal sensor
 2025-12-16  4:16 UTC  (3+ messages)
` [PATCH v2 2/3] thermal: spacemit: k1: Add thermal sensor support

[syzbot] [mm?] WARNING in blkdev_common_ioctl
 2025-12-16  4:39 UTC  (2+ messages)
` Forwarded: [PATCH] block: add allocation size check in blkdev_pr_read_keys()

[PATCH v2] wifi: ath11k: move .max_tx_ring to struct ath11k_hw_hal_params
 2025-12-16  4:35 UTC 

[PATCH] spi: stm32-ospi: Remove unneeded semicolon
 2025-12-16  4:32 UTC 

[PATCH v2 00/10] gpu: nova-core: miscellaneous improvements
 2025-12-16  4:27 UTC  (11+ messages)
` [PATCH v2 01/10] gpu: nova-core: gsp: warn if data remains after processing a message
` [PATCH v2 02/10] gpu: nova-core: gsp: remove unnecessary Display impls
` [PATCH v2 03/10] gpu: nova-core: gsp: simplify sequencer opcode parsing
` [PATCH v2 04/10] gpu: nova-core: gsp: remove unneeded sequencer trait
` [PATCH v2 05/10] gpu: nova-core: gsp: derive `Debug` on more sequencer types
` [PATCH v2 06/10] gpu: nova-core: gsp: derive Zeroable for GspStaticConfigInfo
` [PATCH v2 07/10] gpu: nova-core: firmware: fwsec: do not require bound device when unneeded
` [PATCH v2 08/10] gpu: nova-core: use core library's CStr instead of kernel one
` [PATCH v2 09/10] gpu: nova-core: simplify str_from_null_terminated
` [PATCH v2 10/10] gpu: nova-core: gsp: use available device reference

[PATCH v4 0/3] Add ITE IT61620 MIPI DSI to HDMI bridge driver
 2025-12-16  4:26 UTC  (3+ messages)
` [PATCH v4 1/3] dt-binding: display: Add ITE IT61620 MIPI DSI to HDMI bridge

[PATCH] bug: hush suggest-attribute=format for __warn_printf()
 2025-12-16  4:24 UTC  (2+ messages)

[PATCH net-next] ice: access @pp through netmem_desc instead of page
 2025-12-16  4:20 UTC  (2+ messages)

[PATCH 00/14] Assorted kernel-doc fixes
 2025-12-16  4:17 UTC  (3+ messages)
` [PATCH 06/14] virtio: Describe @map and @vmap members in virtio_device struct

[PATCH net v2] virtio-net: enable all napis before scheduling refill work
 2025-12-16  4:16 UTC  (2+ messages)

[PATCH v3] mm/vmalloc: clarify why vmap_range_noflush() might sleep
 2025-12-16  4:16 UTC  (2+ messages)

[PATCH v2] spi: cadence-quadspi: Parse DT for flashes with the rest of the DT parsing
 2025-12-16  4:08 UTC  (3+ messages)

[syzbot] [net?] [bpf?] general protection fault in bq_flush_to_queue (2)
 2025-12-16  4:06 UTC  (3+ messages)
` [PATCH] bpf: Fix NULL deref in __list_del_clearprev for flush_node

[syzbot] [wireless?] WARNING in ieee80211_ocb_rx_no_sta (2)
 2025-12-16  3:59 UTC  (2+ messages)
` [PATCH] mac80211: ocb: skip rx_no_sta when interface is not joined


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox