From: Johan Hovold <johan@kernel.org>
To: Bartosz Golaszewski <brgl@bgdev.pl>
Cc: Linus Walleij <linus.walleij@linaro.org>,
Andy Shevchenko <andriy.shevchenko@linux.intel.com>,
linux-gpio@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2 1/2] gpiolib: improve coding style for local variables
Date: Fri, 19 Nov 2021 08:57:00 +0100 [thread overview]
Message-ID: <YZdYzLqQgvA96LoU@hovoldconsulting.com> (raw)
In-Reply-To: <20211118132317.15898-1-brgl@bgdev.pl>
On Thu, Nov 18, 2021 at 02:23:16PM +0100, Bartosz Golaszewski wrote:
> Drop unneeded whitespaces and put the variables of the same type
> together for consistency with the rest of the code.
>
> Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl>
> Reviewed-by: Linus Walleij <linus.walleij@linaro.org>
> ---
> drivers/gpio/gpiolib.c | 7 +++----
> 1 file changed, 3 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/gpio/gpiolib.c b/drivers/gpio/gpiolib.c
> index abfbf546d159..20d63028b85c 100644
> --- a/drivers/gpio/gpiolib.c
> +++ b/drivers/gpio/gpiolib.c
> @@ -594,11 +594,10 @@ int gpiochip_add_data_with_key(struct gpio_chip *gc, void *data,
> struct lock_class_key *request_key)
> {
> struct fwnode_handle *fwnode = gc->parent ? dev_fwnode(gc->parent) : NULL;
> - unsigned long flags;
> - int ret = 0;
> - unsigned i;
> - int base = gc->base;
> + int ret = 0, base = gc->base;
This only makes the code harder to read for no good reason.
Keep declarations on separate lines, especially if also initialising.
Note that all but one function in this file initialises return value
variables on their own lines too (as they should).
> struct gpio_device *gdev;
> + unsigned long flags;
> + unsigned int i;
>
> /*
> * First: allocate and populate the internal stat container, and
Johan
prev parent reply other threads:[~2021-11-19 7:57 UTC|newest]
Thread overview: 13+ messages / expand[flat|nested] mbox.gz Atom feed top
2021-11-18 13:23 [PATCH v2 1/2] gpiolib: improve coding style for local variables Bartosz Golaszewski
2021-11-18 13:23 ` [PATCH v2 2/2] gpiolib: check the 'ngpios' property in core gpiolib code Bartosz Golaszewski
2021-11-18 15:44 ` Andy Shevchenko
2021-11-18 16:38 ` Bartosz Golaszewski
2021-11-18 17:01 ` Andy Shevchenko
2021-11-18 17:06 ` Andy Shevchenko
2021-11-18 17:05 ` Andy Shevchenko
2021-11-18 20:12 ` Bartosz Golaszewski
2021-11-18 21:16 ` Andy Shevchenko
2021-11-19 19:35 ` Bartosz Golaszewski
2021-11-22 11:20 ` Andy Shevchenko
2021-11-18 15:44 ` [PATCH v2 1/2] gpiolib: improve coding style for local variables Andy Shevchenko
2021-11-19 7:57 ` Johan Hovold [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=YZdYzLqQgvA96LoU@hovoldconsulting.com \
--to=johan@kernel.org \
--cc=andriy.shevchenko@linux.intel.com \
--cc=brgl@bgdev.pl \
--cc=linus.walleij@linaro.org \
--cc=linux-gpio@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox