From: Catalin Marinas <catalin.marinas@arm.com>
To: Yunfeng Ye <yeyunfeng@huawei.com>
Cc: will@kernel.org, wangkefeng.wang@huawei.com,
linux-arm-kernel@lists.infradead.org,
linux-kernel@vger.kernel.org, wuxu.wu@huawei.com,
Hewenliang <hewenliang4@huawei.com>
Subject: Re: [PATCH v2 1/2] arm64: mm: Rename asid2idx() to ctxid2asid()
Date: Wed, 8 Dec 2021 18:25:09 +0000 [thread overview]
Message-ID: <YbD4hcSWKEXSL1hg@arm.com> (raw)
In-Reply-To: <506863a9-b934-3af3-c70d-3284e14478de@huawei.com>
On Wed, Dec 08, 2021 at 05:16:45PM +0800, Yunfeng Ye wrote:
> The commit 0c8ea531b774 ("arm64: mm: Allocate ASIDs in pairs") introduce
> the asid2idx and idx2asid macro, but these macros are not really useful
> after the commit f88f42f853a8 ("arm64: context: Free up kernel ASIDs if
> KPTI is not in use").
>
> The code "(asid & ~ASID_MASK)" can be instead by a macro, which is the
> same code with asid2idx(). So rename it to ctxid2asid() for a better
> understanding.
>
> Also we add asid2ctxid() macro, the contextid can be generated based on
> the asid and generation through this macro.
The changes look fine to me but please repost with your Signed-off-by.
Thanks.
--
Catalin
next prev parent reply other threads:[~2021-12-08 18:25 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
2021-12-08 9:16 [PATCH v2 1/2] arm64: mm: Rename asid2idx() to ctxid2asid() Yunfeng Ye
2021-12-08 9:17 ` [PATCH v2 2/2] arm64: mm: Use asid feature macro for cheanup Yunfeng Ye
2021-12-08 9:35 ` Kefeng Wang
2021-12-09 1:36 ` Yunfeng Ye
2021-12-08 18:25 ` Catalin Marinas [this message]
2021-12-09 1:35 ` [PATCH v2 1/2] arm64: mm: Rename asid2idx() to ctxid2asid() Yunfeng Ye
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=YbD4hcSWKEXSL1hg@arm.com \
--to=catalin.marinas@arm.com \
--cc=hewenliang4@huawei.com \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=wangkefeng.wang@huawei.com \
--cc=will@kernel.org \
--cc=wuxu.wu@huawei.com \
--cc=yeyunfeng@huawei.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox