From: Frederic Weisbecker <frederic@kernel.org>
To: Joel Fernandes <joelagnelf@nvidia.com>
Cc: "Paul E. McKenney" <paulmck@kernel.org>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
Neeraj Upadhyay <neeraj.upadhyay@kernel.org>,
Joel Fernandes <joel@joelfernandes.org>,
Josh Triplett <josh@joshtriplett.org>,
Boqun Feng <boqun.feng@gmail.com>,
Uladzislau Rezki <urezki@gmail.com>,
Steven Rostedt <rostedt@goodmis.org>,
Mathieu Desnoyers <mathieu.desnoyers@efficios.com>,
Lai Jiangshan <jiangshanlai@gmail.com>,
Zqiang <qiang.zhang1211@gmail.com>,
"rcu@vger.kernel.org" <rcu@vger.kernel.org>
Subject: Re: [1/3] rcu: Replace magic number with meaningful constant in rcu_seq_done_exact() - Patchwork
Date: Wed, 2 Apr 2025 16:22:31 +0200 [thread overview]
Message-ID: <Z-1IJ34Xb6RzucCQ@localhost.localdomain> (raw)
In-Reply-To: <8c8932fd34334718e94f979f9bab2fb7.joelagnelf@nvidia.com>
Le Tue, Apr 01, 2025 at 12:30:40PM -0400, Joel Fernandes a écrit :
> Hello, Frederic,
>
> On Tue, 1 Apr 2025 16:27:36 GMT, Frederic Weisbecker wrote:
> > Le Mon, Mar 31, 2025 at 02:29:52PM -0700, Paul E. McKenney a écrit :
> > > The disagreement is a feature, at least up to a point. That feature
> > > allows CPUs to go idle for long periods without RCU having to bother
> > > them or to mess with their per-CPU data (give or take ->gpwrap). It also
> > > allows per-rcu_node-leaf locking, which is important on large systems.
> > >
> > > Trying to make precisely globally agreed-on beginnings and ends of
> > > RCU grace periods will not end well from performance, scalability,
> > > or real-time-response viewpoints. ;-)
> >
> > The distributed disagreement is definetly a feature. The duplicate root
> > is more debatable.
> >
> > > But simplifications that don't hurt performance, scalability, and
> > > real-time-response are of course welcome.
> >
> > I'm not even sure my proposal is a simplification. Perhaps it is. Another
> > hope is that it could avoid future accidents.
> >
>
> Aside from the performance concerns:
>
> Sorry if this is silly but could you provide a small hint as to how
> unifying the global counter with the node affects QS reporting or hotplug?
> It was not immediately obvious to me. Thanks for the help.
First of all rcu_seq_start() must be before the hotplug scan, otherwise
you run into this:
rcu_state.gp_seq = 4
CPU0/ rcu_gp_kthread() CPU 1 CPU 2
------------- ---------- -----------
//rcu_gp_init()
rcu_for_each_leaf_node(rnp) {
raw_spin_lock_rcu_node(rnp);
rnp->qsmaskinit = rnp->qsmaskinitnext
raw_spin_unlock_rcu_node(rnp);
}
rcutree_report_cpu_starting()
raw_spin_lock_rcu_node(rnp);
rnp->qsmaskinitnext |= rdp->grpmask
raw_spin_unlock_rcu_node(rnp);
rcu_read_lock()
r0 = *X
r1 = *X
X = NULL
cookie = get_state_sychronize_rcu()
//cookie = 8
rcu_seq_start(&rcu_state.gp_seq)
//rcu_state.gp_seq == 5
rcu_for_each_node_breadth_first(rnp) {
raw_spin_lock_rcu_node(rnp);
// Ignore CPU 1
rnp->qsmask = rnp->qsmaskinit;
raw_spin_unlock_rcu_node(rnp);
}
[...]
//rcu_gp_cleanup()
rcu_seq_end(&rcu_state.gp_seq)
// rcu_state.gp_seq == 8
poll_state_sychronize_rcu(cookie)
kfree(r1)
r2 = *r0 // CRASH
So the same applies if we convert rcu_state to use the root node.
But if we do rcu_seq_start() on the root node, then an update side
can call note_gp_changes() because of the state change (only if the
root node is also the unique leaf). But this then happens before
the loop that initializes all the ->qsmask
It's not a correctness problem because it won't make the rdp to
report a QS too early, since rnp->qsmask isn't intialized anyway,
but note_gp_changes() would needlessly lock the rnp lock to record
the state change in rdp->gp_seq.
This is why we need an intermediate state called RCU_SEQ_STARTED
during which note_gp_changes() can safely ignore the state change.
Then once the root's qsmask is initialized, the state can switch
to RCU_SEQ_WAIT_QS, after which calling note_gp_changes() becomes
useful.
Hope that helped.
Thanks.
next prev parent reply other threads:[~2025-04-02 14:22 UTC|newest]
Thread overview: 3+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-04-01 16:30 [1/3] rcu: Replace magic number with meaningful constant in rcu_seq_done_exact() - Patchwork Joel Fernandes
2025-04-02 14:22 ` Frederic Weisbecker [this message]
2025-04-05 11:23 ` Joel Fernandes
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=Z-1IJ34Xb6RzucCQ@localhost.localdomain \
--to=frederic@kernel.org \
--cc=boqun.feng@gmail.com \
--cc=jiangshanlai@gmail.com \
--cc=joel@joelfernandes.org \
--cc=joelagnelf@nvidia.com \
--cc=josh@joshtriplett.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mathieu.desnoyers@efficios.com \
--cc=neeraj.upadhyay@kernel.org \
--cc=paulmck@kernel.org \
--cc=qiang.zhang1211@gmail.com \
--cc=rcu@vger.kernel.org \
--cc=rostedt@goodmis.org \
--cc=urezki@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox