From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from mail-wm1-f53.google.com (mail-wm1-f53.google.com [209.85.128.53]) (using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)) (No client certificate requested) by smtp.subspace.kernel.org (Postfix) with ESMTPS id 045441DF25A for ; Thu, 16 Jan 2025 11:34:16 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; arc=none smtp.client-ip=209.85.128.53 ARC-Seal:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1737027258; cv=none; b=kgsBWggRGq8bQce1E5+GGe057Y0ASpSsWoiRBOmYJn0Ldkbq4kv/ndrBJuiuRBHppxFZec5fuhIDibHdXTYskV4BU2DIDXoujTh8Q2jkHLvNeg5hGrLC67aXcb4Vz3ISUnsL3xDik/ypU6WIhTfOzyhoz83I1dJwgJ8QrC9byAI= ARC-Message-Signature:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1737027258; c=relaxed/simple; bh=wRdABTSuBNGtp8zBEek0Enpvhtjjj8uaJF4CLNbhRn4=; h=Date:From:To:Cc:Subject:Message-ID:References:MIME-Version: Content-Type:Content-Disposition:In-Reply-To; b=i+bD0RWGQFCbaXEaYZeGgcRqjbZLYTVR/jr3H9XXHwmRA5YeHbq23EY5luV4l2AddoOLy6+lcxNXnToh3wWyNxpJ6H3F9Ks0vxL6U67SOPqQjo6ZFVCYBL8dpnLjwYCpVaPZE1ncZ5U2DkkObHt/0zp/3QsySNEUx4msWyc8FD8= ARC-Authentication-Results:i=1; smtp.subspace.kernel.org; dmarc=none (p=none dis=none) header.from=ffwll.ch; spf=none smtp.mailfrom=ffwll.ch; dkim=pass (1024-bit key) header.d=ffwll.ch header.i=@ffwll.ch header.b=dXPvuJao; arc=none smtp.client-ip=209.85.128.53 Authentication-Results: smtp.subspace.kernel.org; dmarc=none (p=none dis=none) header.from=ffwll.ch Authentication-Results: smtp.subspace.kernel.org; spf=none smtp.mailfrom=ffwll.ch Authentication-Results: smtp.subspace.kernel.org; dkim=pass (1024-bit key) header.d=ffwll.ch header.i=@ffwll.ch header.b="dXPvuJao" Received: by mail-wm1-f53.google.com with SMTP id 5b1f17b1804b1-43621d27adeso4690325e9.2 for ; Thu, 16 Jan 2025 03:34:16 -0800 (PST) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=ffwll.ch; s=google; t=1737027255; x=1737632055; darn=vger.kernel.org; h=in-reply-to:content-disposition:mime-version:references :mail-followup-to:message-id:subject:cc:to:from:date:from:to:cc :subject:date:message-id:reply-to; bh=v4MJGnyq9Jr4SltNGHPkGuJ4PxUjxoIzJSXslir8OU0=; b=dXPvuJaodGYnoDGWqR+fI/bu1XYuMCWU7L7p0TVqPb8UxSszOr0wvq/IflZ3KhP8pA N3RSo/rJL4MGQmr/f+e+T/Dyo51+/1SY7lfWewIIKWT8jGrhPfAW6ntMsvQ+pvfi9hnV yCOq/IBWj42fwPhAcyVh4teHj/UP7OjhAC3Lc= X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20230601; t=1737027255; x=1737632055; h=in-reply-to:content-disposition:mime-version:references :mail-followup-to:message-id:subject:cc:to:from:date :x-gm-message-state:from:to:cc:subject:date:message-id:reply-to; bh=v4MJGnyq9Jr4SltNGHPkGuJ4PxUjxoIzJSXslir8OU0=; b=knuc2iQmuZ5tw+qHawopw61X3M0yLvdVgz6YdbAt8Flt0MKyXdRpFIPgeP/4ia7RXQ ou6EeSP9rvB2GfK7A+X0urnDSmYFfZkPRLutxUHI87G3lBgHTMAePU2C/yu+lwNsthig qJBhGMTRG0cmgFk12YOchwuN4U2/wM6fB1jp+56HyKrnH+40pMcPWyEYEFOG/bSuvshx vN3WQkZyI1WfRMcZafXBZY9LEG7ieoTpOsKFaO9bVF8ykxsHzQOVuIPdRBFXuzX2vesE jtdmI1EbvAWCV31910X1mFSFRwtHpUDnOaqFcTuEwii2o+jh4DC8OzWoFfFWU2WL5i3h 6R3Q== X-Forwarded-Encrypted: i=1; AJvYcCU56iioY3FwjCQz3wz+w/h1F2LKYZ5kJBmulVQfMyaYvjMUmw2Gev1+CK0IESIkG5lVxek21Q2tZpSpf1k=@vger.kernel.org X-Gm-Message-State: AOJu0Yzd+vselBOwqpmOzu2tmUqgyB9KSYkZI0NjJ1YDUqTkFMKtQ73d KX0Guo4hxVGZQEbdSoD+PbCOXhCPxtcu4whXRGTtgRXbV+jILL5lPWi4en/corg= X-Gm-Gg: ASbGncuOzQ9xSLp1R1p/byW85MnCxvKCsWfQfZPVl4qVrun4DBSRk0D7vynsIQhrytB ZbT8vveDjGqAkucS8PHdNDGyIlTAS+ZlCg5dmpGmrTAkS+Q+9RFedwibUfWqCPENx90gdx3vCC9 lo9rM8+F5eGdpA9lAXza6r0qkmo6DLi6jKdFtRdLM31OHTw5MQTPrV1skG3FQWBHdLAnFTCJqfK JwWW/cmOstK4Ee6ueB8cyDeyCyjaBGCVKgEuf16mg60cbRai37OtpS3GvK7eBGKLZk9 X-Google-Smtp-Source: AGHT+IErj50kwukc85huKkCJYLaART5mT2IODUndO+0Igb2Ypw4ChGIORsEB547GA+IhAvPghnXWOw== X-Received: by 2002:a05:600c:5125:b0:434:eb73:b0c0 with SMTP id 5b1f17b1804b1-436e266f994mr334857565e9.5.1737027255152; Thu, 16 Jan 2025 03:34:15 -0800 (PST) Received: from phenom.ffwll.local ([2a02:168:57f4:0:5485:d4b2:c087:b497]) by smtp.gmail.com with ESMTPSA id 5b1f17b1804b1-437c7528076sm57644835e9.25.2025.01.16.03.34.14 (version=TLS1_3 cipher=TLS_AES_256_GCM_SHA384 bits=256/256); Thu, 16 Jan 2025 03:34:14 -0800 (PST) Date: Thu, 16 Jan 2025 12:34:12 +0100 From: Simona Vetter To: Maxime Ripard Cc: Maarten Lankhorst , Thomas Zimmermann , David Airlie , Simona Vetter , Andrzej Hajda , Neil Armstrong , Robert Foss , Laurent Pinchart , Jonas Karlman , Jernej Skrabec , Douglas Anderson , dri-devel@lists.freedesktop.org, linux-kernel@vger.kernel.org Subject: Re: [PATCH 22/29] drm/bridge: Rename atomic hooks parameters to drop old prefix Message-ID: Mail-Followup-To: Maxime Ripard , Maarten Lankhorst , Thomas Zimmermann , David Airlie , Simona Vetter , Andrzej Hajda , Neil Armstrong , Robert Foss , Laurent Pinchart , Jonas Karlman , Jernej Skrabec , Douglas Anderson , dri-devel@lists.freedesktop.org, linux-kernel@vger.kernel.org References: <20250115-bridge-connector-v1-0-9a2fecd886a6@kernel.org> <20250115-bridge-connector-v1-22-9a2fecd886a6@kernel.org> Precedence: bulk X-Mailing-List: linux-kernel@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20250115-bridge-connector-v1-22-9a2fecd886a6@kernel.org> X-Operating-System: Linux phenom 6.12.3-amd64 On Wed, Jan 15, 2025 at 10:05:29PM +0100, Maxime Ripard wrote: > All the bridge atomic hooks were using the old_bridge_state name for > their drm_bridge_state parameter. However, this state is the current > state being committed for all of them, which ends up being confusing. > > Let's rename it to bridge_state for all of them. > > Signed-off-by: Maxime Ripard > --- > include/drm/drm_bridge.h | 8 ++++---- > 1 file changed, 4 insertions(+), 4 deletions(-) > > diff --git a/include/drm/drm_bridge.h b/include/drm/drm_bridge.h > index 4b84faf14e368310dd20aa964e8178ec80aa6fa7..8e18130be8bb85fc2463917dde9bf1d281934184 100644 > --- a/include/drm/drm_bridge.h > +++ b/include/drm/drm_bridge.h > @@ -303,11 +303,11 @@ struct drm_bridge_funcs { > * there is one) when this callback is called. > * > * The @atomic_pre_enable callback is optional. > */ > void (*atomic_pre_enable)(struct drm_bridge *bridge, > - struct drm_bridge_state *old_bridge_state); > + struct drm_bridge_state *bridge_state); > > /** > * @atomic_enable: > * > * This callback should enable the bridge. It is called right after > @@ -323,11 +323,11 @@ struct drm_bridge_funcs { > * chain if there is one. > * > * The @atomic_enable callback is optional. > */ > void (*atomic_enable)(struct drm_bridge *bridge, > - struct drm_bridge_state *old_bridge_state); > + struct drm_bridge_state *bridge_state); Checked this one, and it very clearly passes the old state. Because the new state you can get by looking at bridge->state. So this looks very wrong. If you want to fully update the pattern, pass the drm_atomic_state instead, and let callbacks lookup any additional states they use as needed. -Sima > /** > * @atomic_disable: > * > * This callback should disable the bridge. It is called right before > * the preceding element in the display pipe is disabled. If the > @@ -340,11 +340,11 @@ struct drm_bridge_funcs { > * signals) feeding it is still running when this callback is called. > * > * The @atomic_disable callback is optional. > */ > void (*atomic_disable)(struct drm_bridge *bridge, > - struct drm_bridge_state *old_bridge_state); > + struct drm_bridge_state *bridge_state); > > /** > * @atomic_post_disable: > * > * This callback should disable the bridge. It is called right after the > @@ -359,11 +359,11 @@ struct drm_bridge_funcs { > * called. > * > * The @atomic_post_disable callback is optional. > */ > void (*atomic_post_disable)(struct drm_bridge *bridge, > - struct drm_bridge_state *old_bridge_state); > + struct drm_bridge_state *bridge_state); > > /** > * @atomic_duplicate_state: > * > * Duplicate the current bridge state object (which is guaranteed to be > > -- > 2.47.1 > -- Simona Vetter Software Engineer, Intel Corporation http://blog.ffwll.ch