The Linux Kernel Mailing List
 help / color / mirror / Atom feed
From: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
To: Krzysztof Kozlowski <krzk@kernel.org>
Cc: Michael Wu <Michael.Wu@kneron.us>,
	Jarkko Nikula <jarkko.nikula@linux.intel.com>,
	Mika Westerberg <mika.westerberg@linux.intel.com>,
	Jan Dabros <jsd@semihalf.com>,
	"linux-i2c@vger.kernel.org" <linux-i2c@vger.kernel.org>,
	Andi Shyti <andi.shyti@kernel.org>,
	morgan chang <morgan.chang@kneron.us>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH 1/2] i2c: designware: determine HS tHIGH and tLOW based on HW paramters
Date: Thu, 26 Sep 2024 17:09:02 +0300	[thread overview]
Message-ID: <ZvVq_sBK3T5wHZd4@smile.fi.intel.com> (raw)
In-Reply-To: <ecfb3621-fb8e-4452-a83f-bfe5f0b03398@kernel.org>

On Thu, Sep 26, 2024 at 03:50:07PM +0200, Krzysztof Kozlowski wrote:
> On 26/09/2024 14:18, Andy Shevchenko wrote:
> > On Thu, Sep 26, 2024 at 08:45:47AM +0000, Michael Wu wrote:
> >>> On Wed, Sep 25, 2024 at 12:16:10PM +0300, Andy Shevchenko wrote:
> >>>> On Wed, Sep 25, 2024 at 04:04:30PM +0800, Michael Wu wrote:

...

> >>>>> + * @bus_loading: for high speed mode, the bus loading affects the high
> >>> and low
> >>>>> + *	pulse width of SCL
> >>>>
> >>>> This is bad naming, better is bus_capacitance.
> >>>
> >>> Even more specific bus_capacitance_pf as we usually add physical units to the
> >>> variable names, so we immediately understand from the code the order of
> >>> numbers and their physical meanings. 
> >>
> >> Sounds good. However, I think the length of "bus_capacitance_pf" is a bit
> >> long, we may often encounter the limit of more than 80 characters in a
> >> line when coding. I'll rename it to "bus_cap_pf".
> > 
> > Limit had been relaxed to 100. I still think we may use temporary variables,
> 
> Just to be clear, because you encourage reformatting it to 100:
> 
> You mix coding style with checkpatch. Checkpatch does not define coding
> style. Coding style doc defines it. Limit is 80, unless growing to 100
> improves readability.

Somebody can still use land line rotary phones, while others are
on mobile ones, indeed. :-)

Jokes aside, the second part of my remark was in regard to how to make
the lines shorter in case somebody is so picky about 80 limit.

> > if needed, in order to make code neater. That said, I slightly prefer
> > bus_capacitance_pf over the shortened variant.

-- 
With Best Regards,
Andy Shevchenko



  reply	other threads:[~2024-09-26 14:09 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-09-25  8:04 [PATCH 0/2] Compute HS HCNT and LCNT based on HW parameters Michael Wu
2024-09-25  8:04 ` [PATCH 1/2] i2c: designware: determine HS tHIGH and tLOW based on HW paramters Michael Wu
2024-09-25  9:16   ` Andy Shevchenko
2024-09-25  9:21     ` Andy Shevchenko
2024-09-26  8:45       ` Michael Wu
2024-09-26 12:18         ` Andy Shevchenko
2024-09-26 13:50           ` Krzysztof Kozlowski
2024-09-26 14:09             ` Andy Shevchenko [this message]
2024-09-25 10:58   ` Jarkko Nikula
2024-09-25 11:02     ` Andy Shevchenko
2024-09-26  9:11     ` Michael Wu
2024-09-25 11:33   ` Krzysztof Kozlowski
2024-09-27 13:41   ` kernel test robot
2024-09-25  8:04 ` [PATCH 2/2] dt-bindings: i2c: snps,designware-i2c: add bus-loading and clk-freq-optimized Michael Wu
2024-09-25 11:32   ` Krzysztof Kozlowski

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=ZvVq_sBK3T5wHZd4@smile.fi.intel.com \
    --to=andriy.shevchenko@linux.intel.com \
    --cc=Michael.Wu@kneron.us \
    --cc=andi.shyti@kernel.org \
    --cc=jarkko.nikula@linux.intel.com \
    --cc=jsd@semihalf.com \
    --cc=krzk@kernel.org \
    --cc=linux-i2c@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mika.westerberg@linux.intel.com \
    --cc=morgan.chang@kneron.us \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox