From: Neil Armstrong <neil.armstrong@linaro.org>
To: Manivannan Sadhasivam <mani@kernel.org>
Cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
Rob Herring <robh@kernel.org>,
Krzysztof Kozlowski <krzk+dt@kernel.org>,
Conor Dooley <conor+dt@kernel.org>,
Geert Uytterhoeven <geert+renesas@glider.be>,
Magnus Damm <magnus.damm@gmail.com>,
Bartosz Golaszewski <brgl@kernel.org>,
Bjorn Helgaas <bhelgaas@google.com>,
Bjorn Andersson <andersson@kernel.org>,
Konrad Dybcio <konradybcio@kernel.org>,
linux-usb@vger.kernel.org, devicetree@vger.kernel.org,
linux-kernel@vger.kernel.org, linux-renesas-soc@vger.kernel.org,
linux-pci@vger.kernel.org, linux-arm-msm@vger.kernel.org
Subject: Re: [PATCH v3 4/9] pci: pwrctrl: generic: support for the UPD720201/UPD720202 USB 3.0 xHCI Host Controller
Date: Mon, 9 Feb 2026 15:00:02 +0100 [thread overview]
Message-ID: <a4e55e91-0e03-4e63-8542-d8ad61b38906@linaro.org> (raw)
In-Reply-To: <fbxbnou5mdlhaq5dpxr3wdzmjetwdp7auaaqeunc67tgk5ej2m@cnnkr2pcwy77>
On 2/9/26 12:30, Manivannan Sadhasivam wrote:
> On Fri, Feb 06, 2026 at 03:50:32PM +0100, Neil Armstrong wrote:
>> Enable the generic pwrctrl driver to control the power of the
>> PCIe UPD720201/UPD720202 USB 3.0 xHCI Host Controller.
>>
>> Signed-off-by: Neil Armstrong <neil.armstrong@linaro.org>
>> ---
>> drivers/pci/pwrctrl/generic.c | 4 ++++
>> 1 file changed, 4 insertions(+)
>>
>> diff --git a/drivers/pci/pwrctrl/generic.c b/drivers/pci/pwrctrl/generic.c
>> index 08e53243cdbd..4a57a631362f 100644
>> --- a/drivers/pci/pwrctrl/generic.c
>> +++ b/drivers/pci/pwrctrl/generic.c
>> @@ -73,6 +73,10 @@ static const struct of_device_id pci_pwrctrl_slot_of_match[] = {
>> {
>> .compatible = "pciclass,0604",
>> },
>> + /* Renesas UPD720201/UPD720202 USB 3.0 xHCI Host Controller */
>> + {
>> + .compatible = "pci1912,0014",
>
> No need to add the compatible to the driver. Just use the existing compatible as
> fallback in the binding/dts.
???
Sorry but this is insane, in no world a standalone PCIe USB controller could be qualified as
compatible as a pciclass,0604 slot.
Technically it would work just fine, but "compatibility" has a meaning....
Neil
>
> - Mani
>
next prev parent reply other threads:[~2026-02-09 14:00 UTC|newest]
Thread overview: 29+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-02-06 14:50 [PATCH v3 0/9] arm64: dts: qcom: Add support for the Ayaneo Pocket S2 Neil Armstrong
2026-02-06 14:50 ` [PATCH v3 1/9] dt-bindings: usb: document the Renesas UPD720201/UPD720202 USB 3.0 xHCI Host Controller Neil Armstrong
2026-02-10 2:37 ` Rob Herring (Arm)
2026-02-12 15:17 ` Bjorn Andersson
2026-02-13 8:25 ` Neil Armstrong
2026-02-06 14:50 ` [PATCH v3 2/9] pci: pwrctrl: slot: fix dev_err_probe() usage Neil Armstrong
2026-02-06 15:13 ` Bartosz Golaszewski
2026-02-06 14:50 ` [PATCH v3 3/9] pci: pwrctrl: rename pci-pwrctrl-slot as generic Neil Armstrong
2026-02-09 11:31 ` Manivannan Sadhasivam
2026-02-09 11:33 ` Manivannan Sadhasivam
2026-02-09 13:57 ` Neil Armstrong
2026-02-06 14:50 ` [PATCH v3 4/9] pci: pwrctrl: generic: support for the UPD720201/UPD720202 USB 3.0 xHCI Host Controller Neil Armstrong
2026-02-09 11:30 ` Manivannan Sadhasivam
2026-02-09 14:00 ` Neil Armstrong [this message]
2026-02-09 14:49 ` Manivannan Sadhasivam
2026-02-09 14:59 ` Neil Armstrong
2026-02-10 8:00 ` Manivannan Sadhasivam
2026-02-10 9:01 ` Neil Armstrong
2026-02-10 11:03 ` Manivannan Sadhasivam
2026-02-10 12:25 ` Dmitry Baryshkov
2026-02-06 14:50 ` [PATCH v3 5/9] arm64: defconfig: enable pci-pwrctrl-generic as module Neil Armstrong
2026-02-09 11:32 ` Manivannan Sadhasivam
2026-02-06 14:50 ` [PATCH v3 6/9] dt-binding: vendor-prefixes: document the Ayaneo brand Neil Armstrong
2026-02-06 14:50 ` [PATCH v3 7/9] dt-bindings: arm: qcom: document the Ayaneo Pocket S2 Neil Armstrong
2026-02-06 23:16 ` Rob Herring (Arm)
2026-02-06 14:50 ` [PATCH v3 8/9] arm64: dts: qcom: sm8650: Add sound DAI prefix for DP Neil Armstrong
2026-02-06 14:50 ` [PATCH v3 9/9] arm64: dts: qcom: add basic devicetree for Ayaneo Pocket S2 gaming console Neil Armstrong
2026-02-06 21:35 ` [PATCH v3 0/9] arm64: dts: qcom: Add support for the Ayaneo Pocket S2 Bjorn Helgaas
2026-02-09 9:15 ` Neil Armstrong
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=a4e55e91-0e03-4e63-8542-d8ad61b38906@linaro.org \
--to=neil.armstrong@linaro.org \
--cc=andersson@kernel.org \
--cc=bhelgaas@google.com \
--cc=brgl@kernel.org \
--cc=conor+dt@kernel.org \
--cc=devicetree@vger.kernel.org \
--cc=geert+renesas@glider.be \
--cc=gregkh@linuxfoundation.org \
--cc=konradybcio@kernel.org \
--cc=krzk+dt@kernel.org \
--cc=linux-arm-msm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pci@vger.kernel.org \
--cc=linux-renesas-soc@vger.kernel.org \
--cc=linux-usb@vger.kernel.org \
--cc=magnus.damm@gmail.com \
--cc=mani@kernel.org \
--cc=robh@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox