From: "Ahmed S. Darwish (dev)" <darwi.dev@cacheline.de>
To: "Ahmed S. Darwish" <darwi@linutronix.de>
Cc: Ingo Molnar <mingo@redhat.com>, Borislav Petkov <bp@alien8.de>,
Dave Hansen <dave.hansen@linux.intel.com>,
Thomas Gleixner <tglx@linutronix.de>,
Andrew Cooper <andrew.cooper3@citrix.com>,
"H. Peter Anvin" <hpa@zytor.com>,
John Ogness <john.ogness@linutronix.de>,
x86@kernel.org, x86-cpuid@lists.linux.dev,
LKML <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v1 9/9] x86/cpuid: Rename native_cpuid_REG() to cpuid_native_REG()
Date: Fri, 9 May 2025 11:59:27 +0200 [thread overview]
Message-ID: <aB3R_5_aSCeGeLVr@lx-t490> (raw)
In-Reply-To: <20250508150240.172915-10-darwi@linutronix.de>
On Thu, 08 May 2025, Ahmed S. Darwish wrote:
>
> - native_cpuid_eax(1);
> + cpuid_native_eax(1);
>
...
>
> - cpuid_1_eax = native_cpuid_eax(1);
> + cpuid_1_eax = cpuid_native_eax(1);
>
Now that I'm looking at this with fresher eyes, I think below form would
be much better:
cpuid_eax_native()
cpuid_ebx_native()
cpuid_ecx_native()
cpuid_edx_native()
So that it aligns with:
cpuid_eax()
cpuid_ebx()
cpuid_ecx()
cpuid_edx()
at the rest of the <cpuid/api.h> header. Thus the diff becomes:
- cpuid_1_eax = native_cpuid_eax(1);
+ cpuid_1_eax = cpuid_eax_native(1);
- if (native_cpuid_ecx(1) & BIT(31))
+ if (cpuid_ecx_native(1) & BIT(31))
But I'll wait for review feedback before rolling a v2. Maybe people want
to keep having "native_" at the start, instead of forcing a strict
"cpuid_" namespace.
(With "CPUID refactoring" hat on, and as the above mini diff shows, I
honestly think forcing a "cpuid_" namespace, even on native OPs, is much
cleaner.)
Thanks,
~ Ahmed
next prev parent reply other threads:[~2025-05-09 9:59 UTC|newest]
Thread overview: 29+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-05-08 15:02 [PATCH v1 0/9] x86/cpuid: Headers cleanup Ahmed S. Darwish
2025-05-08 15:02 ` [PATCH v1 1/9] x86/cpuid: Move CPUID(0x2) APIs into <cpuid/api.h> Ahmed S. Darwish
2025-05-15 17:17 ` [tip: x86/core] " tip-bot2 for Ahmed S. Darwish
2025-05-08 15:02 ` [PATCH v1 2/9] x86/cpuid: Set <asm/cpuid/api.h> as the main CPUID header Ahmed S. Darwish
2025-05-15 16:25 ` Ingo Molnar
2025-05-15 18:29 ` Ahmed S. Darwish
2025-05-15 17:17 ` [tip: x86/core] " tip-bot2 for Ahmed S. Darwish
2025-05-08 15:02 ` [PATCH v1 3/9] x86/cpuid: Rename have_cpuid_p() to cpuid_feature() Ahmed S. Darwish
2025-05-15 17:17 ` [tip: x86/core] " tip-bot2 for Ahmed S. Darwish
2025-05-08 15:02 ` [PATCH v1 4/9] x86/cpuid: Rename hypervisor_cpuid_base() to cpuid_hypervisor_base() Ahmed S. Darwish
2025-05-15 16:40 ` Ingo Molnar
2025-05-15 18:31 ` Ahmed S. Darwish
2025-05-08 15:02 ` [PATCH v1 5/9] x86/cpuid: Rename cpuid_get_leaf_0x2_regs() to cpuid_leaf_0x2() Ahmed S. Darwish
2025-05-15 17:17 ` [tip: x86/core] " tip-bot2 for Ahmed S. Darwish
2025-05-16 9:01 ` tip-bot2 for Ahmed S. Darwish
2025-05-08 15:02 ` [PATCH v1 6/9] x86/cacheinfo: Rename CPUID(0x2) descriptors iterator parameter Ahmed S. Darwish
2025-05-15 17:17 ` [tip: x86/core] " tip-bot2 for Ahmed S. Darwish
2025-05-16 9:00 ` tip-bot2 for Ahmed S. Darwish
2025-05-08 15:02 ` [PATCH v1 7/9] x86/cpu: " Ahmed S. Darwish
2025-05-15 17:17 ` [tip: x86/core] x86/cpu/intel: " tip-bot2 for Ahmed S. Darwish
2025-05-16 9:00 ` tip-bot2 for Ahmed S. Darwish
2025-05-08 15:02 ` [PATCH v1 8/9] x86/cpuid: Rename native_cpuid() to cpuid_native() Ahmed S. Darwish
2025-05-15 17:00 ` Ingo Molnar
2025-05-15 18:42 ` Ahmed S. Darwish
2025-05-08 15:02 ` [PATCH v1 9/9] x86/cpuid: Rename native_cpuid_REG() to cpuid_native_REG() Ahmed S. Darwish
2025-05-09 9:59 ` Ahmed S. Darwish (dev) [this message]
2025-05-08 18:49 ` [PATCH v1 0/9] x86/cpuid: Headers cleanup Ahmed S. Darwish
2025-05-15 16:51 ` Ingo Molnar
2025-05-15 18:50 ` Ahmed S. Darwish
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=aB3R_5_aSCeGeLVr@lx-t490 \
--to=darwi.dev@cacheline.de \
--cc=andrew.cooper3@citrix.com \
--cc=bp@alien8.de \
--cc=darwi@linutronix.de \
--cc=dave.hansen@linux.intel.com \
--cc=hpa@zytor.com \
--cc=john.ogness@linutronix.de \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=tglx@linutronix.de \
--cc=x86-cpuid@lists.linux.dev \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox