Hi Philipp, > > On the other hand, the fallback is a really nice feature which could > > remove duplicated code. But if the fallback is not present by default, > > it makes it cumbersome to use IMO. > > And it's not easy to automatically determine whether RESET_GPIO is > actually required, because that depends on both device tree and > individual drivers. Well, the driver is small enough to be included always, I'd think. What about adding this to RESET_GPIO: default y if GPIOLIB ? > In short, if both of_parse_phandle_with_args() return -ENOENT, we > should continue to silently return (optional ? NULL : -ENOENT), even if > CONFIG_RESET_GPIO=n. I think I got it. > I think the message should be pr_err() level if we return an error that > will cause the consumer driver probe to fail. Ok, will send v2 tomorrow. Thanks for the fast review! Wolfram