The Linux Kernel Mailing List
 help / color / mirror / Atom feed
From: Sasha Levin <sashal@kernel.org>
To: Hans Zhang <18255117159@163.com>
Cc: lpieralisi@kernel.org, kwilczynski@kernel.org,
	bhelgaas@google.com, helgaas@kernel.org, jingoohan1@gmail.com,
	mani@kernel.org, robh@kernel.org, ilpo.jarvinen@linux.intel.com,
	schnelle@linux.ibm.com, gbayer@linux.ibm.com, lukas@wunner.de,
	arnd@kernel.org, geert@linux-m68k.org, linux-pci@vger.kernel.org,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH v15 6/6] PCI: cadence: Use cdns_pcie_find_*capability() to avoid hardcoding offsets
Date: Thu, 9 Oct 2025 10:54:11 -0400	[thread overview]
Message-ID: <aOfMk9BW8BH2P30V@laps> (raw)
In-Reply-To: <20250813144529.303548-7-18255117159@163.com>

On Wed, Aug 13, 2025 at 10:45:29PM +0800, Hans Zhang wrote:
>@@ -249,9 +252,10 @@ static int cdns_pcie_ep_get_msi(struct pci_epc *epc, u8 fn, u8 vfn)
> {
> 	struct cdns_pcie_ep *ep = epc_get_drvdata(epc);
> 	struct cdns_pcie *pcie = &ep->pcie;
>-	u32 cap = CDNS_PCIE_EP_FUNC_MSI_CAP_OFFSET;
> 	u16 flags, mme;
>+	u8 cap;
>
>+	cap = cdns_pcie_find_capability(pcie, PCI_CAP_ID_MSIX);

We should be passing PCI_CAP_ID_MSI, not PCI_CAP_ID_MSIX here, right?

-- 
Thanks,
Sasha

  reply	other threads:[~2025-10-09 14:54 UTC|newest]

Thread overview: 17+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-08-13 14:45 [PATCH v15 0/6] Refactor capability search into common macros Hans Zhang
2025-08-13 14:45 ` [PATCH v15 1/6] PCI: Clean up __pci_find_next_cap_ttl() readability Hans Zhang
2025-08-20  9:19   ` Gerd Bayer
2025-08-20 11:36     ` Ilpo Järvinen
2025-08-13 14:45 ` [PATCH v15 2/6] PCI: Refactor capability search into PCI_FIND_NEXT_CAP() Hans Zhang
2025-08-13 14:45 ` [PATCH v15 3/6] PCI: Refactor extended capability search into PCI_FIND_NEXT_EXT_CAP() Hans Zhang
2025-08-13 14:45 ` [PATCH v15 4/6] PCI: dwc: Use PCI core APIs to find capabilities Hans Zhang
2025-08-13 14:45 ` [PATCH v15 5/6] PCI: cadence: " Hans Zhang
2025-08-13 14:45 ` [PATCH v15 6/6] PCI: cadence: Use cdns_pcie_find_*capability() to avoid hardcoding offsets Hans Zhang
2025-10-09 14:54   ` Sasha Levin [this message]
2025-10-09 15:47     ` Hans Zhang
2025-08-14  8:32 ` [PATCH v15 0/6] Refactor capability search into common macros Niklas Schnelle
2025-08-14 14:51   ` Hans Zhang
2025-08-14 20:25 ` Bjorn Helgaas
2025-08-14 20:37   ` Niklas Schnelle
2025-08-14 20:51     ` Bjorn Helgaas
2025-08-14 22:21   ` Hans Zhang

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=aOfMk9BW8BH2P30V@laps \
    --to=sashal@kernel.org \
    --cc=18255117159@163.com \
    --cc=arnd@kernel.org \
    --cc=bhelgaas@google.com \
    --cc=gbayer@linux.ibm.com \
    --cc=geert@linux-m68k.org \
    --cc=helgaas@kernel.org \
    --cc=ilpo.jarvinen@linux.intel.com \
    --cc=jingoohan1@gmail.com \
    --cc=kwilczynski@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pci@vger.kernel.org \
    --cc=lpieralisi@kernel.org \
    --cc=lukas@wunner.de \
    --cc=mani@kernel.org \
    --cc=robh@kernel.org \
    --cc=schnelle@linux.ibm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox