From: Christoph Hellwig <hch@infradead.org>
To: Sakari Ailus <sakari.ailus@iki.fi>
Cc: Joe Perches <joe@perches.com>,
Sakari Ailus <sakari.ailus@linux.intel.com>,
Andy Whitcroft <apw@canonical.com>,
linux-kernel@vger.kernel.org,
Dwaipayan Ray <dwaipayanray1@gmail.com>,
Lukas Bulwahn <lukas.bulwahn@gmail.com>,
Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Subject: Re: [PATCH 1/1] checkpatch: Deprecate container_of() in favour of container_of_const()
Date: Wed, 5 Nov 2025 05:01:46 -0800 [thread overview]
Message-ID: <aQtKul7TSt-UVsIl@infradead.org> (raw)
In-Reply-To: <aQsF9tuTWRn3tfS_@valkosipuli.retiisi.eu>
Well, if container_of_const is a drop-in replacement for all uses of
container_of, just fix the implementation? If it is an almost but not
complete replacement, find a different name for the few uses. And if
it's not anywhere near drop in, just using container_of make a lot more
sense.
Just in case it wasn't clear: We really should keep the shorter nice
name as the default if at all possible. Both because it reads better
and because it avoids churn.
next prev parent reply other threads:[~2025-11-05 13:01 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-08-11 8:57 [PATCH 1/1] checkpatch: Deprecate container_of() in favour of container_of_const() Sakari Ailus
2025-08-11 9:05 ` Greg Kroah-Hartman
2025-11-05 8:08 ` Sakari Ailus
2025-11-05 9:22 ` Joe Perches
2025-11-05 13:01 ` Christoph Hellwig [this message]
2025-11-05 16:25 ` Sakari Ailus
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=aQtKul7TSt-UVsIl@infradead.org \
--to=hch@infradead.org \
--cc=apw@canonical.com \
--cc=dwaipayanray1@gmail.com \
--cc=gregkh@linuxfoundation.org \
--cc=joe@perches.com \
--cc=linux-kernel@vger.kernel.org \
--cc=lukas.bulwahn@gmail.com \
--cc=sakari.ailus@iki.fi \
--cc=sakari.ailus@linux.intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox