From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from mail-dy1-f170.google.com (mail-dy1-f170.google.com [74.125.82.170]) (using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)) (No client certificate requested) by smtp.subspace.kernel.org (Postfix) with ESMTPS id EED264A02 for ; Thu, 12 Feb 2026 00:07:58 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; arc=none smtp.client-ip=74.125.82.170 ARC-Seal:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1770854880; cv=none; b=hCdysoSMsQvL/9wTWHgFHD3Im3mF15xi9+elpCfaKCiM0spfWkkfUH2A5QU9aH1iVDeciAjvOwhJw3IwYVHicXmBQJVkSCrzRPq6gvDm5q0MgLMfULDvA1lpW7tj2BIjCYT5CdiDU95xKeYrjpEIiJ1O6eFdYMs+sOLBWuQeyAk= ARC-Message-Signature:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1770854880; c=relaxed/simple; bh=Lv+ZIxkZdPIukSkVmaBhzxRyhm6nhsYeNw41k6EsUMQ=; h=Date:From:To:Cc:Subject:Message-ID:References:MIME-Version: Content-Type:Content-Disposition:In-Reply-To; b=cdizV418h5Es8rkeFbU2n9xxa2mj6x9Q3cP4LagjSBuvNCzHz17uFu3M3aE2uR5JYge8R1kEfhGZQJ8V5G2z6+0RcG1rIC4MN8p45BWKddsTIrncXxn8WEMXe07xd2MttBPIyE0bQ9SoFdr4TtIe1RPYkd8ZtiymOfeX1l9lQlU= ARC-Authentication-Results:i=1; smtp.subspace.kernel.org; dmarc=pass (p=none dis=none) header.from=gmail.com; spf=pass smtp.mailfrom=gmail.com; dkim=pass (2048-bit key) header.d=gmail.com header.i=@gmail.com header.b=KwTtZj2k; arc=none smtp.client-ip=74.125.82.170 Authentication-Results: smtp.subspace.kernel.org; dmarc=pass (p=none dis=none) header.from=gmail.com Authentication-Results: smtp.subspace.kernel.org; spf=pass smtp.mailfrom=gmail.com Authentication-Results: smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=gmail.com header.i=@gmail.com header.b="KwTtZj2k" Received: by mail-dy1-f170.google.com with SMTP id 5a478bee46e88-2b785801c93so14172035eec.0 for ; Wed, 11 Feb 2026 16:07:58 -0800 (PST) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20230601; t=1770854878; x=1771459678; darn=vger.kernel.org; h=in-reply-to:content-disposition:mime-version:references:message-id :subject:cc:to:from:date:from:to:cc:subject:date:message-id:reply-to; bh=jod8g++UrMJjPGENywCHZK3vSzJ+1L5xwi8NVPgGzhg=; b=KwTtZj2kd57J/7yeVctlS7h40lDy5GpLCoK/biwcUkVRKJMyWkzgPfZUrUX4VraEC8 IQ3+QB0dhPZ6A5zWhfjxOcXJhjt+X7HGAYCUbMnLyURoXx/jghW8vVRlA1f1fWXySaf9 4bs2fAyWK18r2J7cobO8HQQxtzRm64cqP/DE0n9GSGQKe59KOv6Ld/hfn/+Cw074so7p eIICACF4k61xLaD2a1IVvWB2tvVw/VRCtsF0c5dTMB3GMQZL6wZqECqc0Hd4GvlsA8Rd qTFsXZbT2wZU2FiXin1JFSlDdbee+a+WoqdH9mFk2ObMvcQZp/4o0hoS+fJEzCfRN5RB 7lww== X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20230601; t=1770854878; x=1771459678; h=in-reply-to:content-disposition:mime-version:references:message-id :subject:cc:to:from:date:x-gm-gg:x-gm-message-state:from:to:cc :subject:date:message-id:reply-to; bh=jod8g++UrMJjPGENywCHZK3vSzJ+1L5xwi8NVPgGzhg=; b=fz2o+P+XtCz+YviCgNlVfmokYOL8ReJBpGfrV34cLs4EBTQosE+ZfRR+a44dK8RDFd RM0a1x9uEfxlAVvdwxmm+y+OWqCdLTqbZFFZNjH1p1Zt5P8bCcjZnWbE7DPKwsIxLeRF U6f/nxIqTtDvjthFiQO8vwMWHvDZMw+Bg1DPVpvjwxiGYQdwCuQTKdi5LNLTWNKiJ4Jy I8H0JGsDLN+/DYp1hlmCjnupKFL/ZAoLh9kznbVa8xQna5lXnR7aSD8lzxZFm6/7rdcq LsdH7y/rZis0Nf8OkFWyS0wBrmsMASwCLacBv+Copi4lcMGAO66YrAAUH4EtpuxC0n8C lmfg== X-Gm-Message-State: AOJu0YwGO11QBvqnUHXJ6sEvUMFMJHv3Fi+kn9n4ilDcOWOWURCG+L47 jk8CUZSTgKLb9oMamOZyYtLi4UGxUpJgyLOz4iobsXeBkUr6t5GKSbxG X-Gm-Gg: AZuq6aJTXxhQKTil14HpfrY7ImQoJ8Vn5g6i9ijNWPoPqqkkXsrs3f768VhlM+5I6Md Y6/ubTFNaUjMiLRhEE4H2lqCdTdt4uOyD0nICOKE6T7TRILNouhMr7/H/w+eaPb9dCARjngF94Q wS/MFHVOt63ziXlYV+tSShuqG4Yrzbg8SZnZu0NYZnu7yR2RPZj97XBYTFMDcpp0ktMsCWjEF1F VA20xS68UwsOjNaOcznCpaNMARF7XBsAnbMbcfDZTBn3htbGI9m49cB+Qrnmli79cLkFchl4Pb8 rZu/xGJ15h3cqcFz26kmUByIuaMsVPPh7d09Z/z4cia9hYA9OE8k2nt/GugzCW3ynbDZbzWInky 9ihaMKVheGZT5ruXeyN9HINt5NiS+dwFDAkHDCgJgtcIlnydHLmMmXN6rhGv7vHRgfhnb1lXjqa Wm5Z4ldx1MHfUH8XvBnWXsLWFFN3oyTjVeUQhIiJjX0QaMQNH9aaJYmGQJkhb+FLcwdQ== X-Received: by 2002:a05:7300:7b92:b0:2ba:8ae0:8576 with SMTP id 5a478bee46e88-2baa7f7064cmr548258eec.3.1770854877882; Wed, 11 Feb 2026 16:07:57 -0800 (PST) Received: from fedora (c-67-164-59-41.hsd1.ca.comcast.net. [67.164.59.41]) by smtp.gmail.com with ESMTPSA id 5a478bee46e88-2ba9dba2fe9sm2347889eec.7.2026.02.11.16.07.56 (version=TLS1_3 cipher=TLS_AES_256_GCM_SHA384 bits=256/256); Wed, 11 Feb 2026 16:07:57 -0800 (PST) Date: Wed, 11 Feb 2026 16:07:54 -0800 From: "Vishal Moola (Oracle)" To: Dave Hansen Cc: linux-kernel@vger.kernel.org, linux-mm@kvack.org, x86@kernel.org, "Mike Rapoport (Microsoft)" , akpm@linux-foundation.org, "Matthew Wilcox (Oracle)" , Dave Hansen , Andy Lutomirski , Peter Zijlstra Subject: Re: [PATCH v5 1/4] mm: Add address apis for ptdescs Message-ID: References: <20260211195233.368497-1-vishal.moola@gmail.com> <20260211195233.368497-2-vishal.moola@gmail.com> <0ead4a2d-c88c-4c89-b1dd-5954c28edb99@intel.com> Precedence: bulk X-Mailing-List: linux-kernel@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: On Wed, Feb 11, 2026 at 02:18:20PM -0800, Vishal Moola (Oracle) wrote: > On Wed, Feb 11, 2026 at 12:13:10PM -0800, Dave Hansen wrote: > > On 2/11/26 11:52, Vishal Moola (Oracle) wrote: > > > +/** > > > + * pgtable_alloc_addr - Allocate pagetables to get an address > > > + * @gfp: GFP flags > > > + * @order: desired pagetable order > > > > FWIW, I don't like how pgtable_alloc_addr() looks in practice. It reads > > like it is: "allocate a page table address", not "allocate a page > > table". I don't have a better suggestion other than having: > > Hmmm. I meant for it to read "allocate a page table and get its address." > > > pgtable_alloc() > > > > that returns a page table pointer, a void*, and: > > Initially, I intended to name it pgtable_alloc() & pgtable_free(). I saw > arm using pgtable_alloc() and powerpc using pgtable_free(), so I looked > for another name. I've done some digging about these names. The arm cases uses a function pointer, so we should be able to use that name without issue. What do you think is a reasonable name for freeing? pgtable_free() is defined for sparc and powerpc. I could rename them prefixed with "__" to get the name since they only have 1-2 internal callers. > > ptdesc_alloc() > > > > which returns a ptdesc*. But I suspect that would get confusing at the > > point that ptdescs _themselves_ start getting allocated. > > The ptdesc_alloc() equivalent right now is named pagetable_alloc(), so I > don't think it'd get confusing.