From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from mail.virtlab.unibo.it (mail.virtlab.unibo.it [130.136.161.50]) by smtp.subspace.kernel.org (Postfix) with ESMTP id 7241230C359 for ; Thu, 2 Jul 2026 16:10:57 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; arc=none smtp.client-ip=130.136.161.50 ARC-Seal:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1783008662; cv=none; b=Zb/LerghBaSIfIkZ3BHlTG7mQ9sE0rwYwLWch5XfcO8KEN/LPWn4BoN0bGZJg4VKTGR86J+bLfv/73YpFaBrJ0IG/RdulDO13/UoRvhL+C/6KYODxnlY2AYzlX8lIDb6MZv9+Waf8Zf3rMWF1mm6DsYwea+AFbqlAezqTpkmT+g= ARC-Message-Signature:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1783008662; c=relaxed/simple; bh=nNzA0can61bX6xnSFj6vlIKPCtelsctfEUnTJc/Pe/E=; h=Date:From:To:Cc:Subject:Message-ID:References:MIME-Version: Content-Type:Content-Disposition:In-Reply-To; b=B2XHWRo8UElzwFWcWV6w9PoITdgqaRw76weOsVuADg2DBZUCJyfPz7ii9GnCRYCB9rYrgTtn+3fUygrLeugjsFueUe2bTbZRstSxQK1XrW3DFsmqkQ8SW6ZonfTU8RCvzFAMr6FcMithDSfKFQwPH9xKegqhA1L1nxKbolo07lY= ARC-Authentication-Results:i=1; smtp.subspace.kernel.org; dmarc=pass (p=reject dis=none) header.from=cs.unibo.it; spf=pass smtp.mailfrom=cs.unibo.it; dkim=pass (1024-bit key) header.d=cs.unibo.it header.i=@cs.unibo.it header.b=BDy7YkPp; arc=none smtp.client-ip=130.136.161.50 Authentication-Results: smtp.subspace.kernel.org; dmarc=pass (p=reject dis=none) header.from=cs.unibo.it Authentication-Results: smtp.subspace.kernel.org; spf=pass smtp.mailfrom=cs.unibo.it Authentication-Results: smtp.subspace.kernel.org; dkim=pass (1024-bit key) header.d=cs.unibo.it header.i=@cs.unibo.it header.b="BDy7YkPp" Received: from cs.unibo.it (host0.studiodavoli.it [109.234.61.1]) by mail.virtlab.unibo.it (Postfix) with ESMTPSA id 0E2C01C0095; Thu, 2 Jul 2026 18:10:49 +0200 (CEST) DKIM-Signature: v=1; a=rsa-sha256; c=simple/simple; d=cs.unibo.it; s=virtlab; t=1783008650; bh=nNzA0can61bX6xnSFj6vlIKPCtelsctfEUnTJc/Pe/E=; h=Date:From:To:Cc:Subject:References:In-Reply-To:From; b=BDy7YkPpc0q3Fs7nLInZKRBSdiLH7f3lovNc/evqrjJEaz7zR+IuUTykhjX4YBMnT RBokyW2ZVunrbDwjyaiNargNVK3AYN680GMMhV55oXuB9P18LdAOxVgvR20+qtnhF9 S4OwNquiyutXoAoq4SNU4236sNKUoZ6fOSWknqi4= Date: Thu, 2 Jul 2026 18:10:48 +0200 From: Renzo Davoli To: Oleg Nesterov Cc: "Dmitry V. Levin" , linux-kernel@vger.kernel.org, Andrew Morton , Shuah Khan , Alexey Gladkov , Eugene Syromyatnikov , Mike Frysinger , Davide Berardi , strace-devel@lists.strace.io Subject: Re: [PATCH 1/5] ptrace: add PTRACE_SYSCALL_INFO_SECCOMP_SKIP Message-ID: References: <20260701150558.330348-1-renzo@cs.unibo.it> <20260701150558.330348-2-renzo@cs.unibo.it> <20260702110755.GA16303@strace.io> Precedence: bulk X-Mailing-List: linux-kernel@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: On Thu, Jul 02, 2026 at 04:47:08PM +0200, Oleg Nesterov wrote: > On 07/02, Oleg Nesterov wrote: > Wdyt about something like below? I like it. I have one comment: > + if (ptrace_get_syscall_info_op(child) != info.op) { > + if (info.op != PTRACE_SYSCALL_INFO_EXIT) > + return -EINVAL; > + force = true; > + } I have found the behavior "negative syscall number => skip syscall" defined only for PTRACE_EVENT_SECCOMP in the manual. I'd restrict the option to this case, for safety. A minimal detail: I'd also rename "force" into "skip" or "skip_syscall", just for the sake of readability. Dmitry: does this proposal have counter effects for strace? renzo