From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from mail-wm1-f41.google.com (mail-wm1-f41.google.com [209.85.128.41]) (using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)) (No client certificate requested) by smtp.subspace.kernel.org (Postfix) with ESMTPS id AA9CE5695 for ; Mon, 13 Jul 2026 08:26:42 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; arc=none smtp.client-ip=209.85.128.41 ARC-Seal:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1783931204; cv=none; b=RFvIhkwAvBDRVH2AhlpwCD8ocmzXxxyrjzGADJpcOsHVXOZvfjLhIqbnH9jZTE+E9HeT/keA2wvQpAbxf7T5XOi5sdLy9Kly2uTZaXo7uJMKEbIsiyf1J/JhL1i3dPFTinEXTw5vAwuT1G8MsACc3T3MKW/tFVPniFRNOu+06ag= ARC-Message-Signature:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1783931204; c=relaxed/simple; bh=C082o+EiFKpjjyCwale+ZemOqCiOLALjOGsSt2C9bbw=; h=Date:From:To:Cc:Subject:Message-ID:References:MIME-Version: Content-Type:Content-Disposition:In-Reply-To; b=fShGahAoPoeGyK8t4LGN9VAxY/cysc08WFC/BrionkyNsgNr18bSo8XEvI/nnryJZIp1ZaQLXvlL5NRPn7fCAVqLcWi52YbxStZp9BF2NTTB3acJsmxa9L2jDY9vsWLkI/CWgIYwnHyWf61DSgveuaCeh7JWjWplSSIeyxdZ0d8= ARC-Authentication-Results:i=1; smtp.subspace.kernel.org; dmarc=pass (p=reject dis=none) header.from=google.com; spf=pass smtp.mailfrom=google.com; dkim=pass (2048-bit key) header.d=google.com header.i=@google.com header.b=spE2nylB; arc=none smtp.client-ip=209.85.128.41 Authentication-Results: smtp.subspace.kernel.org; dmarc=pass (p=reject dis=none) header.from=google.com Authentication-Results: smtp.subspace.kernel.org; spf=pass smtp.mailfrom=google.com Authentication-Results: smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=google.com header.i=@google.com header.b="spE2nylB" Received: by mail-wm1-f41.google.com with SMTP id 5b1f17b1804b1-493be0fbcc5so82135e9.0 for ; Mon, 13 Jul 2026 01:26:42 -0700 (PDT) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=google.com; s=20251104; t=1783931201; x=1784536001; darn=vger.kernel.org; h=in-reply-to:content-disposition:content-type:mime-version :references:message-id:subject:cc:to:from:date:from:to:cc:subject :date:message-id:reply-to:content-type; bh=amf55tWJXben6rIQyHF/blCpD5b43dwdFfwgfK1yuhQ=; b=spE2nylBc5Ngqawy09sLiAJ9xTArHZOc5rkOrQC5qpqKCqj2nCa7jM+upiisXJQex6 QaI6CyPSdyJ9CbEHebZdm4Q7BmQi9QqaVLPhLGXhqJqC8CgKiGW/0mgEagISsNLxAjWl R5fs/MgM9E6XkGMfXl4KztyY9h3uIFwVGXvXhM4ReVlU7rigJBnEPQzUWzWnl1DQ9i2g TA+dIFDS7TLMdJ1N4E2CPhSh4ige36XLJbtibHmdP2Bx0vw4b6JWsMUQ6j75/csnaxU3 NNW+F7PZEiLQZbOkn+gxijzuZq+8AW0qCyrE7DNcw1k45q+DEMiJlKWbSa1A3BB7gzv/ xjQw== X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20251104; t=1783931201; x=1784536001; h=in-reply-to:content-disposition:content-type:mime-version :references:message-id:subject:cc:to:from:date:x-gm-gg :x-gm-message-state:from:to:cc:subject:date:message-id:reply-to :content-type; bh=amf55tWJXben6rIQyHF/blCpD5b43dwdFfwgfK1yuhQ=; b=PquvgPC2/Ux0BXemKZdh5yF40W8K/ry2sZgIMqbe10Znu0M4wmSKsk8z0WQ10AtzoJ fsO0mX9MROxS5lGizaAY4hqMzWDEaf4HhGPUuGA9fCJ5UCLbJwwj+NEbwB87XpcjgPrV O2QhLFP43GXEZd2Wi4tKlLGlhEcnx0lAjs657FEnabtPwdZMqC6/IJD2+w6wjqY2sDtC SWyyiQdMDce87sRneE/kpXv77EBvKrTRdPhOVwMIlcRNAcl/U/EF95P1BUxZN66IzTmO +pyBJgMbIZw8c8pWdb1Y+tkFgVFmFwGolBfP2e05GLqrsSdFUQepsb0iLtNJ1JhVImU5 WCig== X-Forwarded-Encrypted: i=1; AHgh+Rqc/LM7CnsNVtBG7vGSPLkFzN4/tZYkmZ+9w+UsavxrxEEy1LOrqffvanF6ks4XjhKEyJfyPsmIXoA0hSA=@vger.kernel.org X-Gm-Message-State: AOJu0YwEDkUVKHx8RdkY1SazmMgrzBGCrtIJp72NTB4uNLCxhuHqXc0F 3x/SZVPwhxvjx1gLeEDM/VgTsMQIv3ljxPMXPuiNKFYrlwgaWJUSb1vTQIsn0aOs+A== X-Gm-Gg: AfdE7cnFTR3e/BMwhUdBEOYJCTFUJcMhsS4ft7Clxj+5c+O2kZ8eHGtCQFGOvEQs3Pf IXg9szQkNVd5V+9GoCO1TzhLYpMW7PXvJogigD2IIRn5UsmGLGAHOLsFP5nnDISqTjVxXXVB+OF WaMOvr55IeTSsvHeuXR6zJCO7s84XXrGbZasJFhYnFXxi542lraqxGOC2maNmuHzjXkD40dbMma I36VqZ18WPZRJJ2CFGxwR84tbx9LpxGQFI8tanqisimEPPpUk/9k2ywTP8bGkus14dV5fXPG5QC /ZZxpFeRUPWKtTVF6EH0vBMl4Yk1ew5t/njtB/XNciadvmRtTeIuN1iCZWKFqyIJ0X8Nhxdvyrl GN2XfNoXPjUwEpmJZijgzrMZ1f+Juk5yaEPdDc6VzyKxH7EQvy4ZOR1VJ1mFmj0qcL8HJ4RrN8n xTAotvo+Q1LMeQJvbwvfKiaf7KoGtEPmMWrBXBSO1Vs7lQFLJ1cpZN+4uDflc= X-Received: by 2002:a05:600c:3589:b0:492:203f:a378 with SMTP id 5b1f17b1804b1-49465abb636mr24695e9.8.1783931200485; Mon, 13 Jul 2026 01:26:40 -0700 (PDT) Received: from google.com (220.60.76.34.bc.googleusercontent.com. [34.76.60.220]) by smtp.gmail.com with ESMTPSA id ffacd0b85a97d-47a9de1d91bsm88670924f8f.4.2026.07.13.01.26.39 (version=TLS1_3 cipher=TLS_AES_256_GCM_SHA384 bits=256/256); Mon, 13 Jul 2026 01:26:39 -0700 (PDT) Date: Mon, 13 Jul 2026 08:26:35 +0000 From: Mostafa Saleh To: Vincent Donnefort Cc: Fuad Tabba , linux-kernel@vger.kernel.org, kvmarm@lists.linux.dev, linux-arm-kernel@lists.infradead.org, maz@kernel.org, oupton@kernel.org, seiden@linux.ibm.com, joey.gouly@arm.com, suzuki.poulose@arm.com, yuzenghui@huawei.com, catalin.marinas@arm.com, will@kernel.org Subject: Re: [PATCH] KVM: arm64: Avoid naming collision in tracing Message-ID: References: <20260712153835.2264905-1-smostafa@google.com> Precedence: bulk X-Mailing-List: linux-kernel@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: On Mon, Jul 13, 2026 at 09:11:27AM +0100, Vincent Donnefort wrote: > [...] > > > > > > > > > I did not add Fixes tag as this is currently dormant and not breaking > > > > > anything. > > > > > --- > > > > > arch/arm64/kvm/hyp/include/nvhe/clock.h | 8 ++++---- > > > > > arch/arm64/kvm/hyp/nvhe/clock.c | 4 ++-- > > > > > arch/arm64/kvm/hyp/nvhe/trace.c | 4 ++-- > > > > > 3 files changed, 8 insertions(+), 8 deletions(-) > > > > > > > > > > diff --git a/arch/arm64/kvm/hyp/include/nvhe/clock.h b/arch/arm64/kvm/hyp/include/nvhe/clock.h > > > > > index 9f429f5c0664..c2ccd0e8bf22 100644 > > > > > --- a/arch/arm64/kvm/hyp/include/nvhe/clock.h > > > > > +++ b/arch/arm64/kvm/hyp/include/nvhe/clock.h > > > > > @@ -6,11 +6,11 @@ > > > > > #include > > > > > > > > > > #ifdef CONFIG_NVHE_EL2_TRACING > > > > > -void trace_clock_update(u32 mult, u32 shift, u64 epoch_ns, u64 epoch_cyc); > > > > > -u64 trace_clock(void); > > > > > +void hyp_trace_clock_update(u32 mult, u32 shift, u64 epoch_ns, u64 epoch_cyc); > > > > > +u64 hyp_trace_clock(void); > > > > > > > > hyp_trace_clock overlaps the host side: arch/arm64/kvm/hyp_trace.c > > > > already has a struct hyp_trace_clock and static helpers > > > > hyp_trace_clock_enable() / hyp_trace_clock_show() for the debugfs view > > > > of the same clock. No actual collision, so this is only a readability > > > > point, but a reader grepping hyp_trace_clock now gets two unrelated > > > > things. Maybe you'd want to consider a different name, but naming is > > > > hard :) > > If we were to rename: the clock is a "hyp_clock" so probably trace_hyp_clock() > is the right thing here. > > while the "hyp_trace_" is the prefix for hyp_trace.c file content. > > Although I would like to see why we pull trace_clock() from the kernel into EL2. > That bit sounds wrong and if we have a way around perhaps that's better? Most include path look like this: In file included from ./include/linux/ftrace.h:11, from ./include/linux/kprobes.h:28, from ./include/linux/kgdb.h:17, from ./arch/arm64/include/asm/cacheflush.h:11, from ./include/linux/cacheflush.h:5, from ./include/linux/highmem.h:8, from ./include/linux/bvec.h:10, from ./include/linux/blk_types.h:10, from ./include/linux/writeback.h:13, from ./include/linux/memcontrol.h:23, from ./include/linux/resume_user_mode.h:8, from ./include/linux/entry-virt.h:6, from ./include/linux/kvm_host.h:5, Although, some files have ./arch/arm64/include/asm/cacheflush.h directly. Thanks, Mostafa > > > > > > > Yes, that shouldn't be a problem, I just added hyp_ prefix, but I > > > am ok with any suggestions! > > > > Didn't I say naming is hard? :) How about, el2_? Not really happy with > > that either tbh... but can't think of a better one... > > > > /fuad > > > > > > > > Thanks, > > > Mostafa > > > > > > > > > > > Reviewed-by: Fuad Tabba > > > > Tested-by: Fuad Tabba < fuad.tabba@linux.dev> > > > > > > > > Test: builds fine with the different config enables. > > > > > > > > Cheers, > > > > /fuad