From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1755274AbcHSNbG (ORCPT ); Fri, 19 Aug 2016 09:31:06 -0400 Received: from mail3-relais-sop.national.inria.fr ([192.134.164.104]:50221 "EHLO mail3-relais-sop.national.inria.fr" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1754298AbcHSNbD (ORCPT ); Fri, 19 Aug 2016 09:31:03 -0400 X-IronPort-AV: E=Sophos;i="5.28,544,1464645600"; d="scan'208";a="190588999" Date: Fri, 19 Aug 2016 09:30:01 -0400 (EDT) From: Julia Lawall X-X-Sender: jll@hadrien To: SF Markus Elfring cc: Amitoj Kaur Chawla , LKML , Coccinelle , Gilles Muller , Michal Marek , Nicolas Palix Subject: Re: [Cocci] Coccinelle: Script to replace allocate and memset with zalloc functions In-Reply-To: <33c75c5f-59d5-5fd4-6767-6144b4f245bc@users.sourceforge.net> Message-ID: References: <20160801070233.GA19102@amitoj-Inspiron-3542> <33c75c5f-59d5-5fd4-6767-6144b4f245bc@users.sourceforge.net> User-Agent: Alpine 2.10 (DEB 1266 2009-07-14) MIME-Version: 1.0 Content-Type: MULTIPART/MIXED; BOUNDARY="8323329-276722591-1471613404=:3078" Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org This message is in MIME format. The first part should be readable text, while the remaining parts are likely unreadable without MIME-aware tools. --8323329-276722591-1471613404=:3078 Content-Type: TEXT/PLAIN; charset=utf-8 Content-Transfer-Encoding: 8BIT On Fri, 19 Aug 2016, SF Markus Elfring wrote: > >> I suggest to take another look at a few implementation details. > >> > >> 1. Would it make sense to merge such SmPL rules into one > >> so that code duplication could be reduced a bit > >> in such a script? > >> > >> 2. How do you think about to extend the shown check list > >> with the function "kvm_kvzalloc"? > … > > kvm_kvzalloc function doesn't fit the same pattern as the other > > functions in this semantic patch, and is kvm specific, > > Has this one got a similar function property? Do you have any example where XXX followed by memset is converted to this function? > > Do you prefer to exclude such functions which belong to subsystems > so far generally? Yes, because it would introduce unwanted dependencies. > > > so the semantic patch looks fine as is. > > How do you think about to express the shown source code repetition > as an aspect by an other script format? It is fine as it is. julia --8323329-276722591-1471613404=:3078--