From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S933078AbcHWIvy (ORCPT ); Tue, 23 Aug 2016 04:51:54 -0400 Received: from Galois.linutronix.de ([146.0.238.70]:55941 "EHLO Galois.linutronix.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1757306AbcHWIvM (ORCPT ); Tue, 23 Aug 2016 04:51:12 -0400 Date: Tue, 23 Aug 2016 10:48:38 +0200 (CEST) From: Thomas Gleixner To: Peter Zijlstra cc: John Stultz , Steven Rostedt , lkml , Ingo Molnar , Andrew Morton , Clark Williams , Jon Masters , Daniel Wagner , Carsten Emde , Sebastian Andrzej Siewior Subject: Re: [PATCH v2 0/4] tracing: Add Hardware Latency detector tracer In-Reply-To: <20160823084735.GO10153@twins.programming.kicks-ass.net> Message-ID: References: <20160810135356.265780824@goodmis.org> <20160819140928.GK10121@twins.programming.kicks-ass.net> <20160819102620.763bd7a0@gandalf.local.home> <20160819150551.GE10153@twins.programming.kicks-ass.net> <20160823084735.GO10153@twins.programming.kicks-ass.net> User-Agent: Alpine 2.20 (DEB 67 2015-01-07) MIME-Version: 1.0 Content-Type: text/plain; charset=US-ASCII Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Tue, 23 Aug 2016, Peter Zijlstra wrote: > On Fri, Aug 19, 2016 at 09:36:41AM -0700, John Stultz wrote: > > On Fri, Aug 19, 2016 at 8:05 AM, Peter Zijlstra wrote: > > > John, looks like 4ca22c2648f9 ("timekeeping: Add warnings when overflows > > > or underflows are observed") buggered things. > > > > Oof. Apologies. I missed that the fast methods called that helper as well. > > > > > > Any objection to open-coding it for the fast method, like (sorry for > > the whitespace damage here): > > > > @@ -401,7 +401,10 @@ static __always_inline u64 > > __ktime_get_fast_ns(struct tk_fast *tkf) > > do { > > seq = raw_read_seqcount_latch(&tkf->seq); > > tkr = tkf->base + (seq & 0x01); > > - now = ktime_to_ns(tkr->base) + timekeeping_get_ns(tkr); > > + now = ktime_to_ns(tkr->base); > > + > > + now += clocksource_delta(tkr->read(tkr->clock), > > + tkr->cycle_last, tkr->mask); > > } while (read_seqcount_retry(&tkf->seq, seq)); > > > > return now; > > > > If not I'll get such a patch sorted, tested and tagged for -stable. > > Works for me, Thomas? No objections.