From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S934338AbcIVNgm (ORCPT ); Thu, 22 Sep 2016 09:36:42 -0400 Received: from Galois.linutronix.de ([146.0.238.70]:38081 "EHLO Galois.linutronix.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S933619AbcIVNgj (ORCPT ); Thu, 22 Sep 2016 09:36:39 -0400 Date: Thu, 22 Sep 2016 15:34:06 +0200 (CEST) From: Thomas Gleixner To: Peter Zijlstra cc: Waiman Long , Mike Galbraith , Ingo Molnar , Jonathan Corbet , linux-kernel@vger.kernel.org, linux-doc@vger.kernel.org, Davidlohr Bueso , Jason Low , Scott J Norton , Douglas Hatch Subject: Re: [RFC PATCH v2 3/5] futex: Throughput-optimized (TO) futexes In-Reply-To: <20160922074932.GV5008@twins.programming.kicks-ass.net> Message-ID: References: <1474378963-15496-1-git-send-email-Waiman.Long@hpe.com> <1474378963-15496-4-git-send-email-Waiman.Long@hpe.com> <1474441172.27308.19.camel@gmail.com> <57E319BE.2050208@hpe.com> <20160922074932.GV5008@twins.programming.kicks-ass.net> User-Agent: Alpine 2.20 (DEB 67 2015-01-07) MIME-Version: 1.0 Content-Type: text/plain; charset=US-ASCII Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Thu, 22 Sep 2016, Peter Zijlstra wrote: > On Wed, Sep 21, 2016 at 07:37:34PM -0400, Waiman Long wrote: > > On 09/21/2016 02:59 AM, Mike Galbraith wrote: > > >On Tue, 2016-09-20 at 09:42 -0400, Waiman Long wrote: > > >>This patch introduces a new futex implementation called > > >>throughput-optimized (TO) futexes. > > >nit: 'TO' sounds way too much like timeout... TP? You even use 'to' as > > >shorthand for timeout in the next patch. > > > > I agree. I am not that satisfied with the TO name. So I will change it to TP > > in my next revision of the patch. Thanks for the suggestion. > > I'd leave out the TO part entirely (or only mention it in changelogs). > > That is, I'd call the futex ops: FUTEX_LOCK and FUTEX_UNLOCK. That brings me to a different question: How is user space going to support this, i.e. is this some extra magic for code which implements its own locking primitives or is there going to be a wide use via e.g. glibc. Also what's the reason that we can't do probabilistic spinning for FUTEX_WAIT and have to add yet another specialized variant of futexes? Thanks, tglx