From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1752470AbdKHNLC (ORCPT ); Wed, 8 Nov 2017 08:11:02 -0500 Received: from Galois.linutronix.de ([146.0.238.70]:46765 "EHLO Galois.linutronix.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751789AbdKHNLA (ORCPT ); Wed, 8 Nov 2017 08:11:00 -0500 Date: Wed, 8 Nov 2017 14:10:55 +0100 (CET) From: Thomas Gleixner To: Joao Martins cc: Paolo Bonzini , Ingo Molnar , "H. Peter Anvin" , x86@kernel.org, linux-kernel@vger.kernel.org, kvm@vger.kernel.org, Radim Krcmar , xen-devel , Boris Ostrovsky , Juergen Gross , Andy Lutomirski Subject: Re: [PATCH v7 2/5] x86/pvclock: add setter for pvclock_pvti_cpu0_va In-Reply-To: <36a22b0a-e745-4f6f-ca9a-fe549aad930e@oracle.com> Message-ID: References: <20171019133918.18367-1-joao.m.martins@oracle.com> <20171019133918.18367-3-joao.m.martins@oracle.com> <591d9a46-f96e-b3a6-d412-0267f4e412e5@redhat.com> <36a22b0a-e745-4f6f-ca9a-fe549aad930e@oracle.com> User-Agent: Alpine 2.20 (DEB 67 2015-01-07) MIME-Version: 1.0 Content-Type: text/plain; charset=US-ASCII Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Wed, 8 Nov 2017, Joao Martins wrote: > On 11/08/2017 11:06 AM, Thomas Gleixner wrote: > > The only nit-pick I have are the convoluted function names: > > > > pvclock_set_pvti_cpu0_va() pvclock_pvti_cpu0_va() > > > > What on earth does that mean? > > > Those two functions respectively set and get in pvclock common code the address > of a page for vCPU 0 containing time info (pvti, which is periodically updated > by hypervisor). This region is guest memory and registered with hypervisor by > guest PV clocksource and set in pvclock if certain conditions are met (i.e. > PVCLOCK_TSC_STABLE_BIT is supported by hypervisor), and the getter is afterwards > used by vdso and ptp_kvm. > > FWIW I merely followed the current style/code of the existent function but there > could be a better name like "pvclock_set_data() pvclock_get_data()". Albeit the > current names are more explicit on what we should expect to set or return from > the functions. Fair enough. > > > Aside of that can you please make it at least symetric, i.e. _set_ and > > _get_ ? > > > OK - Provided this is changing an exported symbol (pvclock_pvti_cpu0_va in use > by ptp_kvm) and a non-functional change would you want me to address in a > separate patch or it is OK to have in this one? Just fixup the ptp_kvm call site in the very same patch. Thanks, tglx