From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1756175Ab0EKTua (ORCPT ); Tue, 11 May 2010 15:50:30 -0400 Received: from www.tglx.de ([62.245.132.106]:36808 "EHLO www.tglx.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1750939Ab0EKTu2 (ORCPT ); Tue, 11 May 2010 15:50:28 -0400 Date: Tue, 11 May 2010 21:50:10 +0200 (CEST) From: Thomas Gleixner To: "Pan, Jacob jun" cc: Jacob Pan , "H. Peter Anvin" , Ingo Molnar , "Du, Alek" , Arjan van de Ven , "Tang, Feng" , LKML Subject: RE: [PATCH 3/8] x86/apic: allow use of lapic timer early calibration result In-Reply-To: <43F901BD926A4E43B106BF17856F0755A74B2827@orsmsx508.amr.corp.intel.com> Message-ID: References: <1273254108-3234-1-git-send-email-jacob.jun.pan@linux.intel.com> <1273254108-3234-4-git-send-email-jacob.jun.pan@linux.intel.com> <43F901BD926A4E43B106BF17856F0755A74B2827@orsmsx508.amr.corp.intel.com> User-Agent: Alpine 2.00 (LFD 1167 2008-08-23) MIME-Version: 1.0 Content-Type: TEXT/PLAIN; charset=US-ASCII Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Jacob, On Tue, 11 May 2010, Pan, Jacob jun wrote: > Thanks for the review. > > > > > > > lapic timer calibration can be combined with tsc in platform specific > > > calibration functions. if such calibration result is obtained early, > > > we can skip the redundent calibration loops. > > > > I'd rather move lapic calibration into TSC calibration in general as > > we do the same thing twice for no good reason. > > > > That needs some code restructuring, but that's worth it. > > > I am trying to avoid the risks of completely remove the current lapic > calibration code since there are so many platforms with different timer > options. And I don't understand things like why pm timer is preferred. > Why not use the rating in clocksource? We do not have access to the clocksource at that point. But we do a calibration loop for TSC and for lapic timer. There is no reason why we can't do that in one go. > > Aside of my general objection it'd be not a good idea to make this > > global w/o renaming it to something sensible like > > lapic_timer_frequency. > > > perhaps, the calibration data can directly be assigned to lapic timer > clock_event_device.mult? There is no need for the device specific result > scale (e.g. bus clocks per tick) No. That needs an accessor function. Thanks, tglx