From: Thomas Gleixner <tglx@linutronix.de>
To: John Stultz <john.stultz@linaro.org>
Cc: LKML <linux-kernel@vger.kernel.org>, Ingo Molnar <mingo@elte.hu>,
Magnus Damm <magnus.damm@gmail.com>
Subject: Re: [patch 05/15] clocksource: Allow clocksource select to skip current clocksource
Date: Wed, 15 May 2013 11:42:25 +0200 (CEST) [thread overview]
Message-ID: <alpine.LFD.2.02.1305151142100.1388@ionos> (raw)
In-Reply-To: <517F17AB.5070100@linaro.org>
On Mon, 29 Apr 2013, John Stultz wrote:
> On 04/25/2013 01:31 PM, Thomas Gleixner wrote:
> > Preparatory patch for clocksource unbind support.
> >
> > Modify clocksource_select, so it skips the current clocksource on
> > request and tries to find a fallback clocksource. Convert all existing
> > users. No functional change.
> >
> > Signed-off-by: Thomas Gleixner<tglx@linutronix.de>
> > ---
> > kernel/time/clocksource.c | 24 ++++++++++++++----------
> > 1 file changed, 14 insertions(+), 10 deletions(-)
> >
> > Index: tip/kernel/time/clocksource.c
> > ===================================================================
> > --- tip.orig/kernel/time/clocksource.c
> > +++ tip/kernel/time/clocksource.c
> > @@ -553,7 +553,7 @@ static u64 clocksource_max_deferment(str
> > #ifndef CONFIG_ARCH_USES_GETTIMEOFFSET
> > -static struct clocksource *clocksource_find_best(bool oneshot)
> > +static struct clocksource *clocksource_find_best(bool oneshot, bool
> > skipcur)
> > {
> > struct clocksource *cs;
> > @@ -566,6 +566,8 @@ static struct clocksource *clocksource_f
> > * the best rating.
> > */
> > list_for_each_entry(cs, &clocksource_list, list) {
> > + if (skipcur && cs == curr_clocksource)
> > + continue;
> > if (oneshot && !(cs->flags & CLOCK_SOURCE_VALID_FOR_HRES))
> > continue;
> > return cs;
> > @@ -581,18 +583,20 @@ static struct clocksource *clocksource_f
> > * Select the clocksource with the best rating, or the clocksource,
> > * which is selected by userspace override.
> > */
> > -static void clocksource_select(void)
> > +static void clocksource_select(bool skipcur)
> > {
> > bool oneshot = tick_oneshot_mode_active();
> > struct clocksource *best, *cs;
> > /* Find the best suitable clocksource */
> > - best = clocksource_find_best(oneshot);
> > + best = clocksource_find_best(oneshot, skipcur);
> > if (!best)
> > return;
> > /* Check for the override clocksource. */
> > list_for_each_entry(cs, &clocksource_list, list) {
> > + if (skipcur && cs == curr_clocksource)
> > + continue;
> > if (strcmp(cs->name, override_name) != 0)
> > continue;
> > /*
> > @@ -620,7 +624,7 @@ static void clocksource_select(void)
> > #else /* !CONFIG_ARCH_USES_GETTIMEOFFSET */
> > -static inline void clocksource_select(void) { }
> > +static inline void clocksource_select(bool skipcur) { }
> > #endif
>
> Not a major objection, but I sort of don't like the bool flag arguments to
> function that alters their behavior, since its not really very descriptive. I
> know I'll be looking at the code below thinking "hmmm..
> clocksource_select(false).. now what does that mean?" at some point not too
> far away.
>
> Instead, would leaving clocksource_select() alone, and introducing a
> clocksource_select_fallback() for the skipcur behavior, be a more descriptive
> choice? The code could very much use the same skipcur logic, in a
> __clocksource_select() or something function, but just helps make the normal
> usage easier to read.
Yeah, I can do that.
next prev parent reply other threads:[~2013-05-15 9:42 UTC|newest]
Thread overview: 48+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-04-25 20:31 [patch 00/15] clocksource/events: Overhaul (un)registration Thomas Gleixner
2013-04-25 20:31 ` [patch 02/15] clocksource: Always verify highres capability Thomas Gleixner
2013-04-30 0:34 ` John Stultz
2013-05-27 9:42 ` [tip:timers/core] " tip-bot for Thomas Gleixner
2013-04-25 20:31 ` [patch 01/15] clocksource: apb_timer: Remove unsused function Thomas Gleixner
2013-04-26 12:43 ` Jamie Iles
2013-04-30 0:32 ` John Stultz
2013-05-27 9:41 ` [tip:timers/core] " tip-bot for Thomas Gleixner
2013-04-25 20:31 ` [patch 03/15] clocksource: Let timekeeping_notify return success/error Thomas Gleixner
2013-04-30 0:37 ` John Stultz
2013-05-27 9:43 ` [tip:timers/core] " tip-bot for Thomas Gleixner
2013-04-25 20:31 ` [patch 04/15] clocksource: Add module refcount Thomas Gleixner
2013-04-30 0:51 ` John Stultz
2013-05-27 9:45 ` [tip:timers/core] " tip-bot for Thomas Gleixner
2013-04-25 20:31 ` [patch 06/15] clocksource: Split out user string input Thomas Gleixner
2013-04-29 23:29 ` John Stultz
2013-05-15 9:41 ` Thomas Gleixner
2013-05-27 9:47 ` [tip:timers/core] " tip-bot for Thomas Gleixner
2013-04-25 20:31 ` [patch 05/15] clocksource: Allow clocksource select to skip current clocksource Thomas Gleixner
2013-04-30 1:00 ` John Stultz
2013-05-15 9:42 ` Thomas Gleixner [this message]
2013-05-27 9:46 ` [tip:timers/core] " tip-bot for Thomas Gleixner
2013-04-25 20:31 ` [patch 07/15] clocksource: Provide unbind interface in sysfs Thomas Gleixner
2013-04-30 1:11 ` John Stultz
2013-05-15 9:47 ` Thomas Gleixner
2013-05-15 16:53 ` John Stultz
2013-05-15 18:41 ` Thomas Gleixner
2013-05-27 9:48 ` [tip:timers/core] " tip-bot for Thomas Gleixner
2013-04-25 20:31 ` [patch 08/15] clocksource: Let clocksource_unregister() return success/error Thomas Gleixner
2013-04-30 1:01 ` John Stultz
2013-05-27 9:50 ` [tip:timers/core] " tip-bot for Thomas Gleixner
2013-04-25 20:31 ` [patch 09/15] clockevents: Get rid of the notifier chain Thomas Gleixner
2013-05-27 9:51 ` [tip:timers/core] " tip-bot for Thomas Gleixner
2013-04-25 20:31 ` [patch 11/15] clockevents: Move the tick_notify() switch case to clockevents_notify() Thomas Gleixner
2013-05-27 9:54 ` [tip:timers/core] " tip-bot for Thomas Gleixner
2013-04-25 20:31 ` [patch 10/15] clockevents: Simplify locking Thomas Gleixner
2013-05-27 9:52 ` [tip:timers/core] " tip-bot for Thomas Gleixner
2013-04-25 20:31 ` [patch 13/15] clockevents: Provide sysfs interface Thomas Gleixner
2013-04-26 22:37 ` Stephen Boyd
2013-05-15 9:50 ` Thomas Gleixner
2013-05-15 22:30 ` Stephen Boyd
2013-05-27 9:56 ` [tip:timers/core] " tip-bot for Thomas Gleixner
2013-04-25 20:31 ` [patch 12/15] clockevents: Add module refcount Thomas Gleixner
2013-05-27 9:55 ` [tip:timers/core] " tip-bot for Thomas Gleixner
2013-04-25 20:31 ` [patch 14/15] clockevents: Split out selection logic Thomas Gleixner
2013-05-27 9:57 ` [tip:timers/core] " tip-bot for Thomas Gleixner
2013-04-25 20:31 ` [patch 15/15] clockevents: Implement unbind functionality Thomas Gleixner
2013-05-27 9:59 ` [tip:timers/core] " tip-bot for Thomas Gleixner
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=alpine.LFD.2.02.1305151142100.1388@ionos \
--to=tglx@linutronix.de \
--cc=john.stultz@linaro.org \
--cc=linux-kernel@vger.kernel.org \
--cc=magnus.damm@gmail.com \
--cc=mingo@elte.hu \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox