From: Mike Rapoport <rppt@kernel.org>
To: Pratyush Yadav <pratyush@kernel.org>
Cc: Pasha Tatashin <pasha.tatashin@soleen.com>,
Alexander Graf <graf@amazon.com>,
Muchun Song <muchun.song@linux.dev>,
Oscar Salvador <osalvador@suse.de>,
David Hildenbrand <david@kernel.org>,
Andrew Morton <akpm@linux-foundation.org>,
Jason Miu <jasonmiu@google.com>,
Jork Loeser <jloeser@linux.microsoft.com>,
kexec@lists.infradead.org, linux-mm@kvack.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH v6 04/22] kho: return virtual address of mem_map from kho_get_mem_map()
Date: Sun, 2 Aug 2026 14:25:24 +0300 [thread overview]
Message-ID: <am8pJCeLv0cOMzpf@kernel.org> (raw)
In-Reply-To: <20260801084833.1897543-5-pratyush@kernel.org>
On Sat, Aug 01, 2026 at 10:48:13AM +0200, Pratyush Yadav wrote:
> From: "Pratyush Yadav (Google)" <pratyush@kernel.org>
>
> Currently the preserved memory map address is returned by
> kho_get_mem_map_phys(). It is only used by kho_populate().
> kho_populate() doesn't use the actual value. It only cares that the
> address exists and is valid.
>
> In coming patches, more callers will be added, all of which will need
> the virtual address of the preserved memory map. Since kho_populate()
> doesn't care about the actual value and only cares about validity, it
> can also use the virtual address returned by kho_get_mem_map(). It only
> needs to make sure the returned value is not NULL.
>
> Rename kho_get_mem_map_phys() to kho_get_mem_map() and return the
> virtual address of the preserved memory map.
>
> Signed-off-by: Pratyush Yadav (Google) <pratyush@kernel.org>
> ---
> kernel/liveupdate/kexec_handover.c | 25 +++++++++++++++++--------
> 1 file changed, 17 insertions(+), 8 deletions(-)
>
> diff --git a/kernel/liveupdate/kexec_handover.c b/kernel/liveupdate/kexec_handover.c
> index e7451743b87e..5c35c11c273b 100644
> --- a/kernel/liveupdate/kexec_handover.c
> +++ b/kernel/liveupdate/kexec_handover.c
> @@ -512,19 +512,24 @@ static int __init kho_preserved_memory_reserve(unsigned long key)
> return 0;
> }
>
> -/* Returns physical address of the preserved memory map from FDT */
> -static phys_addr_t __init kho_get_mem_map_phys(const void *fdt)
> +/* Returns virtual address of the preserved memory map from FDT */
> +static __init void *kho_get_mem_map(const void *fdt)
> {
> const void *mem_ptr;
> + phys_addr_t mem_map_phys;
> int len;
>
> mem_ptr = fdt_getprop(fdt, 0, KHO_FDT_MEMORY_MAP_PROP_NAME, &len);
> if (!mem_ptr || len != sizeof(u64)) {
> pr_err("failed to get preserved memory map\n");
> - return 0;
> + return NULL;
> }
>
> - return get_unaligned((const u64 *)mem_ptr);
> + mem_map_phys = get_unaligned((const u64 *)mem_ptr);
> + if (!mem_map_phys)
> + return NULL;
> +
> + return phys_to_virt(mem_map_phys);
This time sashiko found a real issue with this on arm64:
Will calling phys_to_virt() unconditionally here cause a panic on ARM64
during early boot?
When booting with KHO properties, early_init_dt_scan() calls kho_populate()
which then calls kho_get_mem_map(). Since this happens before
arm64_memblock_init() sets up memstart_addr, the internal phys_to_virt()
implementation evaluates PHYS_OFFSET with an uninitialized memstart_addr.
This fails the VM_BUG_ON(memstart_addr & 1) assertion when CONFIG_DEBUG_VM
is enabled.
I fixed this up by keeping kho_get_mem_map_phys() and adding a thin
kho_get_mem_map() that returns the virtual address.
This caused some rebase conflicts afterwards, please check I didn't mess up
anything :)
> }
>
> /*
> @@ -1647,9 +1652,8 @@ void __init kho_populate(phys_addr_t fdt_phys, u64 fdt_len,
> {
> unsigned int scratch_cnt = scratch_len / sizeof(*kho_scratch);
> struct kho_scratch *scratch = NULL;
> - phys_addr_t mem_map_phys;
> - void *fdt = NULL;
> bool populated = false;
> + void *fdt = NULL;
> int err;
>
> /* Validate the input FDT */
> @@ -1671,8 +1675,13 @@ void __init kho_populate(phys_addr_t fdt_phys, u64 fdt_len,
> goto unmap_fdt;
> }
>
> - mem_map_phys = kho_get_mem_map_phys(fdt);
> - if (!mem_map_phys)
> + /*
> + * At this point phys_to_virt() doesn't work properly and so
> + * kho_get_mem_map() can return a pre-KASLR virtual address. But here we
> + * only want to make sure the mem_map is valid so the actual value
> + * doesn't matter as long as it isn't NULL.
> + */
> + if (!kho_get_mem_map(fdt))
> goto unmap_fdt;
>
> scratch = early_memremap(scratch_phys, scratch_len);
> --
> 2.55.0.571.g244d577d93-goog
>
--
Sincerely yours,
Mike.
next prev parent reply other threads:[~2026-08-02 11:25 UTC|newest]
Thread overview: 25+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-08-01 8:48 [PATCH v6 00/22] kho: make boot time huge page allocation work nicely with KHO Pratyush Yadav
2026-08-01 8:48 ` [PATCH v6 01/22] kho: generalize radix tree APIs Pratyush Yadav
2026-08-01 8:48 ` [PATCH v6 02/22] kho: make radix max key width more obvious Pratyush Yadav
2026-08-01 8:48 ` [PATCH v6 03/22] kho: disallow wide keys in radix tree Pratyush Yadav
2026-08-01 8:48 ` [PATCH v6 04/22] kho: return virtual address of mem_map from kho_get_mem_map() Pratyush Yadav
2026-08-02 11:25 ` Mike Rapoport [this message]
2026-08-01 8:48 ` [PATCH v6 05/22] kho: store incoming radix tree in kho_in Pratyush Yadav
2026-08-01 8:48 ` [PATCH v6 06/22] kho: move all memory retrieval logic to kho_mem_retrieve() Pratyush Yadav
2026-08-01 8:48 ` [PATCH v6 07/22] kho: add a struct for radix callbacks Pratyush Yadav
2026-08-01 8:48 ` [PATCH v6 08/22] kho: add callback for table pages Pratyush Yadav
2026-08-01 8:48 ` [PATCH v6 09/22] kho: add data argument to radix walk callback Pratyush Yadav
2026-08-01 8:48 ` [PATCH v6 10/22] kho: allow early-boot usage of the KHO radix tree Pratyush Yadav
2026-08-01 8:48 ` [PATCH v6 11/22] kho: allow destroying " Pratyush Yadav
2026-08-01 8:48 ` [PATCH v6 12/22] kho: add kho_radix_init_tree() Pratyush Yadav
2026-08-01 8:48 ` [PATCH v6 13/22] kho: expose kho_scratch_overlap() to kexec_handover.h Pratyush Yadav
2026-08-01 8:48 ` [PATCH v6 14/22] kho: initialize kho_scratch pointer earlier in boot Pratyush Yadav
2026-08-01 8:48 ` [PATCH v6 15/22] kho: initialize preserved memory map radix tree earlier Pratyush Yadav
2026-08-01 8:48 ` [PATCH v6 16/22] mm/mm_init: simplify deferred_free_pages() migratetype init Pratyush Yadav
2026-08-01 8:48 ` [PATCH v6 17/22] mm/mm_init: don't rely on memblock to get KHO scratch migratetype Pratyush Yadav
2026-08-01 8:48 ` [PATCH v6 18/22] kho: extend scratch Pratyush Yadav
2026-08-01 8:48 ` [PATCH v6 19/22] memblock: always include KHO headers Pratyush Yadav
2026-08-01 8:48 ` [PATCH v6 20/22] memblock: make HugeTLB bootmem allocation work with KHO Pratyush Yadav
2026-08-01 8:48 ` [PATCH v6 21/22] memblock: add memblock_reserved_hugetlb_size() Pratyush Yadav
2026-08-01 8:48 ` [PATCH v6 22/22] kho: exclude hugetlb memory from scratch size calculation Pratyush Yadav
2026-08-02 11:28 ` [PATCH v6 00/22] kho: make boot time huge page allocation work nicely with KHO Mike Rapoport
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=am8pJCeLv0cOMzpf@kernel.org \
--to=rppt@kernel.org \
--cc=akpm@linux-foundation.org \
--cc=david@kernel.org \
--cc=graf@amazon.com \
--cc=jasonmiu@google.com \
--cc=jloeser@linux.microsoft.com \
--cc=kexec@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=muchun.song@linux.dev \
--cc=osalvador@suse.de \
--cc=pasha.tatashin@soleen.com \
--cc=pratyush@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox