From: "Luck, Tony" <tony.luck@intel.com>
To: Chen Yu <yu.c.chen@intel.com>
Cc: Reinette Chatre <reinette.chatre@intel.com>,
Ben Horgan <ben.horgan@arm.com>,
James Morse <james.morse@arm.com>,
Dave Martin <Dave.Martin@arm.com>,
Babu Moger <babu.moger@amd.com>, Fenghua Yu <fenghuay@nvidia.com>,
Borislav Petkov <bp@alien8.de>,
Thomas Gleixner <tglx@linutronix.de>,
Dave Hansen <dave.hansen@linux.intel.com>,
Peter Newman <peternewman@google.com>, <chen.yu@linux.dev>,
<x86@kernel.org>, <linux-kernel@vger.kernel.org>
Subject: Re: [RFC PATCH 25/31] x86/resctrl: Introduce region-based MBA write implementation on MMIO space
Date: Tue, 4 Aug 2026 14:13:12 -0700 [thread overview]
Message-ID: <anJV6OwBcQJB5y71@agluck-desk3> (raw)
In-Reply-To: <003c5ab0a49d3bd5d0dec0af50632073c378b6e8.1785680802.git.yu.c.chen@intel.com>
On Mon, Aug 03, 2026 at 12:07:38AM +0800, Chen Yu wrote:
> Implement the marc_hw_update() callback to program per-region MBA
> bandwidth values via MMIO.
>
> The MARC register layout packs 4 regions into each 64-bit register,
> with a 9-bit bandwidth field per region at (region % 4) * 16 bits.
> The MMIO address for a given CLOSID is calculated using the MARC index
> function 1:
>
> addr = base + Floor(Region / 4) * 512 + CLOS * 8
>
> Each controller handles a single (region, type) pair, but a write always
> touches the whole 64-bit register. The callback therefore does a
> read-modify-write: it changes only its own region's field and writes
> every other bit back exactly as it was read, so the reserved bits keep
> their original values. A shadow copy of the register (marc_buf) holds
> the value last written, which spares the read on later updates.
>
> Signed-off-by: Chen Yu <yu.c.chen@intel.com>
> ---
> arch/x86/kernel/cpu/resctrl/erdt.c | 52 ++++++++++++++++++++++++++
> arch/x86/kernel/cpu/resctrl/internal.h | 4 ++
> 2 files changed, 56 insertions(+)
>
> diff --git a/arch/x86/kernel/cpu/resctrl/erdt.c b/arch/x86/kernel/cpu/resctrl/erdt.c
> index 38720c3b4a3d..c25aff805b12 100644
> --- a/arch/x86/kernel/cpu/resctrl/erdt.c
> +++ b/arch/x86/kernel/cpu/resctrl/erdt.c
> @@ -275,6 +275,49 @@ struct erdt_domain_info *erdt_find_domain_info(int cpu)
>
> static void marc_hw_update(struct hw_param *m)
> {
> + struct rdt_hw_ctrl_domain *hw_dom = resctrl_to_arch_ctrl_dom(m->dom);
> + struct resctrl_hw_ctrl *hw_ctrl = resctrl_to_arch_ctrl(m->ctrl);
> + enum resctrl_ctrl_name name = hw_ctrl->r_ctrl.name;
> + unsigned int offset, region, type, region_offset_bits;
> + struct erdt_domain_info *d = hw_dom->d_info;
> + enum erdt_mmio_type mmio_type;
> + void __iomem *addr;
> + int closid_idx;
> + unsigned int i;
> + u64 val;
> +
> + if (!d || !d->marc)
> + return;
> +
> + offset = name - RESCTRL_CTRL_NAME_REGION0_OPT;
> + region = offset / RESCTRL_CTRL_REGION_NR_CTRLS;
> + type = offset % RESCTRL_CTRL_REGION_NR_CTRLS;
> + mmio_type = ERDT_MMIO_MARC_OPT + type;
> + region_offset_bits = (region % 4) * 16;
> +
> + if (d->marc_buf_type != mmio_type) {
> + memset(d->marc_buf, 0,
> + d->marc->mba_reg_size * 512 * sizeof(u64));
> + d->marc_buf_type = mmio_type;
> + }
> +
> + for (i = m->low; i < m->high; i++) {
> + closid_idx = (region / 4) * 64 + i;
> + addr = d->base[mmio_type] + closid_idx * 8;
> +
> + /* The cached value retains the reserved bits to be preserved. */
> + val = d->marc_buf[closid_idx];
> + if (!val)
> + val = readq(addr);
> +
> + if (WARN_ON_ONCE(!val))
> + return;
> +
> + val &= ~(0x1ffULL << region_offset_bits);
> + val |= (u64)(hw_dom->ctrl_val[i] & 0x1ff) << region_offset_bits;
> + d->marc_buf[closid_idx] = val;
> + writeq(val, addr);
> + }
> }
There are lots of opinions about bit fields. I'm a fan for h/w registers
accessed in architecture specific code.
I think the version below is easier to read than all the inline masks and
shifts.
-Tony
union bw_ctrl {
u64 reg;
struct {
u16 val : 9;
u16 rsvd : 7;
} regions[4];
};
static void marc_hw_update(struct hw_param *m)
{
struct rdt_hw_ctrl_domain *hw_dom = resctrl_to_arch_ctrl_dom(m->dom);
struct resctrl_hw_ctrl *hw_ctrl = resctrl_to_arch_ctrl(m->ctrl);
enum resctrl_ctrl_name name = hw_ctrl->r_ctrl.name;
struct erdt_domain_info *d = hw_dom->d_info;
unsigned int offset, region, type;
enum erdt_mmio_type mmio_type;
union bw_ctrl mmio_ctrl;
void __iomem *addr;
int closid_idx;
unsigned int i;
if (!d || !d->marc)
return;
offset = name - RESCTRL_CTRL_NAME_REGION0_OPT;
region = offset / RESCTRL_CTRL_REGION_NR_CTRLS;
type = offset % RESCTRL_CTRL_REGION_NR_CTRLS;
mmio_type = ERDT_MMIO_MARC_OPT + type;
if (d->marc_buf_type != mmio_type) {
memset(d->marc_buf, 0,
d->marc->mba_reg_size * 512 * sizeof(u64));
d->marc_buf_type = mmio_type;
}
for (i = m->low; i < m->high; i++) {
closid_idx = (region / 4) * 64 + i;
addr = d->base[mmio_type] + closid_idx * 8;
/* The cached value retains the reserved bits to be preserved. */
mmio_ctrl.reg = d->marc_buf[closid_idx];
if (!mmio_ctrl.reg)
mmio_ctrl.reg = readq(addr);
if (WARN_ON_ONCE(!mmio_ctrl.reg))
return;
mmio_ctrl.regions[region].val = hw_dom->ctrl_val[i];
d->marc_buf[closid_idx] = mmio_ctrl.reg;
writeq(mmio_ctrl.reg, addr);
}
}
next prev parent reply other threads:[~2026-08-04 21:13 UTC|newest]
Thread overview: 37+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-08-02 15:57 [RFC PATCH 00/31] Introduce region-aware RDT support Chen Yu
2026-08-02 16:02 ` [RFC PATCH 01/31] x86/topology: Export topo_lookup_cpuid() for resctrl use Chen Yu
2026-08-02 16:02 ` [RFC PATCH 02/31] x86/resctrl: Require 64-bit x86 for resctrl support Chen Yu
2026-08-02 16:02 ` [RFC PATCH 03/31] x86/resctrl: Parse ACPI ERDT table and save CACD cpumask for RMDD domains Chen Yu
2026-08-02 16:03 ` [RFC PATCH 04/31] x86/resctrl: Attach ACPI ERDT information to L3 mon domain on CPU online Chen Yu
2026-08-02 16:03 ` [RFC PATCH 05/31] x86/resctrl: Parse ACPI CMRC table Chen Yu
2026-08-04 17:19 ` Luck, Tony
2026-08-04 18:13 ` Luck, Tony
2026-08-05 4:59 ` Chen, Yu C
2026-08-02 16:03 ` [RFC PATCH 06/31] x86/resctrl: Refactor the monitor read function Chen Yu
2026-08-02 16:04 ` [RFC PATCH 07/31] fs/resctrl: Do not invoke smp_processor_id() in preemptible context Chen Yu
2026-08-02 16:04 ` [RFC PATCH 08/31] x86/resctrl: Introduce erdt_cpu_has() and erdt_support() Chen Yu
2026-08-02 16:05 ` [RFC PATCH 09/31] x86/resctrl: Add MMIO-based LLC occupancy monitoring support Chen Yu
2026-08-02 16:05 ` [RFC PATCH 10/31] Revert "x86/resctrl: NOT_FOR_INCLUSION: Example support for multiple controls" Chen Yu
2026-08-02 16:05 ` [RFC PATCH 11/31] x86/resctrl: Rename struct resctrl_membw to struct resctrl_ctrl_scalar Chen Yu
2026-08-02 16:05 ` [RFC PATCH 12/31] x86/resctrl: Rename struct resctrl_cache to struct resctrl_ctrl_bitmap Chen Yu
2026-08-02 16:05 ` [RFC PATCH 13/31] x86/resctrl: Add per-control and per-resource flags Chen Yu
2026-08-02 16:06 ` [RFC PATCH 14/31] x86/resctrl: Add emulation controller list to resctrl_ctrl Chen Yu
2026-08-02 16:06 ` [RFC PATCH 15/31] x86/resctrl: Parse ACPI MMRC table Chen Yu
2026-08-02 16:06 ` [RFC PATCH 16/31] x86/resctrl: Replace "msr" in monitoring data identifiers Chen Yu
2026-08-02 16:06 ` [RFC PATCH 17/31] x86/resctrl: Introduce region aware MBM event definitions Chen Yu
2026-08-02 16:06 ` [RFC PATCH 18/31] x86/resctrl: Introduce memory region based MBM read callback on MMIO space Chen Yu
2026-08-02 16:06 ` [RFC PATCH 19/31] x86/resctrl: Enable the region based events by adding them into the event Chen Yu
2026-08-02 16:06 ` [RFC PATCH 20/31] x86/resctrl: Rename msr_update to hw_update Chen Yu
2026-08-02 16:07 ` [RFC PATCH 21/31] x86/resctrl: Parse ACPI MARC table Chen Yu
2026-08-02 16:07 ` [RFC PATCH 22/31] fs/resctrl: Add region-based control names and resctrl_ctrl_name_region() Chen Yu
2026-08-02 16:07 ` [RFC PATCH 23/31] x86/resctrl: Add region aware MBA controllers Chen Yu
2026-08-02 16:07 ` [RFC PATCH 24/31] x86/resctrl: Attach ACPI ERDT information to ctrl domain on CPU online Chen Yu
2026-08-02 16:07 ` [RFC PATCH 25/31] x86/resctrl: Introduce region-based MBA write implementation on MMIO space Chen Yu
2026-08-04 21:13 ` Luck, Tony [this message]
2026-08-05 6:32 ` Chen, Yu C
2026-08-02 16:07 ` [RFC PATCH 26/31] x86/resctrl: Allow control writes from any CPU for MMIO controllers Chen Yu
2026-08-02 16:07 ` [RFC PATCH 27/31] x86/resctrl: Enable region-aware MBM/MBA via the RDT_CTRL register Chen Yu
2026-08-02 16:08 ` [RFC PATCH 28/31] x86/resctrl: Emulate the legacy MBA controller via the region MAX controls Chen Yu
2026-08-02 16:08 ` [RFC PATCH 29/31] fs/resctrl: Expose emulation controllers in a resource_schemata subdir Chen Yu
2026-08-02 16:08 ` [RFC PATCH 30/31] fs/resctrl: Fix excessive padding in schemata output Chen Yu
2026-08-02 16:08 ` [RFC PATCH 31/31] x86,fs/resctrl: Update Documentation for region aware RDT Chen Yu
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=anJV6OwBcQJB5y71@agluck-desk3 \
--to=tony.luck@intel.com \
--cc=Dave.Martin@arm.com \
--cc=babu.moger@amd.com \
--cc=ben.horgan@arm.com \
--cc=bp@alien8.de \
--cc=chen.yu@linux.dev \
--cc=dave.hansen@linux.intel.com \
--cc=fenghuay@nvidia.com \
--cc=james.morse@arm.com \
--cc=linux-kernel@vger.kernel.org \
--cc=peternewman@google.com \
--cc=reinette.chatre@intel.com \
--cc=tglx@linutronix.de \
--cc=x86@kernel.org \
--cc=yu.c.chen@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox