The Linux Kernel Mailing List
 help / color / mirror / Atom feed
From: Matthew Wilcox <willy@infradead.org>
To: Johannes Weiner <hannes@cmpxchg.org>
Cc: Tal Zussman <tz2294@columbia.edu>,
	Andrew Morton <akpm@linux-foundation.org>,
	Chris Li <chrisl@kernel.org>, Kairui Song <kasong@tencent.com>,
	Kemeng Shi <shikemeng@huaweicloud.com>,
	Nhat Pham <nphamcs@gmail.com>, Baoquan He <baoquan.he@linux.dev>,
	Barry Song <baohua@kernel.org>,
	Youngjun Park <youngjun.park@lge.com>,
	David Hildenbrand <david@kernel.org>,
	Lorenzo Stoakes <ljs@kernel.org>,
	"Liam R. Howlett" <liam@infradead.org>,
	Vlastimil Babka <vbabka@kernel.org>,
	Mike Rapoport <rppt@kernel.org>,
	Suren Baghdasaryan <surenb@google.com>,
	Michal Hocko <mhocko@suse.com>, Christoph Hellwig <hch@lst.de>,
	Yosry Ahmed <yosry@kernel.org>,
	Chengming Zhou <chengming.zhou@linux.dev>,
	linux-mm@kvack.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 6/6] mm/swap: rename __swap_writepage() to __swap_writeout()
Date: Fri, 7 Aug 2026 20:05:00 +0100	[thread overview]
Message-ID: <anYsXImJ86OY-IZI@casper.infradead.org> (raw)
In-Reply-To: <anYPVB3dwJCVoXVv@cmpxchg.org>

On Fri, Aug 07, 2026 at 01:01:08PM -0400, Johannes Weiner wrote:
> On Thu, Aug 06, 2026 at 06:55:38PM -0400, Tal Zussman wrote:
> > Commit 84798514db50 ("mm: Remove swap_writepage() and
> > shmem_writepage()") renamed swap_writepage() to swap_writeout().  Rename
> > __swap_writepage(), which operates on a folio, to match its caller.
> > Update a stale reference to swap_writepage() in swapfile.c as well.
> > 
> > Signed-off-by: Tal Zussman <tz2294@columbia.edu>
> 
> Looking at that commit, I can only guess that pageout() had an
> influence on the swap_writeout() name.
> 
> However, on the read side of the page_io.c API, we're following
> swap_read_folio* consistently.
> 
> [__]swap_write_folio* would seem more symmetrical?

I wanted to be sure that filesystem authors see this as something unusual
rather than something they should implement as a counterpart to their
read_folio operation.  So it was intentionally asymmetric.  I'm open
to discussion of better names, but my hope is that we get closer to the
'do direct IO' model and shmem doesn't need to swizzle its folios into
the swapcache to get them into the swap system.

> [ At the risk of starting something, should the file itself be
>   renamed? swap_rw.c or swap_io.c or something. ]

I'm not opposed to that either!

  reply	other threads:[~2026-08-07 22:00 UTC|newest]

Thread overview: 23+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-08-06 22:55 [PATCH 0/6] mm/page_io: folio conversion cleanups Tal Zussman
2026-08-06 22:55 ` [PATCH 1/6] mm/page_io: convert write completion handlers to folios Tal Zussman
2026-08-07 16:49   ` Johannes Weiner
2026-08-07 18:42     ` Matthew Wilcox
2026-08-06 22:55 ` [PATCH 2/6] mm: remove PageReclaim Tal Zussman
2026-08-07 16:50   ` Johannes Weiner
2026-08-07 18:48   ` Matthew Wilcox
2026-08-07 19:27     ` Tal Zussman
2026-08-06 22:55 ` [PATCH 3/6] mm/page_io: use swap entries directly in zeromap helpers Tal Zussman
2026-08-07 16:53   ` Johannes Weiner
2026-08-07 18:50   ` Matthew Wilcox
2026-08-06 22:55 ` [PATCH 4/6] mm/page_io: rename bio_associate_blkg_from_page() Tal Zussman
2026-08-07 16:53   ` Johannes Weiner
2026-08-07 18:56   ` Matthew Wilcox
2026-08-07 19:30     ` Tal Zussman
2026-08-06 22:55 ` [PATCH 5/6] mm/page_io: refer to folios in swap_writeout() comments Tal Zussman
2026-08-07 16:54   ` Johannes Weiner
2026-08-07 18:59   ` Matthew Wilcox
2026-08-06 22:55 ` [PATCH 6/6] mm/swap: rename __swap_writepage() to __swap_writeout() Tal Zussman
2026-08-07 17:01   ` Johannes Weiner
2026-08-07 19:05     ` Matthew Wilcox [this message]
2026-08-07 19:44     ` Tal Zussman
2026-08-07 19:06   ` Matthew Wilcox

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=anYsXImJ86OY-IZI@casper.infradead.org \
    --to=willy@infradead.org \
    --cc=akpm@linux-foundation.org \
    --cc=baohua@kernel.org \
    --cc=baoquan.he@linux.dev \
    --cc=chengming.zhou@linux.dev \
    --cc=chrisl@kernel.org \
    --cc=david@kernel.org \
    --cc=hannes@cmpxchg.org \
    --cc=hch@lst.de \
    --cc=kasong@tencent.com \
    --cc=liam@infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=ljs@kernel.org \
    --cc=mhocko@suse.com \
    --cc=nphamcs@gmail.com \
    --cc=rppt@kernel.org \
    --cc=shikemeng@huaweicloud.com \
    --cc=surenb@google.com \
    --cc=tz2294@columbia.edu \
    --cc=vbabka@kernel.org \
    --cc=yosry@kernel.org \
    --cc=youngjun.park@lge.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox