From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from smtp.kernel.org (aws-us-west-2-korg-mail-alma10-1.taild15c8.ts.net [100.103.45.18]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by smtp.subspace.kernel.org (Postfix) with ESMTPS id 75DCF3DCD8D for ; Mon, 10 Aug 2026 12:59:38 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; arc=none smtp.client-ip=100.103.45.18 ARC-Seal:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1786366779; cv=none; b=B6bNbHOgakmgmjtIpjhBH2pAKvMp+RTodQaMvUGnlRUwMAXHm4h+TdrYBZ8joIm2+qXEjEiw+FhM+aZasu8o13H6ZkU2sCNDw+t0WM4Ww0yOsJeVnanVDWXnmrYXiodUCCMefcM6lnmdFinzC3SuDGNpAOB5pFLTEiJYJmYIBCo= ARC-Message-Signature:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1786366779; c=relaxed/simple; bh=xwD52R3nEbU7Q2/pfVXThw9xTFHQLrENbEXYW5ARZtg=; h=Date:From:To:Cc:Subject:Message-ID:References:MIME-Version: Content-Type:Content-Disposition:In-Reply-To; b=u91Qt1sn5Olzsw62GneABg92i2Rlfx+d2K94L6Z5BdqchoSTMNbm8BEUIEtJ0pFkptLzBq/f71SQFa3b6dc3Fgkavv0aolzOVlc+AtorQC2/RZr4zpxk+Ty5jmxyJN+zXuWDi4kTL4mb1CLnNcQ+86jvhbcUpxMdrAyMhrgNtdw= ARC-Authentication-Results:i=1; smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=kernel.org header.i=@kernel.org header.b=T8N/ScqI; arc=none smtp.client-ip=100.103.45.18 Authentication-Results: smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=kernel.org header.i=@kernel.org header.b="T8N/ScqI" Received: by smtp.kernel.org (Postfix) with ESMTPSA id 6B4AC1F000E9; Mon, 10 Aug 2026 12:59:33 +0000 (UTC) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=kernel.org; s=k20260515; t=1786366778; bh=MYlcj+u2W+VYiTXVxXMnRS7W+yO0vIm6ouPOUsdwmkc=; h=Date:From:To:Cc:Subject:References:In-Reply-To; b=T8N/ScqIRjJAOgYs3+PaMhjfCYen/schAQ8rtWFcVjOk3u8u4UptVgFR6RGq3Dx5M VGxojNJ5+REH0WMRaMaJtyik/MA18pnCOt1Sw/rDp8h6KvlISnfEQ2soFKvT6QiQOb wb69fjmO/6z5KEtcNhwbYf5jr915axnLMLnECgKo4TGU/0p4sSL6to/iTe58v/lKET SS7A5yrPnG5XG/SjiWg10X9WT69T2A7Skc/4xpnG0Y2pQH4Bld+fcLnkoGJeA6MpMa B8NXAo/NJsKxM2bDsv8dcSZIAA/I59WOXNFIqvfMJevz9SsRxfieYAoWSE0YG7Ujgh 5cqh1ljwPA//A== Date: Mon, 10 Aug 2026 13:59:18 +0100 From: "Lorenzo Stoakes (ARM)" To: Tal Zussman Cc: Johannes Weiner , Andrew Morton , Chris Li , Kairui Song , Kemeng Shi , Nhat Pham , Baoquan He , Barry Song , Youngjun Park , David Hildenbrand , "Liam R. Howlett" , Vlastimil Babka , Mike Rapoport , Suren Baghdasaryan , Michal Hocko , Matthew Wilcox , Christoph Hellwig , Yosry Ahmed , Chengming Zhou , linux-mm@kvack.org, linux-kernel@vger.kernel.org Subject: Re: [PATCH 6/6] mm/swap: rename __swap_writepage() to __swap_writeout() Message-ID: References: <20260806-b4-page_io-folios-v1-0-0899bac3b826@columbia.edu> <20260806-b4-page_io-folios-v1-6-0899bac3b826@columbia.edu> <0208741b-ba5d-4044-9991-575d162f7513@columbia.edu> Precedence: bulk X-Mailing-List: linux-kernel@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <0208741b-ba5d-4044-9991-575d162f7513@columbia.edu> On Fri, Aug 07, 2026 at 10:44:31PM +0300, Tal Zussman wrote: > On 8/7/26 1:01 PM, Johannes Weiner wrote: > > On Thu, Aug 06, 2026 at 06:55:38PM -0400, Tal Zussman wrote: > >> Commit 84798514db50 ("mm: Remove swap_writepage() and > >> shmem_writepage()") renamed swap_writepage() to swap_writeout(). Rename > >> __swap_writepage(), which operates on a folio, to match its caller. > >> Update a stale reference to swap_writepage() in swapfile.c as well. > >> > >> Signed-off-by: Tal Zussman > > > > Thanks for the reviews! > > > Looking at that commit, I can only guess that pageout() had an > > influence on the swap_writeout() name. > > > > However, on the read side of the page_io.c API, we're following > > swap_read_folio* consistently. > > > > [__]swap_write_folio* would seem more symmetrical? > > > > That sounds reasonable, will change it. > > > [ At the risk of starting something, should the file itself be > > renamed? swap_rw.c or swap_io.c or something. ] > > > > You said it, not me... :) > I like swap_io.c - happy to stick a patch at the beginning renaming it > if there are no objections. folio_io.c! ;) Kidding, swap_io.c seems reasonable, feel free to rename it. You should also update the entry in MAINTAINERS too. -- Cheers, Lorenzo