From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from mail-oa1-f43.google.com (mail-oa1-f43.google.com [209.85.160.43]) (using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)) (No client certificate requested) by smtp.subspace.kernel.org (Postfix) with ESMTPS id 6D6573659FB for ; Mon, 10 Aug 2026 22:46:18 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; arc=none smtp.client-ip=209.85.160.43 ARC-Seal:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1786401979; cv=none; b=IqdHGzhJDoLRh1VsB9HrP7eVQ/s5wU3HIelBtLXM5P3MvspuWizMu6T5sROGfxL8q4xAmOeUhdH+c43BMRj1PXGhm9qYj0rJPfp0IJ85rHE4sQb03jOEx3nKx+OvRZpD1PXBCVUdWBMH3cr+sOz3OXP9w9/MND/oXlYyAN2EFpE= ARC-Message-Signature:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1786401979; c=relaxed/simple; bh=atio8WWti2RY9sgr+9gukfvD+3mJSshfufJStoESB30=; h=Date:From:To:Cc:Subject:Message-ID:References:MIME-Version: Content-Type:Content-Disposition:In-Reply-To; b=cb1M1JtKkWLMMpeR5ePL58w3UomH5ymbNzyUvLFDF/pukPvvV8xEjaWpvK4sP/+tRHxQtkjNuGnX2+A9TIkDsL3D8LEP0uGRPHwFE+clHsnjT4D8gYi3R5nW+kaoEk6TBZa1UaPDeifSSkKbGYKu4NZLookgPrj1AM0TUz1ywpg= ARC-Authentication-Results:i=1; smtp.subspace.kernel.org; dmarc=pass (p=none dis=none) header.from=gmail.com; spf=pass smtp.mailfrom=gmail.com; dkim=pass (2048-bit key) header.d=gmail.com header.i=@gmail.com header.b=GIcVsMT0; arc=none smtp.client-ip=209.85.160.43 Authentication-Results: smtp.subspace.kernel.org; dmarc=pass (p=none dis=none) header.from=gmail.com Authentication-Results: smtp.subspace.kernel.org; spf=pass smtp.mailfrom=gmail.com Authentication-Results: smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=gmail.com header.i=@gmail.com header.b="GIcVsMT0" Received: by mail-oa1-f43.google.com with SMTP id 586e51a60fabf-44caeb973b3so91394fac.1 for ; Mon, 10 Aug 2026 15:46:18 -0700 (PDT) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20251104; t=1786401977; x=1787006777; darn=vger.kernel.org; h=in-reply-to:content-disposition:content-type:mime-version :references:message-id:subject:cc:to:from:date:from:to:cc:subject :date:message-id:reply-to:content-type; bh=6vKSn7IJifBrXS/CY6LXzOgG31cv6satHmdZfKI7Lkg=; b=GIcVsMT0jUTcRwdjbgVi/YDBP29+uy27JBsU/4XeQhUqqo6mkFEgN6NxM2D0r8ZOrM iIOKk0G0pmUS7xd8qXxnb3D9OIwQYs0aqR3HU0ZW4N4CTrp/QyMplaVGevY6pgCdK1xh 92rTnJuAK3u2bOl59KY+VOgtYMnywYSIxiEYlqI/r9yffIzPXOMGOMLgxmeko5sP/Y4z /I0QOkMLKbGL/QdrZje23Ld1n+hNImZ/IGgRaEi+ILc8+MwMRnpLwZZhO1lLZ8wIliFV NyklrVf3B4CgfGpEq0hYOxrScMfaVLjA10t2Re2cZ9UR8f77Ktyt6SR9617RkD4JCd5w bKCQ== X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20251104; t=1786401977; x=1787006777; h=in-reply-to:content-disposition:content-type:mime-version :references:message-id:subject:cc:to:from:date:x-gm-gg :x-gm-message-state:from:to:cc:subject:date:message-id:reply-to :content-type; bh=6vKSn7IJifBrXS/CY6LXzOgG31cv6satHmdZfKI7Lkg=; b=i9Kaea4iLIm8SOrNpqQ6Q+MoSlxui9Q7ThNpIa8d/5L/53H0d2tYrWED6xlzG/DpCP w8uP4UzNKbGFbEWR+dQuWiMSzKyUaqOn9UAmPDuR/mp7oYtrjHKgCj1DJVV9UVeumyew f455Y1m+wM4vdY0v6uP24A/vywQqiMybHgifzOqqiNEm2Og5qHLgcIrLiR92BLncyo+G 2P0pCWB96wVicVjFH5dy2j0nibMQNXfeBcXB2j70bpcUEmGdU7HySppP7LiPTQDyFv1l hARtrvD208QSXHnFY41mV3MXYXtXQm4xapTgVpiu5vFZzRLOZo6Pjrq3KumCEK46u7aZ bQDg== X-Forwarded-Encrypted: i=1; AHgh+RoYQIQubOE1S0HfoL4O//K/kODzCR4cVUyIwfKT/Kt2kjv2KNtiaA7oqBgzJ8a6DqNwjO+8qcphlj6UblI=@vger.kernel.org X-Gm-Message-State: AOJu0Yw9uYoAa4cm2et69VFxyHPmI0QXAt6c4+9z7aGso73AcYnRnFj+ RfgXoqBbj7mdayQJG3zBRTtDwovZ245q6ozCOOVMoa53zfsBO3hkhm32 X-Gm-Gg: AR+sD10/AVFyAov/fW95yAiXsgxFfe3TulhkUZ87fwVO7wGOTtEdGrjOIwe8gDgWiM7 fPCNHfbBGFzZzghcMoK6K7mfijENw2sv6/kUbbWolXFlZiOlGmAbHQydIV8TSaz8diVrB6XwZcw q4CC6Kn8pnFhaScL7WejKuw1h63pznW4ZT9/BOAnt13j01YAWdcOxvYOgCIKGq1LBA8VW5pDyWr M0N0nYckBwCtpyrp+thlEM4qP5rGQB3qqdLrtraXEtCaJd8EBVcHsD4tj2keD+jmlSo+pzhIXT4 rLJDGQJPTA2hSNXqlej6UPNcXE+h3Fk3s5YTAooKoKSKppIrRofRUlfTGx2AtjyC6yHkxa9YrKU 4ikVG2brBH7Y66BOAQw7JE7sdm5FH6x9WMJXWKxLwdKdTexc6UXTLP3g+pm8zk06ksDl2NeWJsh aoT51GWkw5cy97i0hUdv+gop+t90KHxFzlMuPBhiD1v+EhhSvDc8zXMiv+fqxagHMoRQ== X-Received: by 2002:a05:6870:6120:b0:448:c946:9ae1 with SMTP id 586e51a60fabf-4599eebfa44mr24566861fac.18.1786401977177; Mon, 10 Aug 2026 15:46:17 -0700 (PDT) Received: from gmail.com ([108.243.219.47]) by smtp.gmail.com with ESMTPSA id 586e51a60fabf-459f1a88ef6sm9276831fac.8.2026.08.10.15.46.14 (version=TLS1_3 cipher=TLS_AES_256_GCM_SHA384 bits=256/256); Mon, 10 Aug 2026 15:46:15 -0700 (PDT) Date: Mon, 10 Aug 2026 17:46:12 -0500 From: Akash Sukhavasi To: Neil Armstrong Cc: Doug Anderson , Linus Walleij , Jessica Zhang , Maarten Lankhorst , Maxime Ripard , Thomas Zimmermann , David Airlie , Simona Vetter , dri-devel@lists.freedesktop.org, linux-kernel@vger.kernel.org Subject: Re: [PATCH] drm/panel: samsung-s6d16d0: Use mipi_dsi_*_multi(); fix minor bugs Message-ID: References: <20260807-mipi-dsi-s6d16d0-multi-v1-1-c6179f6f3c98@gmail.com> <3aaca93e-ea45-4a57-9532-7fb95f23c4fa@linaro.org> Precedence: bulk X-Mailing-List: linux-kernel@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <3aaca93e-ea45-4a57-9532-7fb95f23c4fa@linaro.org> On Mon, Aug 10, 2026 at 11:57:06AM +0200, Neil Armstrong wrote: > > + struct mipi_dsi_multi_context dsi_ctx = { .dsi = to_mipi_dsi_device(s6->dev) }; > > Ok why not keeping the original: > > struct mipi_dsi_device *dsi = to_mipi_dsi_device(s6->dev); > struct mipi_dsi_multi_context dsi_ctx = { .dsi = dsi }; > > > It's much easier to read, for me at least, but I won't block it... > > > /* Enter sleep mode */ > > - ret = mipi_dsi_dcs_enter_sleep_mode(dsi); > > - if (ret) { > > - dev_err(s6->dev, "failed to enter sleep mode (%d)\n", ret); > > - return ret; > > - } > > + mipi_dsi_dcs_enter_sleep_mode_multi(&dsi_ctx); > > Add a comment you ignore the the dsi_ctx.accum_err and it's fine > You could write: > > if (dsi_ctx.accum_err) { > gpiod_set_value_cansleep(s6->reset_gpio, 1); > regulator_disable(s6->supply); > } > > return dsi_ctx.accum_err; Thanks for the review, Neil. Will address all three in v2. On the intermediate dsi variable, I prefer inlining it to keep one fewer variable in scope, but I see the readability argument. Will revert it. -- Thanks, Akash