From: Shakeel Butt <shakeel.butt@linux.dev>
To: Michal Hocko <mhocko@suse.com>
Cc: Andrew Morton <akpm@linux-foundation.org>,
Johannes Weiner <hannes@cmpxchg.org>,
Roman Gushchin <roman.gushchin@linux.dev>,
Muchun Song <muchun.song@linux.dev>,
Joshua Hahn <joshua.hahnjy@gmail.com>,
Jakub Kicinski <kuba@kernel.org>,
Meta kernel team <kernel-team@meta.com>,
linux-mm@kvack.org, cgroups@vger.kernel.org,
linux-kernel@vger.kernel.org,
Joy Chaoyue Xiong <cxiong@meta.com>
Subject: Re: [PATCH v2] memcg: trim the per-cpu charge stock instead of draining it
Date: Thu, 20 Aug 2026 09:06:29 -0700 [thread overview]
Message-ID: <aoclMssJAyYw2aCn@linux.dev> (raw)
In-Reply-To: <aoanalsTiGmL69LN@tiehlicka>
On Thu, Aug 20, 2026 at 09:06:18AM +0200, Michal Hocko wrote:
> On Wed 19-08-26 18:20:10, Shakeel Butt wrote:
> > Joy reported that an application generating a request/response traffic
> > pattern spends 44.6% to 57.0% of CPU in the memcg charge/uncharge path
> > for a range of message sizes, against 0.27% to 0.71% outside that range.
> > Running from the root memcg, where socket memory accounting is skipped,
> > recovers the performance.
> >
> > Tracing the charge path showed that the application generates a pattern
> > where the write syscall charges one page and the read syscall uncharges
> > two pages on the same CPU. This hits a corner case in the memcg percpu
> > stock code that thrashes the stock continuously.
> >
> > In the memcg percpu stock code, MEMCG_CHARGE_BATCH (64) is both the high
> > watermark and the emptying target, i.e. on a request to charge one page
> > the kernel charges MEMCG_CHARGE_BATCH pages and caches
> > (MEMCG_CHARGE_BATCH - 1) of them in the percpu stock. The following
> > uncharge of 2 pages takes the cached count to (MEMCG_CHARGE_BATCH + 1),
> > and refill_stock() then empties the cache completely. With such a
> > pattern the percpu stock becomes completely ineffective.
> >
> > Instead of a single boundary point for charges, use the technique the
> > page allocator uses for its own percpu caches, which keeps the watermark
> > and the emptying target apart: nr_pcp_free() frees between batch and
> > high - batch pages, leaving at least pcp->batch on the list. Add a high
> > watermark MEMCG_STOCK_HIGH and, once the cached count goes over it,
> > return only the pages above MEMCG_STOCK_LOW. The watermarks are
> > MEMCG_CHARGE_BATCH apart, so a page_counter update still covers a full
> > batch.
> >
> > For now, keep MEMCG_STOCK_HIGH same as MEMCG_CHARGE_BATCH and in
> > future we will reevaluate if it makes sense to increase it.
> >
> > Reported-by: Joy Chaoyue Xiong <cxiong@meta.com>
> > Signed-off-by: Shakeel Butt <shakeel.butt@linux.dev>
>
> Acked-by: Michal Hocko <mhocko@suse.com>
Thanks.
> One minor nit
>
> > ---
> >
> > Changes since v1:
> > http://lore.kernel.org/20260817234651.666540-1-shakeel.butt@linux.dev
> > - Kept the upper limit of memcg stock same as before (Michal)
> >
> > mm/memcontrol.c | 25 +++++++++++++++++++------
> > 1 file changed, 19 insertions(+), 6 deletions(-)
> >
> > diff --git a/mm/memcontrol.c b/mm/memcontrol.c
> > index 17da1f43b7d3..58e4d23cf5e0 100644
> > --- a/mm/memcontrol.c
> > +++ b/mm/memcontrol.c
> [...]
> > @@ -2254,9 +2264,12 @@ static void refill_stock(struct mem_cgroup *memcg, unsigned int nr_pages)
> > empty_slot = i;
> > if (memcg == READ_ONCE(stock->cached[i])) {
> > stock_pages = READ_ONCE(stock->nr_pages[i]) + nr_pages;
> > + if (stock_pages > MEMCG_STOCK_HIGH) {
> > + memcg_uncharge(memcg,
> > + stock_pages - MEMCG_STOCK_LOW);
> > + stock_pages = MEMCG_STOCK_LOW;
>
> I would find it easier to read to keep the update in sync with
> memcg_uncharge, i.e.
> stock_pages = WRITE_ONCE(stock_pages - MEMCG_STOCK_LOW)
Sorry I am not sure I understand your suggestion. The WRITE_ONCE() is throwing
me off.
> > + }
> > WRITE_ONCE(stock->nr_pages[i], stock_pages);
> > - if (stock_pages > MEMCG_CHARGE_BATCH)
> > - drain_stock(stock, i);
> > success = true;
> > break;
> > }
> > --
> > 2.53.0-Meta
>
> --
> Michal Hocko
> SUSE Labs
next prev parent reply other threads:[~2026-08-20 16:07 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-08-20 1:20 [PATCH v2] memcg: trim the per-cpu charge stock instead of draining it Shakeel Butt
2026-08-20 7:06 ` Michal Hocko
2026-08-20 16:06 ` Shakeel Butt [this message]
2026-08-20 18:44 ` Michal Hocko
2026-08-20 20:50 ` Shakeel Butt
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=aoclMssJAyYw2aCn@linux.dev \
--to=shakeel.butt@linux.dev \
--cc=akpm@linux-foundation.org \
--cc=cgroups@vger.kernel.org \
--cc=cxiong@meta.com \
--cc=hannes@cmpxchg.org \
--cc=joshua.hahnjy@gmail.com \
--cc=kernel-team@meta.com \
--cc=kuba@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=mhocko@suse.com \
--cc=muchun.song@linux.dev \
--cc=roman.gushchin@linux.dev \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox