From: Sean Rhodes <sean@starlabs.systems>
To: chrome-platform@lists.linux.dev
Cc: "Corentin Chary" <corentin.chary@gmail.com>,
"Luke D. Jones" <luke@ljones.dev>,
"Denis Benato" <denis.benato@linux.dev>,
"Hans de Goede" <hansg@kernel.org>,
"Ilpo Järvinen" <ilpo.jarvinen@linux.intel.com>,
"Prasanth Ksr" <prasanth.ksr@dell.com>,
"Jorge Lopez" <jorge.lopez2@hp.com>,
"Mark Pearson" <mpearson-lenovo@squebb.ca>,
"Derek J. Clark" <derekjohn.clark@gmail.com>,
"Joshua Grisham" <josh@joshuagrisham.com>,
platform-driver-x86@vger.kernel.org, Dell.Client.Kernel@dell.com,
"Sean Rhodes" <sean@starlabs.systems>,
"Michael S. Tsirkin" <mst@redhat.com>,
"Chen-Yu Tsai" <wenst@chromium.org>,
"Huacai Chen" <chenhuacai@kernel.org>,
"Tzung-Bi Shih" <tzungbi@kernel.org>,
"Brian Norris" <briannorris@chromium.org>,
"Julius Werner" <jwerner@chromium.org>,
"Thomas Zimmermann" <tzimmermann@suse.de>,
"Javier Martinez Canillas" <javierm@redhat.com>,
"Maarten Lankhorst" <maarten.lankhorst@linux.intel.com>,
"Maxime Ripard" <mripard@kernel.org>,
"David Airlie" <airlied@gmail.com>,
"Simona Vetter" <simona@ffwll.ch>,
"Florian Fainelli" <florian.fainelli@broadcom.com>,
"Takashi Sakamoto" <o-takashi@sakamocchi.jp>,
"Bjorn Helgaas" <bhelgaas@google.com>,
"Uwe Kleine-König (The Capable Hub)"
<u.kleine-koenig@baylibre.com>,
"Titouan Ameline de Cadeville" <titouan.ameline@gmail.com>,
"Kees Cook" <kees@kernel.org>,
"Danilo Krummrich" <dakr@kernel.org>,
dri-devel@lists.freedesktop.org,
"Krzysztof Kozlowski" <krzysztof.kozlowski@oss.qualcomm.com>,
"Bjorn Andersson" <andersson@kernel.org>,
"Dmitry Baryshkov" <dmitry.baryshkov@oss.qualcomm.com>,
"Geert Uytterhoeven" <geert@linux-m68k.org>,
"Arnd Bergmann" <arnd@arndb.de>,
"Eric Biggers" <ebiggers@kernel.org>,
"Luca Weiss" <luca.weiss@fairphone.com>,
"Michal Simek" <michal.simek@amd.com>,
"Sven Peter" <sven@kernel.org>,
linux-kernel@vger.kernel.org, oliver@liuxiaozhen.dev
Subject: [PATCH v13 RESEND 0/5] coreboot CFR firmware attributes
Date: Mon, 17 Aug 2026 22:54:46 +0100 [thread overview]
Message-ID: <cover.1787003659.git.sean@starlabs.systems> (raw)
Resending v13 because the previous send path corrupted several inline patch
bodies. No patch content changes.
Move the firmware attributes class helper out of platform/x86, rename the
coreboot-table firmware driver directory from google to coreboot, and add a
coreboot CFR firmware attributes driver.
Changes in v13:
- Rebase on current upstream master.
- Restore the CONFIG_GOOGLE_* to CONFIG_COREBOOT_* renames for generic
coreboot firmware symbols, with the old names kept as transitional symbols.
Julius clarified that the symbol names are part of the directory rename
cleanup and should describe coreboot rather than Google. Update the matching
Kconfig dependencies and Makefile gates to use the new symbols.
- Split the arm64 defconfig symbol update into a separate final patch, as
requested by Krzysztof and Julius, instead of folding it into the rename.
- Move the COREBOOT FIRMWARE DRIVERS MAINTAINERS entry to its alphabetical
position.
- Make the CFR APM_CNT runtime-apply dependency explicit with HAS_IOPORT
instead of using an x86-only runtime branch.
Changes in v12:
- Temporarily kept the existing CONFIG_GOOGLE_* symbols and dropped the
arm64 defconfig update after review feedback against the user-visible
config rename. v13 supersedes this with transitional symbols and a split
defconfig patch.
- Free invalid enum labels before returning an error from CFR enum parsing.
Changes in v11:
- Keep the scoped cleanup in the CFR driver, but use explicit goto cleanup for
the nested sysfs group registration path.
Changes in v10:
- Rename generic firmware Kconfig symbols from CONFIG_GOOGLE_* to
CONFIG_COREBOOT_* and keep the old names as transitional symbols, as
suggested by Julius.
- Update arm64 defconfig and DRM coreboot framebuffer dependencies for the new
symbols. In v13, the arm64 defconfig update is split into its own patch.
- Address the nested cleanup-path review on CFR attribute registration.
Changes in v9:
- Add the missing kstrtox.h include used by kstrtou32().
- Use a single kobject rollback path when setting registration fails.
- Split a few helper locals for readability, including the pending reboot
device lookup and enum-value population.
- Avoid an intermediate void pointer cast while parsing numeric CFR options.
- Check the possible-values buffer length before computing each label length.
Changes in v8:
- Add a preparatory include-order cleanup before moving the firmware attributes
class helper.
- Add direct includes for __packed and container_of(), use scoped cleanup for
EFI names and the driver mutex, and document the efivar lock requirement on
private helpers.
- Replace the duplicated CFR record walkers with one checked iterator that
distinguishes malformed input from the end of a record list.
- Validate enum entries before accessing them and propagate malformed child
records instead of treating them as absent.
- Restore the EFI variable after a failed runtime apply without retrying the
failed firmware operation, and only emit a change event when the new EFI value
remains stored.
- Document the possible-values size limit and why CFR entries without a usable
runtime EFI variable are skipped.
Tested on a Star Labs Byte with firmware 26.07: runtime APM_CNT apply was
verified with power_led, and reboot-needed behavior was verified with
debug_level.
Sean Rhodes (5):
platform/x86: Sort firmware attributes class includes
firmware: Move firmware attributes class helper
firmware: Rename google firmware directory to coreboot
firmware: coreboot: Add CFR firmware attributes driver
arm64: defconfig: Update coreboot firmware symbols
MAINTAINERS | 34 +-
arch/arm64/configs/defconfig | 6 +-
drivers/firmware/Kconfig | 5 +-
drivers/firmware/Makefile | 3 +-
drivers/firmware/{google => coreboot}/Kconfig | 89 +-
drivers/firmware/coreboot/Makefile | 15 +
drivers/firmware/{google => coreboot}/cbmem.c | 0
drivers/firmware/coreboot/coreboot-cfr.c | 1204 +++++++++++++++++
.../{google => coreboot}/coreboot_table.c | 0
.../{google => coreboot}/coreboot_table.h | 0
.../framebuffer-coreboot.c | 0
drivers/firmware/{google => coreboot}/gsmi.c | 0
.../memconsole-coreboot.c | 0
.../memconsole-x86-legacy.c | 0
.../{google => coreboot}/memconsole.c | 0
.../{google => coreboot}/memconsole.h | 6 +-
drivers/firmware/{google => coreboot}/vpd.c | 0
.../{google => coreboot}/vpd_decode.c | 0
.../{google => coreboot}/vpd_decode.h | 0
.../firmware_attributes_class.c | 2 +-
drivers/firmware/google/Makefile | 14 -
drivers/gpu/drm/sysfb/Kconfig | 2 +-
drivers/platform/x86/Kconfig | 3 -
drivers/platform/x86/Makefile | 2 -
drivers/platform/x86/asus-armoury.c | 2 +-
.../x86/dell/dell-wmi-sysman/sysman.c | 9 +-
drivers/platform/x86/hp/hp-bioscfg/bioscfg.c | 9 +-
drivers/platform/x86/lenovo/think-lmi.c | 5 +-
drivers/platform/x86/lenovo/wmi-other.c | 2 +-
drivers/platform/x86/samsung-galaxybook.c | 3 +-
.../linux/firmware_attributes.h | 6 +-
31 files changed, 1348 insertions(+), 73 deletions(-)
rename drivers/firmware/{google => coreboot}/Kconfig (57%)
create mode 100644 drivers/firmware/coreboot/Makefile
rename drivers/firmware/{google => coreboot}/cbmem.c (100%)
create mode 100644 drivers/firmware/coreboot/coreboot-cfr.c
rename drivers/firmware/{google => coreboot}/coreboot_table.c (100%)
rename drivers/firmware/{google => coreboot}/coreboot_table.h (100%)
rename drivers/firmware/{google => coreboot}/framebuffer-coreboot.c (100%)
rename drivers/firmware/{google => coreboot}/gsmi.c (100%)
rename drivers/firmware/{google => coreboot}/memconsole-coreboot.c (100%)
rename drivers/firmware/{google => coreboot}/memconsole-x86-legacy.c (100%)
rename drivers/firmware/{google => coreboot}/memconsole.c (100%)
rename drivers/firmware/{google => coreboot}/memconsole.h (82%)
rename drivers/firmware/{google => coreboot}/vpd.c (100%)
rename drivers/firmware/{google => coreboot}/vpd_decode.c (100%)
rename drivers/firmware/{google => coreboot}/vpd_decode.h (100%)
rename drivers/{platform/x86 => firmware}/firmware_attributes_class.c (94%)
delete mode 100644 drivers/firmware/google/Makefile
rename drivers/platform/x86/firmware_attributes_class.h => include/linux/firmware_attributes.h (60%)
next reply other threads:[~2026-08-17 21:54 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-08-17 21:54 Sean Rhodes [this message]
2026-08-17 21:54 ` [PATCH v13 RESEND 1/5] platform/x86: Sort firmware attributes class includes Sean Rhodes
2026-08-17 21:54 ` [PATCH v13 RESEND 2/5] firmware: Move firmware attributes class helper Sean Rhodes
2026-08-17 21:54 ` [PATCH v13 RESEND 3/5] firmware: Rename google firmware directory to coreboot Sean Rhodes
2026-08-17 21:54 ` [PATCH v13 RESEND 4/5] firmware: coreboot: Add CFR firmware attributes driver Sean Rhodes
2026-08-17 21:54 ` [PATCH v13 RESEND 5/5] arm64: defconfig: Update coreboot firmware symbols Sean Rhodes
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=cover.1787003659.git.sean@starlabs.systems \
--to=sean@starlabs.systems \
--cc=Dell.Client.Kernel@dell.com \
--cc=airlied@gmail.com \
--cc=andersson@kernel.org \
--cc=arnd@arndb.de \
--cc=bhelgaas@google.com \
--cc=briannorris@chromium.org \
--cc=chenhuacai@kernel.org \
--cc=chrome-platform@lists.linux.dev \
--cc=corentin.chary@gmail.com \
--cc=dakr@kernel.org \
--cc=denis.benato@linux.dev \
--cc=derekjohn.clark@gmail.com \
--cc=dmitry.baryshkov@oss.qualcomm.com \
--cc=dri-devel@lists.freedesktop.org \
--cc=ebiggers@kernel.org \
--cc=florian.fainelli@broadcom.com \
--cc=geert@linux-m68k.org \
--cc=hansg@kernel.org \
--cc=ilpo.jarvinen@linux.intel.com \
--cc=javierm@redhat.com \
--cc=jorge.lopez2@hp.com \
--cc=josh@joshuagrisham.com \
--cc=jwerner@chromium.org \
--cc=kees@kernel.org \
--cc=krzysztof.kozlowski@oss.qualcomm.com \
--cc=linux-kernel@vger.kernel.org \
--cc=luca.weiss@fairphone.com \
--cc=luke@ljones.dev \
--cc=maarten.lankhorst@linux.intel.com \
--cc=michal.simek@amd.com \
--cc=mpearson-lenovo@squebb.ca \
--cc=mripard@kernel.org \
--cc=mst@redhat.com \
--cc=o-takashi@sakamocchi.jp \
--cc=oliver@liuxiaozhen.dev \
--cc=platform-driver-x86@vger.kernel.org \
--cc=prasanth.ksr@dell.com \
--cc=simona@ffwll.ch \
--cc=sven@kernel.org \
--cc=titouan.ameline@gmail.com \
--cc=tzimmermann@suse.de \
--cc=tzungbi@kernel.org \
--cc=u.kleine-koenig@baylibre.com \
--cc=wenst@chromium.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox