From: John Garry <john.garry@huawei.com>
To: Christophe JAILLET <christophe.jaillet@wanadoo.fr>,
<jejb@linux.ibm.com>, <martin.petersen@oracle.com>
Cc: <linux-scsi@vger.kernel.org>, <linux-kernel@vger.kernel.org>,
<kernel-janitors@vger.kernel.org>
Subject: Re: [PATCH 1/3] scsi: hisi_sas: Use devm_bitmap_zalloc() when applicable
Date: Mon, 6 Dec 2021 13:22:13 +0000 [thread overview]
Message-ID: <d1837f2b-2a04-0231-4ccd-1d1118afa595@huawei.com> (raw)
In-Reply-To: <4afa3f71e66c941c660627c7f5b0223b51968ebb.1637961191.git.christophe.jaillet@wanadoo.fr>
On 26/11/2021 21:15, Christophe JAILLET wrote:
> 'hisi_hba->slot_index_tags' is a bitmap. So use 'devm_bitmap_zalloc()' to
> simplify code, improve the semantic and avoid some open-coded arithmetic
> in allocator arguments.
>
> Signed-off-by: Christophe JAILLET<christophe.jaillet@wanadoo.fr>
Acked-by: John Garry <john.garry@huawei.com>
> ---
> The use of 's' is questionable here. I've left it because it looks more
> consistent this way with the surrounding code.
>
> Can it be an issue to have the length of the allocated bitmap not being
> a multiple of sizeof(long)?
The driver does not rely on that (allocated bitmap being a multiple of
sizeof(long)), but the size is 4096 bits, which would be a multiple of
sizeof(long)
Thanks,
John
> I guess that there is some kind of 'rounding' done by the memory allocator
> to keep some alignment, so I think that the previous code is safe (but not
> logical).
> If this is not the case, there is a potential out of bound bug related to
> the bitmap API that expect to access only longs (which is not necessarily
> the case here).
next prev parent reply other threads:[~2021-12-06 13:22 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2021-11-26 21:15 [PATCH 1/3] scsi: hisi_sas: Use devm_bitmap_zalloc() when applicable Christophe JAILLET
2021-11-26 21:18 ` [PATCH 2/3] scsi: hisi_sas: Remove some useless code in 'hisi_sas_alloc()' Christophe JAILLET
2021-12-06 13:23 ` John Garry
2021-11-26 21:18 ` [PATCH 3/3] scsi: hisi_sas: Use non-atomic bitmap functions when possible Christophe JAILLET
2021-12-06 14:30 ` John Garry
2021-12-06 13:22 ` John Garry [this message]
2021-12-07 3:13 ` [PATCH 1/3] scsi: hisi_sas: Use devm_bitmap_zalloc() when applicable Martin K. Petersen
2021-12-14 4:40 ` Martin K. Petersen
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=d1837f2b-2a04-0231-4ccd-1d1118afa595@huawei.com \
--to=john.garry@huawei.com \
--cc=christophe.jaillet@wanadoo.fr \
--cc=jejb@linux.ibm.com \
--cc=kernel-janitors@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-scsi@vger.kernel.org \
--cc=martin.petersen@oracle.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox