From: John Youn <John.Youn@synopsys.com>
To: Bruno Herrera <bruherrera@gmail.com>, John Youn <John.Youn@synopsys.com>
Cc: "robh+dt@kernel.org" <robh+dt@kernel.org>,
"pawel.moll@arm.com" <pawel.moll@arm.com>,
"mark.rutland@arm.com" <mark.rutland@arm.com>,
"ijc+devicetree@hellion.org.uk" <ijc+devicetree@hellion.org.uk>,
"galak@codeaurora.org" <galak@codeaurora.org>,
"linux@armlinux.org.uk" <linux@armlinux.org.uk>,
"mcoquelin.stm32@gmail.com" <mcoquelin.stm32@gmail.com>,
"gregkh@linuxfoundation.org" <gregkh@linuxfoundation.org>,
"balbi@kernel.org" <balbi@kernel.org>,
"zhangfei.gao@linaro.org" <zhangfei.gao@linaro.org>,
"a.seppala@gmail.com" <a.seppala@gmail.com>,
"devicetree@vger.kernel.org" <devicetree@vger.kernel.org>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
"linux-arm-kernel@lists.infradead.org"
<linux-arm-kernel@lists.infradead.org>,
"linux-usb@vger.kernel.org" <linux-usb@vger.kernel.org>
Subject: Re: [PATCH 1/3] usb: dwc2: Add support for STM32F429/439/469 USB OTG in FS mode with internal PHY
Date: Wed, 29 Jun 2016 13:58:34 -0700 [thread overview]
Message-ID: <e7a712ee-c064-3393-c9ea-f80aeb3240cd@synopsys.com> (raw)
In-Reply-To: <CAF3+Tqe=6JxiZ=iefKw=2wD5RQt3d-Mb960H4zum1tFoR08Dhg@mail.gmail.com>
On 6/29/2016 12:47 PM, Bruno Herrera wrote:
> On Mon, Jun 27, 2016 at 7:51 PM, John Youn <John.Youn@synopsys.com> wrote:
>> On 6/21/2016 7:26 PM, Bruno Herrera wrote:
>>> Signed-off-by: Bruno Herrera <bruherrera@gmail.com>
>>
>> Please add a commit message describing the purpose of your changes,
>> some information about the platform you're adding, and the special
>> handling of the GGPIO.
>>
> Ok, no problem.
>
>>> ---
>>> drivers/usb/dwc2/core.c | 18 ++++++++++++++++++
>>> drivers/usb/dwc2/core.h | 5 +++++
>>> drivers/usb/dwc2/hcd.c | 12 +++++++++++-
>>> drivers/usb/dwc2/hw.h | 2 ++
>>> drivers/usb/dwc2/platform.c | 37 +++++++++++++++++++++++++++++++++++++
>>> 5 files changed, 73 insertions(+), 1 deletion(-)
>>>
>>> diff --git a/drivers/usb/dwc2/core.c b/drivers/usb/dwc2/core.c
>>> index 4135a5f..83fbed6 100644
>>> --- a/drivers/usb/dwc2/core.c
>>> +++ b/drivers/usb/dwc2/core.c
>>> @@ -1276,6 +1276,23 @@ static void dwc2_set_param_hibernation(struct dwc2_hsotg *hsotg,
>>> hsotg->core_params->hibernation = val;
>>> }
>>>
>>> +static void dwc2_set_param_stm32_powerdown(struct dwc2_hsotg *hsotg,
>>> + int val)
>>> +{
>>> + if (DWC2_OUT_OF_BOUNDS(val, 0, 1)) {
>>> + if (val >= 0) {
>>> + dev_err(hsotg->dev,
>>> + "'%d' invalid for parameter power down\n",
>>> + val);
>>> + dev_err(hsotg->dev, "power down must be 0 or 1\n");
>>> + }
>>> + val = 0;
>>> + dev_dbg(hsotg->dev, "Setting power down to %d\n", val);
>>> + }
>>> +
>>> + hsotg->core_params->stm32_powerdown = val;
>>> +}
>>> +
>>> /*
>>> * This function is called during module intialization to pass module parameters
>>> * for the DWC_otg core.
>>> @@ -1323,6 +1340,7 @@ void dwc2_set_parameters(struct dwc2_hsotg *hsotg,
>>> dwc2_set_param_uframe_sched(hsotg, params->uframe_sched);
>>> dwc2_set_param_external_id_pin_ctl(hsotg, params->external_id_pin_ctl);
>>> dwc2_set_param_hibernation(hsotg, params->hibernation);
>>> + dwc2_set_param_stm32_powerdown(hsotg, params->stm32_powerdown);
>>> }
>>>
>>> /*
>>> diff --git a/drivers/usb/dwc2/core.h b/drivers/usb/dwc2/core.h
>>> index 3c58d63..d3e4fcb 100644
>>> --- a/drivers/usb/dwc2/core.h
>>> +++ b/drivers/usb/dwc2/core.h
>>> @@ -386,6 +386,10 @@ enum dwc2_ep0_state {
>>> * needed.
>>> * 0 - No (default)
>>> * 1 - Yes
>>> + * @stm32_powerdown: Enable STM32 specific USB FS transceiver power down
>>> + * control.
>>> + * 0 = USB FS transceiver disabled (default)
>>> + * 1 = USB FS transceiver enabled
>>> *
>>> * The following parameters may be specified when starting the module. These
>>> * parameters define how the DWC_otg controller should be configured. A
>>> @@ -426,6 +430,7 @@ struct dwc2_core_params {
>>> int uframe_sched;
>>> int external_id_pin_ctl;
>>> int hibernation;
>>> + int stm32_powerdown;
>>> };
>>>
>>> /**
>>> diff --git a/drivers/usb/dwc2/hcd.c b/drivers/usb/dwc2/hcd.c
>>> index 2df3d04..4f9bb93 100644
>>> --- a/drivers/usb/dwc2/hcd.c
>>> +++ b/drivers/usb/dwc2/hcd.c
>>> @@ -118,7 +118,7 @@ static void dwc2_init_fs_ls_pclk_sel(struct dwc2_hsotg *hsotg)
>>>
>>> static int dwc2_fs_phy_init(struct dwc2_hsotg *hsotg, bool select_phy)
>>> {
>>> - u32 usbcfg, i2cctl;
>>> + u32 usbcfg, usbgpio, i2cctl;
>>
>> The convention in this driver would be to just call 'usbgpio' -> 'ggpio'
>
> OK.
>>
>>> int retval = 0;
>>>
>>> /*
>>> @@ -142,6 +142,16 @@ static int dwc2_fs_phy_init(struct dwc2_hsotg *hsotg, bool select_phy)
>>> return retval;
>>> }
>>> }
>>> +
>>> + if (hsotg->core_params->stm32_powerdown > 0) {
>>> + dev_dbg(hsotg->dev, "STM32 FS PHY enabling transceiver\n");
>>> + /* STM32 uses the GGPIO register as general core
>>> + * configuration register.
>>> + */
>>> + usbgpio = dwc2_readl(hsotg->regs + GGPIO);
>>> + usbgpio |= STM32_OTG_GCCFG_PWRDWN;
>>> + dwc2_writel(usbgpio, hsotg->regs + GGPIO);
>>> + }
>>> }
>>>
>>> /*
>>> diff --git a/drivers/usb/dwc2/hw.h b/drivers/usb/dwc2/hw.h
>>> index 281b57b..d5f9294 100644
>>> --- a/drivers/usb/dwc2/hw.h
>>> +++ b/drivers/usb/dwc2/hw.h
>>> @@ -224,6 +224,8 @@
>>>
>>> #define GPVNDCTL HSOTG_REG(0x0034)
>>> #define GGPIO HSOTG_REG(0x0038)
>>> +#define STM32_OTG_GCCFG_PWRDWN (1 << 16)
>>> +
>>
>> Also, bitfields for GGPIO should be named: GGPIO_xxx
>
> Could it be -> GGPIO_STM32_OTG_GCCFG_PWRDWN
> From my understand the GGPIO are platform/vendor dependent so in the
> future some other vendor could use the same bit for other purpose.
> Should we keep it defined here or only in the scope it is used?
Here is fine. We already have overlapping bitfield definitions for
some registers due to differences in host or device mode.
Regards,
John
prev parent reply other threads:[~2016-06-29 20:58 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-06-22 2:25 [PATCH 1/3] usb: dwc2: Add support for STM32F429/439/469 USB OTG in FS mode with internal PHY Bruno Herrera
2016-06-22 2:25 ` [PATCH 2/3] ARM: dts: STM32 Add USB FS host mode support Bruno Herrera
2016-06-22 2:25 ` [PATCH 3/3] dt-bindings: Document the STM32 USB OTG DWC2 core binding Bruno Herrera
2016-06-24 15:41 ` Rob Herring
2016-06-24 18:51 ` Bruno Herrera
2016-06-28 20:54 ` Rob Herring
2016-06-29 18:56 ` Bruno Herrera
2016-06-30 13:54 ` Rob Herring
2016-06-27 22:51 ` [PATCH 1/3] usb: dwc2: Add support for STM32F429/439/469 USB OTG in FS mode with internal PHY John Youn
2016-06-29 19:46 ` Bruno Herrera
2016-06-29 20:58 ` John Youn [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=e7a712ee-c064-3393-c9ea-f80aeb3240cd@synopsys.com \
--to=john.youn@synopsys.com \
--cc=a.seppala@gmail.com \
--cc=balbi@kernel.org \
--cc=bruherrera@gmail.com \
--cc=devicetree@vger.kernel.org \
--cc=galak@codeaurora.org \
--cc=gregkh@linuxfoundation.org \
--cc=ijc+devicetree@hellion.org.uk \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-usb@vger.kernel.org \
--cc=linux@armlinux.org.uk \
--cc=mark.rutland@arm.com \
--cc=mcoquelin.stm32@gmail.com \
--cc=pawel.moll@arm.com \
--cc=robh+dt@kernel.org \
--cc=zhangfei.gao@linaro.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox