From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by smtp.lore.kernel.org (Postfix) with ESMTP id C79D5E7D0AA for ; Thu, 21 Sep 2023 20:56:39 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S232076AbjIUU4n (ORCPT ); Thu, 21 Sep 2023 16:56:43 -0400 Received: from lindbergh.monkeyblade.net ([23.128.96.19]:53932 "EHLO lindbergh.monkeyblade.net" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S232269AbjIUUex (ORCPT ); Thu, 21 Sep 2023 16:34:53 -0400 Received: from smtp.kernel.org (relay.kernel.org [52.25.139.140]) by lindbergh.monkeyblade.net (Postfix) with ESMTPS id 5349C86112 for ; Thu, 21 Sep 2023 10:37:55 -0700 (PDT) Received: by smtp.kernel.org (Postfix) with ESMTPSA id 4B855C4E681; Thu, 21 Sep 2023 14:19:47 +0000 (UTC) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=kernel.org; s=k20201202; t=1695305987; bh=3omRRAuhKLx3rUlF+M0I38XRTMiyOqLO113BPuaeJPE=; h=Date:From:To:Subject:In-Reply-To:References:Cc:From; b=NarvtlMJI4dC25o33cGWYbiFUCmh6m5wCn6RhAcs1t4sHSKg+gQYLRIib4349DV56 T2KFKBerigcI6jOyzdS970PrTgy6l9Z79H6RKet7hOkbTP5TK5bHV7hDQGBvpazmC0 R+8fGTRFcN44d/smo48T/hkRZ8DM+sjKzqBvwHkoMhicoF5YqATOc2rTwuC4kvFdKc r6bSlPfgbasVYD291yp21mtRIqmcjbDfICi+Iq+0Mv8SWie85dFlmKpAegqkbkgCk8 36N4vbfs4TNFq5wpPiygyjqQM7WizXDFgr7tGoyHqiVnWqBBUYwuOwQkdP+Fzuqa/9 bxEFLDCo148HA== Message-ID: Date: Thu, 21 Sep 2023 14:19:44 +0000 From: "Maxime Ripard" To: "Javier Martinez Canillas" Subject: Re: [PATCH] drm/ssd130x: Drop _helper prefix from struct drm_*_helper_funcs callbacks In-Reply-To: <20230914195138.1518065-1-javierm@redhat.com> References: <20230914195138.1518065-1-javierm@redhat.com> Cc: dri-devel@lists.freedesktop.org, linux-kernel@vger.kernel.org, "Daniel Vetter" , "David Airlie" , "Geert Uytterhoeven" , "Maxime Ripard" Content-Transfer-Encoding: quoted-printable Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Thu, 14 Sep 2023 21:51:24 +0200, Javier Martinez Canillas wrote: > The driver uses a naming convention where functions for struct drm_*_funcs > callbacks are named ssd130x_$object_$operation, while the callbacks for > struct drm_*_helper_funcs are named ssd130x_$object_helper_$operation. >=20 > The idea is that this helper_ prefix in the function names denote that are >=20 > [ ... ] Reviewed-by: Maxime Ripard Thanks! Maxime