From mboxrd@z Thu Jan 1 00:00:00 1970 From: akpm@linux-foundation.org Subject: [merged] kthread-rename-probe_kthread_data-to-kthread_probe_data.patch removed from -mm tree Date: Wed, 12 Oct 2016 12:26:00 -0700 Message-ID: <57fe8e48.hddIL7j38uiKBZCj%akpm@linux-foundation.org> Reply-To: linux-kernel@vger.kernel.org Mime-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Transfer-Encoding: 7bit Return-path: Received: from mail.linuxfoundation.org ([140.211.169.12]:33498 "EHLO mail.linuxfoundation.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S932347AbcJLT0B (ORCPT ); Wed, 12 Oct 2016 15:26:01 -0400 Sender: mm-commits-owner@vger.kernel.org List-Id: mm-commits@vger.kernel.org To: pmladek@suse.com, akpm@linux-foundation.org, bp@suse.de, jkosina@suse.cz, josh@joshtriplett.org, mhocko@suse.cz, mingo@redhat.com, oleg@redhat.com, paulmck@linux.vnet.ibm.com, peterz@infradead.org, rostedt@goodmis.org, tglx@linutronix.de, tj@kernel.org, vbabka@suse.cz, mm-commits@vger.kernel.org The patch titled Subject: kthread: rename probe_kthread_data() to kthread_probe_data() has been removed from the -mm tree. Its filename was kthread-rename-probe_kthread_data-to-kthread_probe_data.patch This patch was dropped because it was merged into mainline or a subsystem tree ------------------------------------------------------ From: Petr Mladek Subject: kthread: rename probe_kthread_data() to kthread_probe_data() Patch series "kthread: Kthread worker API improvements" The intention of this patchset is to make it easier to manipulate and maintain kthreads. Especially, I want to replace all the custom main cycles with a generic one. Also I want to make the kthreads sleep in a consistent state in a common place when there is no work. This patch (of 11): A good practice is to prefix the names of functions by the name of the subsystem. This patch fixes the name of probe_kthread_data(). The other wrong functions names are part of the kthread worker API and will be fixed separately. Link: http://lkml.kernel.org/r/1470754545-17632-2-git-send-email-pmladek@suse.com Signed-off-by: Petr Mladek Suggested-by: Andrew Morton Acked-by: Tejun Heo Cc: Oleg Nesterov Cc: Ingo Molnar Cc: Peter Zijlstra Cc: Steven Rostedt Cc: "Paul E. McKenney" Cc: Josh Triplett Cc: Thomas Gleixner Cc: Jiri Kosina Cc: Borislav Petkov Cc: Michal Hocko Cc: Vlastimil Babka Signed-off-by: Andrew Morton --- include/linux/kthread.h | 2 +- kernel/kthread.c | 4 ++-- kernel/workqueue.c | 2 +- 3 files changed, 4 insertions(+), 4 deletions(-) diff -puN include/linux/kthread.h~kthread-rename-probe_kthread_data-to-kthread_probe_data include/linux/kthread.h --- a/include/linux/kthread.h~kthread-rename-probe_kthread_data-to-kthread_probe_data +++ a/include/linux/kthread.h @@ -44,7 +44,7 @@ bool kthread_should_stop(void); bool kthread_should_park(void); bool kthread_freezable_should_stop(bool *was_frozen); void *kthread_data(struct task_struct *k); -void *probe_kthread_data(struct task_struct *k); +void *kthread_probe_data(struct task_struct *k); int kthread_park(struct task_struct *k); void kthread_unpark(struct task_struct *k); void kthread_parkme(void); diff -puN kernel/kthread.c~kthread-rename-probe_kthread_data-to-kthread_probe_data kernel/kthread.c --- a/kernel/kthread.c~kthread-rename-probe_kthread_data-to-kthread_probe_data +++ a/kernel/kthread.c @@ -138,7 +138,7 @@ void *kthread_data(struct task_struct *t } /** - * probe_kthread_data - speculative version of kthread_data() + * kthread_probe_data - speculative version of kthread_data() * @task: possible kthread task in question * * @task could be a kthread task. Return the data value specified when it @@ -146,7 +146,7 @@ void *kthread_data(struct task_struct *t * inaccessible for any reason, %NULL is returned. This function requires * that @task itself is safe to dereference. */ -void *probe_kthread_data(struct task_struct *task) +void *kthread_probe_data(struct task_struct *task) { struct kthread *kthread = to_kthread(task); void *data = NULL; diff -puN kernel/workqueue.c~kthread-rename-probe_kthread_data-to-kthread_probe_data kernel/workqueue.c --- a/kernel/workqueue.c~kthread-rename-probe_kthread_data-to-kthread_probe_data +++ a/kernel/workqueue.c @@ -4261,7 +4261,7 @@ void print_worker_info(const char *log_l * This function is called without any synchronization and @task * could be in any state. Be careful with dereferences. */ - worker = probe_kthread_data(task); + worker = kthread_probe_data(task); /* * Carefully copy the associated workqueue's workfn and name. Keep _ Patches currently in -mm which might be from pmladek@suse.com are