From: Mat Martineau <martineau@kernel.org>
To: Geliang Tang <geliang@kernel.org>
Cc: mptcp@lists.linux.dev, baohua@kernel.org,
Geliang Tang <tanggeliang@kylinos.cn>
Subject: Re: [PATCH mptcp-next 2/8] Squash to "selftests/bpf: Add bpf_first scheduler & test"
Date: Fri, 20 Dec 2024 17:28:43 -0800 (PST) [thread overview]
Message-ID: <b5ca9ddf-77a9-dd73-e485-71ec6f354054@kernel.org> (raw)
In-Reply-To: <e57ac76105430bab4bbc5ac4f62c77e883dd7f29.1732153672.git.tanggeliang@kylinos.cn>
On Thu, 21 Nov 2024, Geliang Tang wrote:
> From: Geliang Tang <tanggeliang@kylinos.cn>
>
> Split get_subflow() interface into two: get_send() and get_retrans().
>
> Signed-off-by: Geliang Tang <tanggeliang@kylinos.cn>
> ---
> .../selftests/bpf/progs/mptcp_bpf_first.c | 24 +++++++++++++++----
> 1 file changed, 19 insertions(+), 5 deletions(-)
>
> diff --git a/tools/testing/selftests/bpf/progs/mptcp_bpf_first.c b/tools/testing/selftests/bpf/progs/mptcp_bpf_first.c
> index d57399b407a7..36bf9adffb2c 100644
> --- a/tools/testing/selftests/bpf/progs/mptcp_bpf_first.c
> +++ b/tools/testing/selftests/bpf/progs/mptcp_bpf_first.c
> @@ -16,18 +16,32 @@ void BPF_PROG(mptcp_sched_first_release, struct mptcp_sock *msk)
> {
> }
>
> -SEC("struct_ops")
> -int BPF_PROG(bpf_first_get_subflow, struct mptcp_sock *msk,
> - struct mptcp_sched_data *data)
> +static int bpf_first_get_subflow(struct mptcp_sock *msk,
> + struct mptcp_sched_data *data)
> {
> mptcp_subflow_set_scheduled(bpf_mptcp_subflow_ctx_by_pos(data, 0), true);
> return 0;
> }
>
> -SEC(".struct_ops")
> +SEC("struct_ops")
> +int BPF_PROG(bpf_first_get_send, struct mptcp_sock *msk,
> + struct mptcp_sched_data *data)
> +{
> + return bpf_first_get_subflow(msk, data);
> +}
> +
> +SEC("struct_ops")
> +int BPF_PROG(bpf_first_get_retrans, struct mptcp_sock *msk,
> + struct mptcp_sched_data *data)
> +{
> + return bpf_first_get_subflow(msk, data);
> +}
Hi Geliang -
If my suggestion in patch 1 (use get_send for retransmit scheduling if
get_retrans is NULL) doesn't seem like clear enough behavior for BPF
scheduler authors, this code and the following patches could be simplified
by removing the duplicate _retrans function above...
> +
> +SEC(".struct_ops.link")
> struct mptcp_sched_ops first = {
> .init = (void *)mptcp_sched_first_init,
> .release = (void *)mptcp_sched_first_release,
> - .get_subflow = (void *)bpf_first_get_subflow,
> + .get_send = (void *)bpf_first_get_send,
> + .get_retrans = (void *)bpf_first_get_retrans,
... and setting get_retrans like this:
.get_retrans = (void *)bpf_first_get_send,
Then there would be example code for BPF scheduler programmers to see that
it's ok to use the same function pointer in both fields.
- Mat
> .name = "bpf_first",
> };
> --
> 2.43.0
>
>
>
next prev parent reply other threads:[~2024-12-21 1:28 UTC|newest]
Thread overview: 13+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-11-21 2:45 [PATCH mptcp-next 0/8] split get_subflow interface into two Geliang Tang
2024-11-21 2:45 ` [PATCH mptcp-next 1/8] mptcp: " Geliang Tang
2024-12-21 1:23 ` Mat Martineau
2024-11-21 2:45 ` [PATCH mptcp-next 2/8] Squash to "selftests/bpf: Add bpf_first scheduler & test" Geliang Tang
2024-12-21 1:28 ` Mat Martineau [this message]
2024-12-23 9:49 ` Geliang Tang
2024-11-21 2:45 ` [PATCH mptcp-next 3/8] Squash to "selftests/bpf: Add bpf_bkup " Geliang Tang
2024-11-21 2:45 ` [PATCH mptcp-next 4/8] Squash to "selftests/bpf: Add bpf_rr " Geliang Tang
2024-11-21 2:45 ` [PATCH mptcp-next 5/8] Squash to "selftests/bpf: Add bpf_red " Geliang Tang
2024-11-21 2:45 ` [PATCH mptcp-next 6/8] Squash to "selftests/bpf: Add bpf_burst " Geliang Tang
2024-11-21 2:45 ` [PATCH mptcp-next 7/8] Squash to "bpf: Export mptcp packet scheduler helpers" Geliang Tang
2024-11-21 2:45 ` [PATCH mptcp-next 8/8] Squash to "selftests/bpf: Add bpf_burst scheduler & test" Geliang Tang
2024-11-21 3:55 ` [PATCH mptcp-next 0/8] split get_subflow interface into two MPTCP CI
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=b5ca9ddf-77a9-dd73-e485-71ec6f354054@kernel.org \
--to=martineau@kernel.org \
--cc=baohua@kernel.org \
--cc=geliang@kernel.org \
--cc=mptcp@lists.linux.dev \
--cc=tanggeliang@kylinos.cn \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox