MPTCP Linux Development
 help / color / mirror / Atom feed
From: Mat Martineau <mathew.j.martineau@linux.intel.com>
To: menglong8.dong@gmail.com
Cc: mptcp@lists.linux.dev, Menglong Dong <imagedong@tencent.com>
Subject: Re: [PATCH mptcp-next v4 0/3] mptcp: add statistics for mptcp socket in use
Date: Thu, 6 Oct 2022 14:54:00 -0700 (PDT)	[thread overview]
Message-ID: <b60b3786-482e-d308-12fa-4f3605301d46@linux.intel.com> (raw)
In-Reply-To: <20221006061123.1474224-1-imagedong@tencent.com>

On Thu, 6 Oct 2022, menglong8.dong@gmail.com wrote:

> From: Menglong Dong <imagedong@tencent.com>
>
> In the 1th patch, we do some code cleanup with replease 'sock->sk'
> with 'sk'. In the 2th patch, we add statistics for mptcp socket in
> use. And in the 3th patch, we add the testing for this commit.
>

Hi Menglong -

Thanks for the post. While your patches did apply cleanly to the export 
branch when you sent them, there's now a significant merge conflict 
because of this patch (applied today) that refactors 
mptcp_stream_connect():

https://lore.kernel.org/mptcp/c74935435f59a6120f62c56bd5e1519c30d269bf.1664915909.git.pabeni@redhat.com/

Sorry about that timing! Can you rebase and re-post?


- Mat


> Changes since v3:
> - rename MPTCP_DESTROIED to MPTCP_DESTROYED in the 2th patch
>
> Changes since v2:
> - add testing
>
> Changes since v1:
> - split the code cleanup into the 1th patch.
> - decrease the statistics for listening mptcp socket inuse with
>  mptcp_listen_inuse_dec()
> - add MPTCP_DESTROIED flags to store if mptcp_destroy_common() was
>  called on the msk. For fallback case, we need to decrease the
>  statistics only once, and mptcp_destroy_common() can be called
>  more than once.
>
> Menglong Dong (3):
>  mptcp: introduce 'sk' to replace 'sock->sk' in mptcp_listen()
>  mptcp: add statistics for mptcp socket in use
>  selftest: mptcp: add test for mptcp socket in use
>
> net/mptcp/protocol.c                      | 35 ++++++++++++++++++-----
> net/mptcp/protocol.h                      |  1 +
> net/mptcp/subflow.c                       |  3 ++
> tools/testing/selftests/net/mptcp/diag.sh | 28 ++++++++++++++++++
> 4 files changed, 60 insertions(+), 7 deletions(-)
>
> -- 
> 2.37.2
>
>

--
Mat Martineau
Intel

  parent reply	other threads:[~2022-10-06 21:54 UTC|newest]

Thread overview: 7+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-10-06  6:11 [PATCH mptcp-next v4 0/3] mptcp: add statistics for mptcp socket in use menglong8.dong
2022-10-06  6:11 ` [PATCH mptcp-next v4 1/3] mptcp: introduce 'sk' to replace 'sock->sk' in mptcp_listen() menglong8.dong
2022-10-06  6:11 ` [PATCH mptcp-next v4 2/3] mptcp: add statistics for mptcp socket in use menglong8.dong
2022-10-06  6:11 ` [PATCH mptcp-next v4 3/3] selftest: mptcp: add test " menglong8.dong
2022-10-06 13:59   ` selftest: mptcp: add test for mptcp socket in use: Tests Results MPTCP CI
2022-10-06 21:54 ` Mat Martineau [this message]
2022-10-07  9:30   ` [PATCH mptcp-next v4 0/3] mptcp: add statistics for mptcp socket in use Menglong Dong

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=b60b3786-482e-d308-12fa-4f3605301d46@linux.intel.com \
    --to=mathew.j.martineau@linux.intel.com \
    --cc=imagedong@tencent.com \
    --cc=menglong8.dong@gmail.com \
    --cc=mptcp@lists.linux.dev \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox