MPTCP Linux Development
 help / color / mirror / Atom feed
From: Gang Yan <yangang@kylinos.cn>
To: mptcp@lists.linux.dev
Cc: Gang Yan <yangang@kylinos.cn>
Subject: [PATCH mptcp-next v3 0/5] Add 'dump_subflow' test in selftests
Date: Fri, 25 Apr 2025 14:18:38 +0800	[thread overview]
Message-ID: <cover.1745395366.git.yangang@kylinos.cn> (raw)

The 'subflow_get_info_size' is called only in 'inet_sk_attr_size', and
the only calltrace is that 'tcp_diag_dump_one'->'inet_diag_dump_one_icsk'
->'inet_sk_attr_size'.

So It's necessary to add 'get_subflow_info' in mptcp_diag.c to cover this
function. Given a specific TCP connection, it is possible to judge if
it is a MPTCP subflow by 'INET_ULP_INFO_MPTCP' and print 'subflow_info'.

Closes: https://github.com/multipath-tcp/mptcp_net-next/issues/524

------
Changelog
  v2:
    - Fix the CI compiling error.
  v3:
    - Set idaig_ext when 'r' is declared.
    - Declare iovlen to 0, and adjust the increment logic.
    - Squash patch 3 into patch 4.
    - Rename 'subflow_addr' to 'subflow_addrs'
    - Remove the comment and declare [ad]ddr on the same line.
    - Set id.idiag_cookie[0/1] when r is declared.
    - Remove the 'id.idiag_if = 0' because the default value is 0.
    - Squash patch 6 into patch 5.
    - Add the example of output in commit message.
    - Adjust the input of 'mptcp_diag -s' to "saddr:sport daddr:dport"
      to save a few lines in diag.sh
    - In diag.sh, use "mptcp_diag -s '$subflow_line'" instead of
      the old version, and call 'ss' only once to ensure the safety.
    - Fix some error/check/warning problems in CI.
    - Put the link of issue into the commit message of patch 5.

Gang Yan (5):
  selftests: mptcp: add struct params in mptcp_diag
  selftests: mptcp: refactor send_query parameters for code clarity
  selftests: mptcp: refactor NLMSG handling with 'proto'
  selftests: mptcp: add helpers to get subflow_info
  selftests: mptcp: add chk_sublfow in diag.sh

 tools/testing/selftests/net/mptcp/diag.sh     |  33 +++
 .../testing/selftests/net/mptcp/mptcp_diag.c  | 228 +++++++++++++++---
 2 files changed, 229 insertions(+), 32 deletions(-)

-- 
2.43.0


             reply	other threads:[~2025-04-25  6:18 UTC|newest]

Thread overview: 12+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-04-25  6:18 Gang Yan [this message]
2025-04-25  6:18 ` [PATCH mptcp-next v3 1/5] selftests: mptcp: add struct params in mptcp_diag Gang Yan
2025-04-25  6:18 ` [PATCH mptcp-next v3 2/5] selftests: mptcp: refactor send_query parameters for code clarity Gang Yan
2025-04-29 13:00   ` Matthieu Baerts
2025-04-25  6:18 ` [PATCH mptcp-next v3 3/5] selftests: mptcp: refactor NLMSG handling with 'proto' Gang Yan
2025-04-25  6:18 ` [PATCH mptcp-next v3 4/5] selftests: mptcp: add helpers to get subflow_info Gang Yan
2025-04-29 13:05   ` Matthieu Baerts
2025-04-25  6:18 ` [PATCH mptcp-next v3 5/5] selftests: mptcp: add chk_sublfow in diag.sh Gang Yan
2025-04-29 13:05   ` Matthieu Baerts
2025-04-25 12:55 ` [PATCH mptcp-next v3 0/5] Add 'dump_subflow' test in selftests MPTCP CI
2025-04-29 13:00 ` Matthieu Baerts
2025-04-29 13:22   ` Matthieu Baerts

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=cover.1745395366.git.yangang@kylinos.cn \
    --to=yangang@kylinos.cn \
    --cc=mptcp@lists.linux.dev \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox