From: Matthieu Baerts <matttbe@kernel.org>
To: Mat Martineau <martineau@kernel.org>
Cc: MPTCP Upstream <mptcp@lists.linux.dev>, Paolo Abeni <pabeni@redhat.com>
Subject: Patches for netdev (for 6.7)
Date: Mon, 23 Oct 2023 02:12:12 +0200 [thread overview]
Message-ID: <ee535704-52c3-48a5-9893-c195f7975e64@kernel.org> (raw)
Hi Mat,
Regarding the patches we might want to send to netdev this week, I think
all the ones for -net and net-next can go.
- Fixes for -net:
- selftests: mptcp: run userspace pm tests slower (Geliang Tang)
- selftests: mptcp: fix wait_rm_addr/sf parameters (Geliang Tang)
- mptcp: userspace pm send RM_ADDR for ID 0 (Geliang Tang)
- Features for net-next:
- mptcp: add a new sysctl for make after break timeout (Paolo Abeni)
- tools: ynl: add uns-admin-perm to genetlink legacy (Davide Caratti)
- tools: ynl-gen: add support for exact-len validation (Davide Caratti)
- net: mptcp: convert netlink from small_ops to ops (Davide Caratti)
- Documentation: netlink: add a YAML spec for mptcp (Davide Caratti)
- uapi: mptcp: use header file generated from YAML spec (Davide Caratti)
- net: mptcp: rename netlink handlers to
mptcp_pm_nl_<blah>_{doit,dumpit} (Davide Caratti)
- net: mptcp: use policy generated by YAML spec (Davide Caratti)
- mptcp: properly account fastopen data (Paolo Abeni)
- mptcp: use plain bool instead of custom binary enum (Paolo Abeni)
- tcp: define initial scaling factor value as a macro (Paolo Abeni)
- mptcp: give rcvlowat some love (Paolo Abeni)
- mptcp: use copy_from_iter helpers on transmit (Paolo Abeni)
- mptcp: consolidate sockopt synchronization (Paolo Abeni)
- mptcp: ignore notsent_lowat setting at the subflow level (Paolo Abeni)
- mptcp: refactor sndbuf auto-tuning (Paolo Abeni)
- mptcp: drop useless ssk in pm_subflow_check_next (Geliang Tang)
- mptcp: use mptcp_check_fallback helper (Geliang Tang)
- mptcp: use mptcp_get_ext helper (Geliang Tang)
- mptcp: move sk assignment statement ahead (Geliang Tang)
- mptcp: define more local variables sk (Geliang Tang)
- selftests: mptcp: sockopt: drop mptcp_connect var (Geliang Tang)
- selftests: mptcp: display simult in extra_msg (Geliang Tang)
- mptcp: add mptcpi_subflows_total counter (Geliang Tang)
- selftests: mptcp: add evts_get_info helper (Geliang Tang)
- selftests: mptcp: add chk_subflows_total helper (Geliang Tang)
- selftests: mptcp: update userspace pm test helpers (Geliang Tang)
- selftests: mptcp: userspace pm create id 0 subflow (Geliang Tang)
- mptcp: userspace pm rename remove_err to out (Geliang Tang)
- selftests: mptcp: userspace pm remove initial subflow (Geliang Tang)
- selftests: mptcp: userspace pm send RM_ADDR for ID 0 (Geliang Tang)
- selftests: mptcp: add mptcp_lib_kill_wait (Geliang Tang)
- selftests: mptcp: add mptcp_lib_is_v6 (Geliang Tang)
- selftests: mptcp: add mptcp_lib_get_counter (Geliang Tang)
- selftests: mptcp: add missing oflag=append (Geliang Tang)
- selftests: mptcp: add mptcp_lib_make_file (Geliang Tang)
- selftests: mptcp: add mptcp_lib_check_transfer (Geliang Tang)
- selftests: mptcp: add mptcp_lib_wait_local_port_listen (Geliang Tang)
Just a few notes:
In -net, 2 patches introduce conflicts with what is queued for net-next:
- "selftests: mptcp: fix wait_rm_addr/sf parameters" conflicts with:
- "selftests: mptcp: update userspace pm test helper"
→ the patch fixes the same issue but in different functions
- "mptcp: userspace pm send RM_ADDR for ID 0" conflicts with:
- "net: mptcp: rename netlink handlers to
mptcp_pm_nl_<blah>_{doit,dumpit}"
→ the conflict is easy to fix: we want to put a function before one
that is being renamed
- "mptcp: define more local variables sk"
→ also easy to fix: one line in the context that has changed
Because these fixes don't seem critical and because we are getting
closer to have a new release, I think it might be better to send these 3
fixes with the new feature (but keep them at the beginning of the
series). I guess if a note is added in the cover-letter message
explaining it is easier like that, and it is fine to delay the fixes, it
should be OK. WDYT?
Also, about the MPTCP NL YAML specs series where a v2 was needed: it
looks OK to me, but I don't know if Paolo wants to double-check the last
modifications from Davide before sending them. There is a conflict with
one patch from this series and one for -net (see above). I think it
might be better to send this YAML specs series first, then the other
patches.
I think Paolo's patches for net-next can be sent in parallel to Davide's
patches.
Do you think you can send all these patches, please? :)
Cheers,
Matt
next reply other threads:[~2023-10-23 0:12 UTC|newest]
Thread overview: 2+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-10-23 0:12 Matthieu Baerts [this message]
2023-10-23 16:44 ` Patches for netdev (for 6.7) Mat Martineau
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=ee535704-52c3-48a5-9893-c195f7975e64@kernel.org \
--to=matttbe@kernel.org \
--cc=martineau@kernel.org \
--cc=mptcp@lists.linux.dev \
--cc=pabeni@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox