From mboxrd@z Thu Jan 1 00:00:00 1970 From: Heiner Kallweit Subject: [PATCH net-next 0/2] PCI: add two more values for PCIe Max_Read_Request_Size and initially use them in r8169 network driver Date: Mon, 16 Apr 2018 21:35:42 +0200 Message-ID: <00f1255f-acf0-4760-c20f-0b78bda44645@gmail.com> Mime-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Transfer-Encoding: 7bit Cc: "linux-pci@vger.kernel.org" , "netdev@vger.kernel.org" To: Bjorn Helgaas , David Miller , Bjorn Helgaas , Realtek linux nic maintainers Return-path: Received: from mail-wr0-f193.google.com ([209.85.128.193]:41981 "EHLO mail-wr0-f193.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1753543AbeDPTfw (ORCPT ); Mon, 16 Apr 2018 15:35:52 -0400 Sender: netdev-owner@vger.kernel.org List-ID: In r8169 network driver I stumbled across a magic number translating to PCI MRRS size 4K. The PCI core is still missing constants for values 2K and 4K (as defined in PCI standard). So let's add these two constants and use the 4K constant in r8169. Second patch depends on the first one, therefore both patches preferrably should go through either PCI or netdev tree. Heiner Kallweit (2): PCI: add two more values for PCIe Max_Read_Request_Size r8169: replace magic numbers with PCI MRRS constant drivers/net/ethernet/realtek/r8169.c | 39 ++++++++++++++-------------- include/uapi/linux/pci_regs.h | 2 ++ 2 files changed, 21 insertions(+), 20 deletions(-) -- 2.17.0