From mboxrd@z Thu Jan 1 00:00:00 1970 From: Davide Caratti Subject: Re: [PATCH v2 net-next 0/6] net sched actions: code style cleanup and fixes Date: Thu, 28 Jun 2018 14:26:38 +0200 Message-ID: <0bc7c30bc912bfa28da4af6c2c5525cb8c5acf8f.camel@redhat.com> References: <1530120815-13736-1-git-send-email-mrv@mojatatu.com> Mime-Version: 1.0 Content-Type: text/plain; charset="UTF-8" Content-Transfer-Encoding: 7bit Cc: netdev@vger.kernel.org, kernel@mojatatu.com, jhs@mojatatu.com, xiyou.wangcong@gmail.com, jiri@resnulli.us To: Roman Mashak , davem@davemloft.net Return-path: Received: from mx3-rdu2.redhat.com ([66.187.233.73]:57918 "EHLO mx1.redhat.com" rhost-flags-OK-OK-OK-FAIL) by vger.kernel.org with ESMTP id S932640AbeF1M0n (ORCPT ); Thu, 28 Jun 2018 08:26:43 -0400 In-Reply-To: <1530120815-13736-1-git-send-email-mrv@mojatatu.com> Sender: netdev-owner@vger.kernel.org List-ID: On Wed, 2018-06-27 at 13:33 -0400, Roman Mashak wrote: > The patchset fixes a few code stylistic issues and typos, as well as one > detected by sparse semantic checker tool. > > No functional changes introduced. > > Patch 1 & 2 fix coding style bits caught by the checkpatch.pl script > Patch 3 fixes an issue with a shadowed variable > Patch 4 adds sizeof() operator instead of magic number for buffer length > Patch 5 fixes typos in diagnostics messages > Patch 6 explicitly sets unsigned char for bitwise operation > > v2: > - submit for net-next > - added Reviewed-by tags > - use u8* instead of char* as per Davide Caratti suggestion > > Roman Mashak (6): > net sched actions: fix coding style in pedit action > net sched actions: fix coding style in pedit headers > net sched actions: fix sparse warning > net sched actions: use sizeof operator for buffer length > net sched actions: fix misleading text strings in pedit action > net sched actions: avoid bitwise operation on signed value in pedit > > include/net/tc_act/tc_pedit.h | 1 + > include/uapi/linux/tc_act/tc_pedit.h | 9 ++++++-- > net/sched/act_pedit.c | 43 +++++++++++++++++++----------------- > 3 files changed, 31 insertions(+), 22 deletions(-) > for the series: Acked-by: Davide Caratti regards, -- davide