From: Joe Perches <joe@perches.com>
To: Dmitry Kravkov <dmitry@broadcom.com>
Cc: davem@davemloft.net, netdev@vger.kernel.org,
Eilon Greenstein <eilong@broadcom.com>
Subject: Re: [PATCH v2 net-next 07/12] bnx2x: simplify definition of RX_SGE_MASK_LEN and use it.
Date: Sun, 13 Nov 2011 05:10:45 -0800 [thread overview]
Message-ID: <1321189845.2069.4.camel@Joe-Laptop> (raw)
In-Reply-To: <1321188449-5822-8-git-send-email-dmitry@broadcom.com>
On Sun, 2011-11-13 at 14:47 +0200, Dmitry Kravkov wrote:
> diff --git a/drivers/net/ethernet/broadcom/bnx2x/bnx2x_cmn.h b/drivers/net/ethernet/broadcom/bnx2x/bnx2x_cmn.h
[]
> @@ -874,8 +874,7 @@ static inline void bnx2x_clear_sge_mask_next_elems(struct bnx2x_fastpath *fp)
> static inline void bnx2x_init_sge_ring_bit_mask(struct bnx2x_fastpath *fp)
> {
> /* Set the mask to all 1-s: it's faster to compare to 0 than to 0xf-s */
> - memset(fp->sge_mask, 0xff,
> - (NUM_RX_SGE >> BIT_VEC64_ELEM_SHIFT)*sizeof(u64));
> + memset(fp->sge_mask, 0xff, RX_SGE_MASK_LEN * sizeof(u64));
drivers/net/ethernet/broadcom/bnx2x/bnx2x.h:
u64 sge_mask[RX_SGE_MASK_LEN];
perhaps this is more readable as:
memset(fp->sge_mask, 0xff, sizeof(fp->sge_mask));
next prev parent reply other threads:[~2011-11-13 13:10 UTC|newest]
Thread overview: 15+ messages / expand[flat|nested] mbox.gz Atom feed top
2011-11-13 12:47 [PATCH v2 net-next 00/12] bnx2x series Dmitry Kravkov
2011-11-13 12:47 ` [PATCH v2 net-next 01/12] bnx2x: allow FCoE and DCB for 578xx Dmitry Kravkov
2011-11-13 12:47 ` [PATCH v2 net-next 02/12] bnx2x: use rx_queue index for skb_record_rx_queue() Dmitry Kravkov
2011-11-13 12:47 ` [PATCH v2 net-next 03/12] bnx2x: remove unused variable Dmitry Kravkov
2011-11-13 12:47 ` [PATCH v2 net-next 04/12] bnx2x: separate FCoE and iSCSI license initialization Dmitry Kravkov
2011-11-13 12:47 ` [PATCH v2 net-next 05/12] bnx2x: propagate DCBX negotiation Dmitry Kravkov
2011-11-13 12:47 ` [PATCH v2 net-next 06/12] bnx2x: DCBX: use #define instead of magic Dmitry Kravkov
2011-11-13 12:47 ` [PATCH v2 net-next 07/12] bnx2x: simplify definition of RX_SGE_MASK_LEN and use it Dmitry Kravkov
2011-11-13 13:10 ` Joe Perches [this message]
2011-11-13 13:37 ` Dmitry Kravkov
2011-11-13 12:47 ` [PATCH v2 net-next 08/12] bnx2x: remove unused #define Dmitry Kravkov
2011-11-13 12:47 ` [PATCH v2 net-next 09/12] bnx2x: add fan failure event handling Dmitry Kravkov
2011-11-13 12:47 ` [PATCH v2 net-next 10/12] bnx2x: prevent race in statistics flow Dmitry Kravkov
2011-11-13 12:47 ` [PATCH v2 net-next 11/12] bnx2x: Remove on-stack napi struct variable Dmitry Kravkov
2011-11-13 12:47 ` [PATCH v2 net-next 12/12] bnx2x: update driver version to 1.70.35-0 Dmitry Kravkov
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1321189845.2069.4.camel@Joe-Laptop \
--to=joe@perches.com \
--cc=davem@davemloft.net \
--cc=dmitry@broadcom.com \
--cc=eilong@broadcom.com \
--cc=netdev@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox