Netdev List
 help / color / mirror / Atom feed
From: "Michael Chan" <mchan@broadcom.com>
To: "Joe Perches" <joe@perches.com>
Cc: "Matt Carlson" <mcarlson@broadcom.com>,
	netdev@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 2/2] tg3: Use different macros for pci_chip_rev_id accesses
Date: Sat, 16 Feb 2013 14:09:45 -0800	[thread overview]
Message-ID: <1361052585.2240.4.camel@LTIRV-MCHAN1.corp.ad.broadcom.com> (raw)
In-Reply-To: <1d3ed7a644e8de210614f51375e8e913da2f5cb3.1361049158.git.joe@perches.com>

On Sat, 2013-02-16 at 13:20 -0800, Joe Perches wrote:
> Upper case macros for various chip attributes are slightly
> difficult to read and are a bit out of characterto the other
> tg3_<foo> attribute functions.
> 
> Convert:
> 
> GET_ASIC_REV(tp->pci_chip_rev_id)       -> tg3_asic_rev(tp)
> GET_CHIP_REV(tp->pci_chip_rev_id)       -> tg3_chip_rev(tp)
> 
> Remove:
> GET_METAL_REV(tp->pci_chip_rev_id)      -> tg3_metal_rev(tp) (unused)
> 
> Add:
> tg3_chip_rev_id(tp) for tp->pci_chip_rev_id so access styles
> are similar to tg3_asic_rev and tg3_chip_rev.
> 
> These macros are not converted to static inline functions
> because gcc (tested with 4.7.2) is currently unable to
> optimize the object code it produces the same way and code
> is otherwise larger.
> 
> Signed-off-by: Joe Perches <joe@perches.com> 

Acked-by: Michael Chan <mchan@broadcom.com>

  reply	other threads:[~2013-02-16 22:09 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-02-16 21:20 [PATCH 1/2] tg3: Remove define and single use of GET_CHIP_REV_ID Joe Perches
2013-02-16 21:20 ` [PATCH 2/2] tg3: Use different macros for pci_chip_rev_id accesses Joe Perches
2013-02-16 22:09   ` Michael Chan [this message]
2013-02-18 17:46     ` David Miller
2013-02-16 21:44 ` [PATCH 1/2] tg3: Remove define and single use of GET_CHIP_REV_ID Michael Chan
2013-02-18 17:46   ` David Miller

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1361052585.2240.4.camel@LTIRV-MCHAN1.corp.ad.broadcom.com \
    --to=mchan@broadcom.com \
    --cc=joe@perches.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mcarlson@broadcom.com \
    --cc=netdev@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox