From: Jiri Pirko <jiri@resnulli.us>
To: netdev@vger.kernel.org
Cc: davem@davemloft.net, jhs@mojatatu.com, tgraf@suug.ch,
jesse@nicira.com, kaber@trash.net, therbert@google.com,
edumazet@google.com, alexander.h.duyck@redhat.com,
hannes@stressinduktion.org, ast@plumgrid.com,
daniel@iogearbox.net, herbert@gondor.apana.org.au,
cwang@twopensource.com, john.fastabend@gmail.com
Subject: [patch net-next v4 RFC 14/15] flow_dissector: change port array into src,dst tuple
Date: Fri, 24 Apr 2015 17:51:40 +0200 [thread overview]
Message-ID: <1429890701-30052-15-git-send-email-jiri@resnulli.us> (raw)
In-Reply-To: <1429890701-30052-1-git-send-email-jiri@resnulli.us>
Signed-off-by: Jiri Pirko <jiri@resnulli.us>
---
drivers/net/ethernet/cisco/enic/enic_clsf.c | 4 ++--
drivers/net/ethernet/cisco/enic/enic_ethtool.c | 4 ++--
include/net/flow_dissector.h | 9 ++++++---
include/net/ip.h | 4 ++--
include/net/ipv6.h | 4 ++--
net/core/flow_dissector.c | 4 ++--
net/sched/cls_flow.c | 4 ++--
7 files changed, 18 insertions(+), 15 deletions(-)
diff --git a/drivers/net/ethernet/cisco/enic/enic_clsf.c b/drivers/net/ethernet/cisco/enic/enic_clsf.c
index d3d25c7..6739ebc 100644
--- a/drivers/net/ethernet/cisco/enic/enic_clsf.c
+++ b/drivers/net/ethernet/cisco/enic/enic_clsf.c
@@ -35,8 +35,8 @@ int enic_addfltr_5t(struct enic *enic, struct flow_keys *keys, u16 rq)
data.type = FILTER_IPV4_5TUPLE;
data.u.ipv4.src_addr = ntohl(keys->addrs.src);
data.u.ipv4.dst_addr = ntohl(keys->addrs.dst);
- data.u.ipv4.src_port = ntohs(keys->ports.port16[0]);
- data.u.ipv4.dst_port = ntohs(keys->ports.port16[1]);
+ data.u.ipv4.src_port = ntohs(keys->ports.src);
+ data.u.ipv4.dst_port = ntohs(keys->ports.dst);
data.u.ipv4.flags = FILTER_FIELDS_IPV4_5TUPLE;
spin_lock_bh(&enic->devcmd_lock);
diff --git a/drivers/net/ethernet/cisco/enic/enic_ethtool.c b/drivers/net/ethernet/cisco/enic/enic_ethtool.c
index 7588f8d..117c096 100644
--- a/drivers/net/ethernet/cisco/enic/enic_ethtool.c
+++ b/drivers/net/ethernet/cisco/enic/enic_ethtool.c
@@ -352,10 +352,10 @@ static int enic_grxclsrule(struct enic *enic, struct ethtool_rxnfc *cmd)
fsp->h_u.tcp_ip4_spec.ip4dst = n->keys.addrs.dst;
fsp->m_u.tcp_ip4_spec.ip4dst = (__u32)~0;
- fsp->h_u.tcp_ip4_spec.psrc = n->keys.ports.port16[0];
+ fsp->h_u.tcp_ip4_spec.psrc = n->keys.ports.src;
fsp->m_u.tcp_ip4_spec.psrc = (__u16)~0;
- fsp->h_u.tcp_ip4_spec.pdst = n->keys.ports.port16[1];
+ fsp->h_u.tcp_ip4_spec.pdst = n->keys.ports.dst;
fsp->m_u.tcp_ip4_spec.pdst = (__u16)~0;
fsp->ring_cookie = n->rq_id;
diff --git a/include/net/flow_dissector.h b/include/net/flow_dissector.h
index 1fa625b..f7bebb4 100644
--- a/include/net/flow_dissector.h
+++ b/include/net/flow_dissector.h
@@ -34,13 +34,16 @@ struct flow_dissector_key_addrs {
/**
* flow_dissector_key_tp_ports:
* @ports: port numbers of Transport header
- * port16[0]: src port number
- * port16[1]: dst port number
+ * src: source port number
+ * dst: destination port number
*/
struct flow_dissector_key_ports {
union {
__be32 ports;
- __be16 port16[2];
+ struct {
+ __be16 src;
+ __be16 dst;
+ };
};
};
diff --git a/include/net/ip.h b/include/net/ip.h
index b0443d4..0ed6d76 100644
--- a/include/net/ip.h
+++ b/include/net/ip.h
@@ -362,8 +362,8 @@ static inline void inet_set_txhash(struct sock *sk)
keys.addrs.src = inet->inet_saddr;
keys.addrs.dst = inet->inet_daddr;
- keys.ports.port16[0] = inet->inet_sport;
- keys.ports.port16[1] = inet->inet_dport;
+ keys.ports.src = inet->inet_sport;
+ keys.ports.dst = inet->inet_dport;
sk->sk_txhash = flow_hash_from_keys(&keys);
}
diff --git a/include/net/ipv6.h b/include/net/ipv6.h
index 14cd04f..54d03a6 100644
--- a/include/net/ipv6.h
+++ b/include/net/ipv6.h
@@ -698,8 +698,8 @@ static inline void ip6_set_txhash(struct sock *sk)
keys.addrs.src = (__force __be32)ipv6_addr_hash(&np->saddr);
keys.addrs.dst = (__force __be32)ipv6_addr_hash(&sk->sk_v6_daddr);
- keys.ports.port16[0] = inet->inet_sport;
- keys.ports.port16[1] = inet->inet_dport;
+ keys.ports.src = inet->inet_sport;
+ keys.ports.dst = inet->inet_dport;
sk->sk_txhash = flow_hash_from_keys(&keys);
}
diff --git a/net/core/flow_dissector.c b/net/core/flow_dissector.c
index b5e260e..aa48eea 100644
--- a/net/core/flow_dissector.c
+++ b/net/core/flow_dissector.c
@@ -386,9 +386,9 @@ static inline u32 __flow_hash_from_keys(struct flow_keys *keys)
/* get a consistent hash (same value on both flow directions) */
if (((__force u32)keys->addrs.dst < (__force u32)keys->addrs.src) ||
(((__force u32)keys->addrs.dst == (__force u32)keys->addrs.src) &&
- ((__force u16)keys->ports.port16[1] < (__force u16)keys->ports.port16[0]))) {
+ ((__force u16)keys->ports.dst < (__force u16)keys->ports.src))) {
swap(keys->addrs.dst, keys->addrs.src);
- swap(keys->ports.port16[0], keys->ports.port16[1]);
+ swap(keys->ports.src, keys->ports.dst);
}
hash = __flow_hash_3words((__force u32)keys->addrs.dst,
diff --git a/net/sched/cls_flow.c b/net/sched/cls_flow.c
index 4b3e3e3..b435992 100644
--- a/net/sched/cls_flow.c
+++ b/net/sched/cls_flow.c
@@ -88,7 +88,7 @@ static u32 flow_get_proto(const struct sk_buff *skb, const struct flow_keys *flo
static u32 flow_get_proto_src(const struct sk_buff *skb, const struct flow_keys *flow)
{
if (flow->ports.ports)
- return ntohs(flow->ports.port16[0]);
+ return ntohs(flow->ports.src);
return addr_fold(skb->sk);
}
@@ -96,7 +96,7 @@ static u32 flow_get_proto_src(const struct sk_buff *skb, const struct flow_keys
static u32 flow_get_proto_dst(const struct sk_buff *skb, const struct flow_keys *flow)
{
if (flow->ports.ports)
- return ntohs(flow->ports.port16[1]);
+ return ntohs(flow->ports.dst);
return addr_fold(skb_dst(skb)) ^ (__force u16) tc_skb_protocol(skb);
}
--
1.9.3
next prev parent reply other threads:[~2015-04-24 15:52 UTC|newest]
Thread overview: 21+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-04-24 15:51 [patch net-next v4 RFC 00/15] introduce programable flow dissector and cls_flower Jiri Pirko
2015-04-24 15:51 ` [patch net-next v4 RFC 01/15] net: change name of flow_dissector header to match the .c file name Jiri Pirko
2015-04-24 15:51 ` [patch net-next v4 RFC 02/15] flow_dissector: remove unused function flow_get_hlen declaration Jiri Pirko
2015-04-24 15:51 ` [patch net-next v4 RFC 03/15] net: move *skb_get_poff declarations into correct header Jiri Pirko
2015-04-24 15:51 ` [patch net-next v4 RFC 04/15] flow_dissector: fix doc for __skb_get_hash and remove couple of empty lines Jiri Pirko
2015-04-24 15:51 ` [patch net-next v4 RFC 05/15] net: move __skb_get_hash function declaration to flow_dissector.h Jiri Pirko
2015-04-24 15:51 ` [patch net-next v4 RFC 06/15] net: move __skb_tx_hash to skbuff.c Jiri Pirko
2015-04-24 15:51 ` [patch net-next v4 RFC 07/15] net: move netdev_pick_tx and dependencies to net/core/dev.c Jiri Pirko
2015-04-24 15:51 ` [patch net-next v4 RFC 08/15] flow_dissector: fix doc for skb_get_poff Jiri Pirko
2015-04-24 15:51 ` [patch net-next v4 RFC 09/15] flow_dissector: introduce programable flow_dissector Jiri Pirko
2015-04-24 15:51 ` [patch net-next v4 RFC 10/15] flow_dissect: use programable dissector in skb_flow_dissect and friends Jiri Pirko
2015-04-24 15:51 ` [patch net-next v4 RFC 11/15] flow_dissector: add missing header includes Jiri Pirko
2015-04-24 15:51 ` [patch net-next v4 RFC 12/15] flow_dissector: introduce support for ipv6 addressses Jiri Pirko
2015-04-24 17:28 ` Tom Herbert
2015-04-25 19:17 ` Jiri Pirko
2015-04-24 15:51 ` [patch net-next v4 RFC 13/15] flow_dissector: introduce support for Ethernet addresses Jiri Pirko
2015-04-24 15:51 ` Jiri Pirko [this message]
2015-04-24 15:51 ` [patch net-next v4 RFC 15/15] tc: introduce Flower classifier Jiri Pirko
2015-04-26 19:55 ` [patch net-next v4 RFC 00/15] introduce programable flow dissector and cls_flower Or Gerlitz
2015-04-26 19:57 ` Or Gerlitz
2015-04-26 23:33 ` Tom Herbert
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1429890701-30052-15-git-send-email-jiri@resnulli.us \
--to=jiri@resnulli.us \
--cc=alexander.h.duyck@redhat.com \
--cc=ast@plumgrid.com \
--cc=cwang@twopensource.com \
--cc=daniel@iogearbox.net \
--cc=davem@davemloft.net \
--cc=edumazet@google.com \
--cc=hannes@stressinduktion.org \
--cc=herbert@gondor.apana.org.au \
--cc=jesse@nicira.com \
--cc=jhs@mojatatu.com \
--cc=john.fastabend@gmail.com \
--cc=kaber@trash.net \
--cc=netdev@vger.kernel.org \
--cc=tgraf@suug.ch \
--cc=therbert@google.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox