From mboxrd@z Thu Jan 1 00:00:00 1970 From: Roman Mashak Subject: [PATCH v2 net-next 0/6] net sched actions: code style cleanup and fixes Date: Wed, 27 Jun 2018 13:33:29 -0400 Message-ID: <1530120815-13736-1-git-send-email-mrv@mojatatu.com> Cc: netdev@vger.kernel.org, kernel@mojatatu.com, jhs@mojatatu.com, xiyou.wangcong@gmail.com, jiri@resnulli.us, Roman Mashak To: davem@davemloft.net Return-path: Received: from mail-it0-f66.google.com ([209.85.214.66]:40200 "EHLO mail-it0-f66.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S965055AbeF0Rds (ORCPT ); Wed, 27 Jun 2018 13:33:48 -0400 Received: by mail-it0-f66.google.com with SMTP id 188-v6so8584310ita.5 for ; Wed, 27 Jun 2018 10:33:48 -0700 (PDT) Sender: netdev-owner@vger.kernel.org List-ID: The patchset fixes a few code stylistic issues and typos, as well as one detected by sparse semantic checker tool. No functional changes introduced. Patch 1 & 2 fix coding style bits caught by the checkpatch.pl script Patch 3 fixes an issue with a shadowed variable Patch 4 adds sizeof() operator instead of magic number for buffer length Patch 5 fixes typos in diagnostics messages Patch 6 explicitly sets unsigned char for bitwise operation v2: - submit for net-next - added Reviewed-by tags - use u8* instead of char* as per Davide Caratti suggestion Roman Mashak (6): net sched actions: fix coding style in pedit action net sched actions: fix coding style in pedit headers net sched actions: fix sparse warning net sched actions: use sizeof operator for buffer length net sched actions: fix misleading text strings in pedit action net sched actions: avoid bitwise operation on signed value in pedit include/net/tc_act/tc_pedit.h | 1 + include/uapi/linux/tc_act/tc_pedit.h | 9 ++++++-- net/sched/act_pedit.c | 43 +++++++++++++++++++----------------- 3 files changed, 31 insertions(+), 22 deletions(-) -- 2.7.4