From: Markus Pargmann <mpa@pengutronix.de>
To: kernel@pengutronix.de
Cc: Kurt Van Dijck <dev.kurt@vandijck-laurijssen.be>,
Michael Grzeschik <m.grzeschik@pengutronix.de>,
netdev@vger.kernel.org, linux-kernel@vger.kernel.org,
linux-can@vger.kernel.org, mkl@pengutronix.de, wg@grandegger.com
Subject: Re: [PATCH v2] can: c_can: add xceiver enable/disable support
Date: Wed, 20 Jan 2016 15:29:14 +0100 [thread overview]
Message-ID: <1712225.zGdy6Arcqk@adelgunde> (raw)
In-Reply-To: <20160120141151.GA626@airbook.eia.lan>
[-- Attachment #1: Type: text/plain, Size: 1481 bytes --]
Hi,
On Wednesday 20 January 2016 15:11:51 Kurt Van Dijck wrote:
>
> > diff --git a/drivers/net/can/c_can/c_can.c b/drivers/net/can/c_can/c_can.c
> > index f91b094..0723aeb 100644
> > --- a/drivers/net/can/c_can/c_can.c
> > +++ b/drivers/net/can/c_can/c_can.c
> > @@ -1263,6 +1271,10 @@ int register_c_can_dev(struct net_device *dev)
> > */
> > pinctrl_pm_select_sleep_state(dev->dev.parent);
> >
> > + priv->reg_xceiver = devm_regulator_get(priv->device, "xceiver");
>
> I assume "xceiver" is the shorter name for "transceiver"?
> In that case, I suggest changing the devicetree label to "transceiver".
> It would become a mess if different drivers use different names.
> I see no real benefit for naming it "xceiver". "trx" is even shorter :-)
> See also http://www.acronymfinder.com/TRX.html
>
> The internals, like variable names, do not really matter here.
>
> I haven't looked at other driver, yet the argument still stands.
Oh right and perhaps it is necessary to add some documentation for the
devicetree binding if it is not generic already? In that case the DT
mailing list is missing as well.
Best Regards,
Markus
--
Pengutronix e.K. | |
Industrial Linux Solutions | http://www.pengutronix.de/ |
Peiner Str. 6-8, 31137 Hildesheim, Germany | Phone: +49-5121-206917-0 |
Amtsgericht Hildesheim, HRA 2686 | Fax: +49-5121-206917-5555 |
[-- Attachment #2: This is a digitally signed message part. --]
[-- Type: application/pgp-signature, Size: 819 bytes --]
next prev parent reply other threads:[~2016-01-20 14:29 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-01-20 13:44 [PATCH v2] can: c_can: add xceiver enable/disable support Michael Grzeschik
2016-01-20 14:01 ` Markus Pargmann
2016-01-20 14:11 ` Kurt Van Dijck
2016-01-20 14:29 ` Marc Kleine-Budde
2016-01-20 14:29 ` Markus Pargmann [this message]
2016-01-20 16:19 ` Bjørn Mork
2016-01-20 16:46 ` Michael Grzeschik
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1712225.zGdy6Arcqk@adelgunde \
--to=mpa@pengutronix.de \
--cc=dev.kurt@vandijck-laurijssen.be \
--cc=kernel@pengutronix.de \
--cc=linux-can@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=m.grzeschik@pengutronix.de \
--cc=mkl@pengutronix.de \
--cc=netdev@vger.kernel.org \
--cc=wg@grandegger.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox