From: David Miller <davem@davemloft.net>
To: ebiederm@xmission.com
Cc: netdev@vger.kernel.org, den@openvz.org, benjamin.thery@bull.net
Subject: Re: [patch net-2.6.25 1/2][NETNS] net: Modify the neighbour table code so it handles multiple network namespaces
Date: Mon, 24 Dec 2007 15:56:22 -0800 (PST) [thread overview]
Message-ID: <20071224.155622.05258191.davem@davemloft.net> (raw)
In-Reply-To: <20071221131601.818555294@ICON-9-164-138-215.megacenter.de.ibm.com>
From: Eric.W.Biederman" <ebiederm@xmission.com>"@fr.ibm.com
Date: Fri, 21 Dec 2007 14:02:24 +0100
> I'm actually surprised at how much was involved. At first glance it appears
> that the neighbour table data structures are already split by network device
> so all that should be needed is to modify the user interface commands
> to filter the set of neighbours by the network namespace of their devices.
>
> However a couple things turned up while I was reading through the code.
> The proxy neighbour table allows entries with no network device, and
> the neighbour parms are per network device (except for the defaults)
> so they now need a per network namespace default.
>
> So I updated the two structures (which surprised me) with their very
> own network namespace parameter. Updated the relevant lookup and
> destroy routines with a network namespace parameter and modified
> the code that interacts with users to filter out neighbour
> table entries for devices of other namespaces.
>
> I'm a little concerned that we can modify and display the global
> table configuration and from all network namespaces. But
> this appears good enough for now.
>
> I keep thinking modifying the neighbour table to have per network
> namespace instances of each table type would should be cleaner. The
> hash table is already dynamically sized so there are it is not a limiter.
> The default parameter would be straight forward to take care of. However
> when I look at the how the network table is built and used I still find
> some assumptions that there is only a single neighbour table for each
> type of table in the kernel. The netlink operations, neigh_seq_start,
> the non-core network users that call neigh_lookup. So while it might
> be doable it would require more refactoring than my current approach
> of just doing a little extra filtering in the code.
>
> Signed-off-by: Eric W. Biederman <ebiederm@xmission.com>
> Signed-off-by: Daniel Lezcano <dlezcano@fr.ibm.com>
Applied, thanks.
next parent reply other threads:[~2007-12-24 23:56 UTC|newest]
Thread overview: 3+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <20071221130223.348101205@ICON-9-164-138-215.megacenter.de.ibm.com>
[not found] ` <20071221131601.818555294@ICON-9-164-138-215.megacenter.de.ibm.com>
2007-12-24 23:56 ` David Miller [this message]
[not found] ` <20071221131606.284066116@ICON-9-164-138-215.megacenter.de.ibm.com>
2007-12-24 23:56 ` [patch net-2.6.25 2/2][NETNS] net: Add a helper function neigh_param_default_alloc David Miller
2007-12-21 13:59 [patch net-2.6.25 0/2][NETNS] prepare the neigh subsys to handle network namespaces v2 Daniel Lezcano
2007-12-21 13:59 ` [patch net-2.6.25 1/2][NETNS] net: Modify the neighbour table code so it handles multiple network namespaces Daniel Lezcano
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20071224.155622.05258191.davem@davemloft.net \
--to=davem@davemloft.net \
--cc=benjamin.thery@bull.net \
--cc=den@openvz.org \
--cc=ebiederm@xmission.com \
--cc=netdev@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox