From: David Miller <davem@davemloft.net>
To: ordex@autistici.org
Cc: netdev@vger.kernel.org, b.a.t.m.a.n@lists.open-mesh.org
Subject: Re: pull request: batman-adv 2013-01-19
Date: Sat, 19 Jan 2013 10:50:17 -0500 (EST) [thread overview]
Message-ID: <20130119.105017.886816855929937540.davem@davemloft.net> (raw)
In-Reply-To: <1358602079-24024-1-git-send-email-ordex@autistici.org>
From: Antonio Quartulli <ordex@autistici.org>
Date: Sat, 19 Jan 2013 21:27:46 +0800
> here is our second patchset intended for net-next/linux-3.9.
> In this batch you have some struct refactoring and a great kernel doc
> improvement by Marek Lindner. In patch 10/13 you have the random32() function
> renaming proposed by Akinobu Mita.
>
> In 11/13 instead you have a behavioural change brought by Simon Wunderlich which
> is modifying the way a batman-adv virtual interface is unregistered in order to
> prevent a possible deadlock involving rntl_lock and s_active. We have
> already been discussing about this problem and its possible solution on the
> netdev mailing list.
> The rest is just clean up work.
>
> Please pull or let me know if there is any problem.
Pulled, thanks Antonio.
prev parent reply other threads:[~2013-01-19 15:50 UTC|newest]
Thread overview: 15+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-01-19 13:27 pull request: batman-adv 2013-01-19 Antonio Quartulli
2013-01-19 13:27 ` [PATCH 01/13] batman-adv: a delayed_work has to be initialised once Antonio Quartulli
2013-01-19 13:27 ` [PATCH 02/13] batman-adv: align kernel doc properly Antonio Quartulli
2013-01-19 13:27 ` [PATCH 03/13] batman-adv: mark debug_log struct as bat_priv only struct Antonio Quartulli
2013-01-19 13:27 ` [PATCH 04/13] batman-adv: group tt type definitions together Antonio Quartulli
2013-01-19 13:27 ` [PATCH 05/13] batman-adv: rename batadv_if_list_entry struct to make clear it is used by vis Antonio Quartulli
2013-01-19 13:27 ` [PATCH 06/13] batman-adv: rename batadv_recvlist_node " Antonio Quartulli
2013-01-19 13:27 ` [PATCH 07/13] batman-adv: rename batadv_backbone_gw struct to make clear it is used by bla Antonio Quartulli
2013-01-19 13:27 ` [PATCH 08/13] batman-adv: rename batadv_claim " Antonio Quartulli
2013-01-19 13:27 ` [PATCH 09/13] batman-adv: kernel doc for types.h Antonio Quartulli
2013-01-19 13:27 ` [PATCH 10/13] batman-adv: rename random32() to prandom_u32() Antonio Quartulli
2013-01-19 13:27 ` [PATCH 11/13] batman-adv: postpone sysfs removal when unregistering Antonio Quartulli
2013-01-19 13:27 ` [PATCH 12/13] batman-adv: update copyright years Antonio Quartulli
2013-01-19 13:27 ` [PATCH 13/13] batman-adv: Start new development cycle Antonio Quartulli
2013-01-19 15:50 ` David Miller [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20130119.105017.886816855929937540.davem@davemloft.net \
--to=davem@davemloft.net \
--cc=b.a.t.m.a.n@lists.open-mesh.org \
--cc=netdev@vger.kernel.org \
--cc=ordex@autistici.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox