From: Alexander Duyck <alexander.h.duyck@redhat.com>
To: netdev@vger.kernel.org
Cc: davem@davemloft.net
Subject: [net-next PATCH 5/9] fib_trie: Add tnode struct as a container for fields not needed in key_vector
Date: Thu, 05 Mar 2015 14:51:00 -0800 [thread overview]
Message-ID: <20150305225100.1642.67688.stgit@ahduyck-vm-fedora20> (raw)
In-Reply-To: <20150305224208.1642.34205.stgit@ahduyck-vm-fedora20>
This change pulls the fields not explicitly needed in the key_vector and
placed them in the new tnode structure. By doing this we will eventually
be able to reduce the key_vector down to 16 bytes on 64 bit systems, and
12 bytes on 32 bit systems.
Signed-off-by: Alexander Duyck <alexander.h.duyck@redhat.com>
---
net/ipv4/fib_trie.c | 72 ++++++++++++++++++++++++++++-----------------------
1 file changed, 39 insertions(+), 33 deletions(-)
diff --git a/net/ipv4/fib_trie.c b/net/ipv4/fib_trie.c
index f06c92e..5e1c469 100644
--- a/net/ipv4/fib_trie.c
+++ b/net/ipv4/fib_trie.c
@@ -110,7 +110,11 @@ struct key_vector {
};
};
-#define TNODE_SIZE(n) offsetof(struct key_vector, tnode[n])
+struct tnode {
+ struct key_vector kv[1];
+};
+
+#define TNODE_SIZE(n) offsetof(struct tnode, kv[0].tnode[n])
#define LEAF_SIZE TNODE_SIZE(1)
#ifdef CONFIG_IP_FIB_TRIE_STATS
@@ -287,7 +291,7 @@ static void __node_free_rcu(struct rcu_head *head)
#define node_free(n) call_rcu(&n->rcu, __node_free_rcu)
-static struct key_vector *tnode_alloc(int bits)
+static struct tnode *tnode_alloc(int bits)
{
size_t size;
@@ -316,48 +320,50 @@ static inline void empty_child_dec(struct key_vector *n)
static struct key_vector *leaf_new(t_key key, struct fib_alias *fa)
{
- struct key_vector *l = kmem_cache_alloc(trie_leaf_kmem, GFP_KERNEL);
- if (l) {
- l->parent = NULL;
- /* set key and pos to reflect full key value
- * any trailing zeros in the key should be ignored
- * as the nodes are searched
- */
- l->key = key;
- l->slen = fa->fa_slen;
- l->pos = 0;
- /* set bits to 0 indicating we are not a tnode */
- l->bits = 0;
-
- /* link leaf to fib alias */
- INIT_HLIST_HEAD(&l->leaf);
- hlist_add_head(&fa->fa_list, &l->leaf);
- }
+ struct tnode *kv = kmem_cache_alloc(trie_leaf_kmem, GFP_KERNEL);
+ struct key_vector *l = kv->kv;
+
+ if (!kv)
+ return NULL;
+
+ /* initialize key vector */
+ l->key = key;
+ l->pos = 0;
+ l->bits = 0;
+ l->slen = fa->fa_slen;
+
+ /* link leaf to fib alias */
+ INIT_HLIST_HEAD(&l->leaf);
+ hlist_add_head(&fa->fa_list, &l->leaf);
+
return l;
}
static struct key_vector *tnode_new(t_key key, int pos, int bits)
{
- struct key_vector *tn = tnode_alloc(bits);
+ struct tnode *tnode = tnode_alloc(bits);
unsigned int shift = pos + bits;
+ struct key_vector *tn = tnode->kv;
/* verify bits and pos their msb bits clear and values are valid */
BUG_ON(!bits || (shift > KEYLENGTH));
- if (tn) {
- tn->parent = NULL;
- tn->slen = pos;
- tn->pos = pos;
- tn->bits = bits;
- tn->key = (shift < KEYLENGTH) ? (key >> shift) << shift : 0;
- if (bits == KEYLENGTH)
- tn->full_children = 1;
- else
- tn->empty_children = 1ul << bits;
- }
-
- pr_debug("AT %p s=%zu %zu\n", tn, TNODE_SIZE(0),
+ pr_debug("AT %p s=%zu %zu\n", tnode, TNODE_SIZE(0),
sizeof(struct key_vector *) << bits);
+
+ if (!tnode)
+ return NULL;
+
+ if (bits == KEYLENGTH)
+ tn->full_children = 1;
+ else
+ tn->empty_children = 1ul << bits;
+
+ tn->key = (shift < KEYLENGTH) ? (key >> shift) << shift : 0;
+ tn->pos = pos;
+ tn->bits = bits;
+ tn->slen = pos;
+
return tn;
}
next prev parent reply other threads:[~2015-03-05 22:51 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-03-05 22:50 [net-next PATCH 0/9] The rest of the FIB patches (add key_vector to fib_table) Alexander Duyck
2015-03-05 22:50 ` [net-next PATCH 1/9] fib_trie: Return pointer to tnode pointer in resize/inflate/halve Alexander Duyck
2015-03-05 22:50 ` [net-next PATCH 2/9] fib_trie: Rename tnode to key_vector Alexander Duyck
2015-03-05 22:50 ` [net-next PATCH 3/9] fib_trie: replace tnode_get_child functions with get_child macros Alexander Duyck
2015-03-05 22:50 ` [net-next PATCH 4/9] fib_trie: Rename tnode_child_length to child_length Alexander Duyck
2015-03-05 22:51 ` Alexander Duyck [this message]
2015-03-06 13:17 ` [net-next PATCH 5/9] fib_trie: Add tnode struct as a container for fields not needed in key_vector Sergei Shtylyov
2015-03-06 16:13 ` Alexander Duyck
2015-03-05 22:51 ` [net-next PATCH 6/9] fib_trie: Move rcu from key_vector to tnode, add accessors Alexander Duyck
2015-03-05 22:51 ` [net-next PATCH 7/9] fib_trie: Pull empty_children and full_children into tnode Alexander Duyck
2015-03-05 22:51 ` [net-next PATCH 8/9] fib_trie: Move parent from key_vector to tnode Alexander Duyck
2015-03-05 22:51 ` [net-next PATCH 9/9] fib_trie: Add key vector to root, return parent key_vector in resize Alexander Duyck
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20150305225100.1642.67688.stgit@ahduyck-vm-fedora20 \
--to=alexander.h.duyck@redhat.com \
--cc=davem@davemloft.net \
--cc=netdev@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox