From mboxrd@z Thu Jan 1 00:00:00 1970 From: Jiri Pirko Subject: Re: [patch net-next v3 00/10] switchdev: transaction item queue and cleanup Date: Fri, 25 Sep 2015 08:04:29 +0200 Message-ID: <20150925060429.GA2148@nanopsycho.orion> References: <1443081769-11193-1-git-send-email-jiri@resnulli.us> <20150924.230013.2108843761593380405.davem@davemloft.net> Mime-Version: 1.0 Content-Type: text/plain; charset=us-ascii Cc: sfeldma@gmail.com, netdev@vger.kernel.org, idosch@mellanox.com, eladr@mellanox.com, f.fainelli@gmail.com, linux@roeck-us.net, vivien.didelot@savoirfairelinux.com, rami.rosen@intel.com, roopa@cumulusnetworks.com, pjonnala@broadcom.com, andrew@lunn.ch, gospo@cumulusnetworks.com To: David Miller Return-path: Received: from mail-wi0-f171.google.com ([209.85.212.171]:38589 "EHLO mail-wi0-f171.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751564AbbIYGEb (ORCPT ); Fri, 25 Sep 2015 02:04:31 -0400 Received: by wiclk2 with SMTP id lk2so5495558wic.1 for ; Thu, 24 Sep 2015 23:04:30 -0700 (PDT) Content-Disposition: inline In-Reply-To: <20150924.230013.2108843761593380405.davem@davemloft.net> Sender: netdev-owner@vger.kernel.org List-ID: Fri, Sep 25, 2015 at 08:00:13AM CEST, davem@davemloft.net wrote: >From: Scott Feldman >Date: Thu, 24 Sep 2015 20:05:39 -0700 > >> On Thu, Sep 24, 2015 at 1:02 AM, Jiri Pirko wrote: >>> From: Jiri Pirko >>> >>> Jiri Pirko (10): >>> switchdev: rename "trans" to "trans_ph". >>> switchdev: introduce transaction item queue for attr_set and obj_add >>> switchdev: move transaction phase enum under transaction structure >>> switchdev: add switchdev_trans_ph_prepare/commit helpers >>> rocker: push struct switchdev_trans down through rocker code >>> rocker: use switchdev transaction queue for allocated memory >>> switchdev: remove "NONE" transaction phase >>> switchdev: remove "ABORT" transaction phase >>> dsa: use prepare/commit switchdev transaction helpers >>> switchdev: reduce transaction phase enum down to a boolean >>> >>> Documentation/networking/switchdev.txt | 19 ++ >>> drivers/net/ethernet/rocker/rocker.c | 308 ++++++++++++++------------------- >>> include/net/switchdev.h | 40 +++-- >>> net/dsa/slave.c | 31 ++-- >>> net/switchdev/switchdev.c | 125 ++++++++++--- >>> 5 files changed, 296 insertions(+), 227 deletions(-) >> >> Tests pass. ACK on all. >> >> Acked-by: Scott Feldman > >Series applied, thanks everyone. > >But Jiri, in the future you really have to give me more "meat" in this >00/10 posting. You have to provide some description of what your >changes are doing at a high level and why. I thought that in this case it is enough to have descriptions in separate patches. Anyway, will try to write some story to the cover letter next time. Thanks.